Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

SOLVED
Go to solution
Art Wiens
Respected Contributor

Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

Just before I waste my time ... perhaps someone has wasted theirs ;-)

Can a locally restored image copy of the VMS v8.3 cd (on a SCSI disk on an ES47) be upgraded/patched so that it can mount Phase II Shadow Sets, or is there any way around:

$$$ $ MOUNT DSA1: /SHADOW=($1$DGA306:,$1$DGA307:,$1$DGA309:) -
_$$$ EVA_DSA1 DISK$EVA_DSA1 -
_$$$ /SYSTEM /POLICY=MINICOPY=OPTIONAL
%MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

$$$ MOUNT DSA1: /SHADOW=($1$DGA306:,$1$DGA307:,$1$DGA309:) -
_$$$ EVA_DSA1 DISK$EVA_DSA1
%MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

$$$ mount $1$dga306: eva_dsa1
%MOUNT-I-OPRQST, incorrect volume label
%MOUNT-I-NOOPR, no operator available to service request
%MOUNT-I-OPRQST, Please mount volume EVA_DSA1 in device _$1$DGA306: ()
%MOUNT-I-NOOPR, no operator available to service request

Cheers,
Art
10 REPLIES
Hoff
Honored Contributor
Solution

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

It's likely that you already know how to deal with the baseline OpenVMS stuff involved here, so I'm wondering what part of the question I'm missing.

As for the literal question, yes, I expect so (I've certainly tweaked and remastered enough kits over the years, and for various purposes, and OpenVMS Alpha CDs are slightly easier to regenerate than are the OpenVMS I64 El Torito DVDs) but what are you up to here that requires a CD (or a copy of a CD disk) to mount shadowed disks?

As for the error and the recovery process:

NOSHADOW, VMS Volume Shadowing Phase II is not enabled

Facility: MOUNT, Mount Utility

Explanation: The OpenVMS Volume Shadowing software is not enabled.

User Action: The system manager must reboot the system with SYSGEN
parameter SHADOWING set to 2.

Jan van den Ende
Honored Contributor

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

So, Hoff, if I interpret this correctly:

Boot conversationally from CD/DVD
SYSBOOT> SET SHADOWING 2
SYSBOOT> CONT

would do the trick?

Proost.

Have one on me.

jpe
Don't rust yours pelled jacker to fine doll missed aches.
Volker Halle
Honored Contributor

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

Art,

aside from the system parameter, you might also need a VOLSHAD license...

You can definitely mount individual members. Either write-locked (by default), so the SCB is not disturbed or with MOUNT/OVER=(SHAD,ID) $1$DGAx:, but then you will incur shadow-copies when re-mounting the complete shadowset afterwards.

Your mount-command of the $1$DGA306: member has most likely had the wrong label specified, try again with MOUNT/OVER=ID $1$DGA306: or with a MOUNT/FOR first to obtain the correct volume label.

Volker.
Steven Schweda
Honored Contributor

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

> %MOUNT-I-NOOPR, no operator available to service request

MOUNT /NOASSIST might be (slightly) helpful,
too.
Art Wiens
Respected Contributor

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

I though Phase II shadowing was introduced with a patch, ie. it was not available natively with v8.3. I also thought the Shadowing parameter was set the last time I tried this ... obviously not.

So with a cd image restored and SHADOWING set to 2, my attempted mount of the shadow set "hangs". I let it sit for 5 minutes or so and couldn't ctrl-c out of it. ctrl-p "worked" ;-)

I will attempt patching the restored cd image.

Cheers,
Art
Art Wiens
Respected Contributor

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

ps. there doesn't seem to be a license database and yes I also had the wrong volume label for the Shadow set. These were from another installation that I thought I had updated.

Art
Robert Brooks_1
Honored Contributor

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

The SHADOW_SERVER process must be running to mount a shadow set, even a single-member set.

This requirement came about as part of the work done for host-based minimerge (HBMM). I don't know if this process is started by default when booting from a CD; it's likely that it does not start unless SHADOWING is non-zero.

There is no "patch" needed to enable shadowing; as a "SIP" (system integrated product), the bits are shipped as part of the release.

-- Rob
Hoff
Honored Contributor

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

The VOLSHAD PAK and the shadowing parameters and quite possible the cluster settings and the non-writable system disk (CD and DVD disks have a system parameter setting which indicates the disk is write-locked) could all be factors in this.

OpenVMS installations try to avoid using shadowed system disks and shared disks and such and only minimally "play" in a cluster or FC SAN configuration, so you're already likely well out of the sweet spot for the kit testing that's been done here by HP.

I know well what specific tasks you're trying to do here, but not why you're looking at and troubleshooting this approach. What are you up to here? (You've deftly avoided providing any description of what you're really up to here; the background on the problem.)

If you're building a replication or server recovery mechanism of some sort for instance, then the use of the InfoServer may (will?) be right up your alley.
Larry Dillon
Advisor

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

SYSBOOT> SET SHADOWING 2
SYSBOOT> CONT

Worked for me to fix the error:
%MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

I also had to run:
@sys$update:vmslicense

and edit:
sys$system:modparams.dat
Art Wiens
Respected Contributor

Re: Locally installed v8.3 CD - %MOUNT-F-NOSHADOW, VMS Volume Shadowing Phase II is not enabled

Through the mists of time ...