Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

%MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

SOLVED
Go to solution
Ronny_7
Regular Advisor

%MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

Hi,

I have this SMTP problem which I needs some advise. Thank you.

AMDSG4_SYSBACK> TCPIP SHOW VERSION

Compaq TCP/IP Services for OpenVMS Alpha Version V5.3 - ECO 2
on a AlphaServer 4100 5/533 4MB running OpenVMS V7.2-2

AMDSG4_SYSTEM> mail

MAIL> show forward/user=sudiady.aminata
SUDIADY.AMINATA has mail forwarded to AMDSG4::SMTP%""sudiady.aminata@sgexmta8""

MAIL> exit

AMDSG4_SYSTEM> mail login.com sudiady.aminata
%MAIL-E-ERRACTRNS, error activating transport AMDSG4::SMTP
%SYSTEM-E-IVLOGNAM, invalid logical name

Thanks and Regards,
Ronny

11 REPLIES
Hein van den Heuvel
Honored Contributor
Solution

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM


Why do you have that AMDSG4::SMTP% when you are on node AMDSG4 ? Just use SMTP%... !

Hein.
Ronny_7
Regular Advisor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

Hi Hein,

Thank you for the reply.

Please forgive me for my limited knowledge but I have tested on a testing system with the nodename included and it works fine.

Regards,
Ronny
Hein van den Heuvel
Honored Contributor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM


> Please forgive me for my limited knowledge but You are doing fine.

I'm just bluffing, not really knowing this stuff.

> I have tested on a testing system with the nodename included and it works fine.

But in that test, was it an other node?
As the message arrives on amdsg4, that node
name is 'stripped' off. Sending to yourself might just work differently.

Actually that would be a little odd to not have those other nodes send directly through smtp%, unless if you have only one system (amdsg4) that has the smtp tcp internet mail access going and other systems 'route' through that.

Anyway... did you try without that nodename?

Hein.
Willem Grooters
Honored Contributor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

IMHO you coud do without %SMTP with this TCPIP version....
As far as I know VMS mail, I have the impression there's seomething wrong in your FORWARDing. "AMDSG4::SMTP%" looks pretty weird to me. What has been issued to forward this user? That might be the basic problem.
Willem Grooters
OpenVMS Developer & System Manager
Ian Miller.
Honored Contributor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

you appear to have too many quotes i.e. "" instead of just ". Also check SMTP client is enabled on node AMDSG4.
____________________
Purely Personal Opinion
Lokesh_2
Esteemed Contributor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

Hi,

Looks to me a SMTP configuration issue. Can you reconfigure SMTP ??? Also check,

Mail> sho transport
( if you have defined any default transport )

$tcpip sho config smtp/full
( check the alternate gateway )

Also check for the following logicals if they are defined OK:

TCPIP$INET_DOMAIN
TCPIP$INET_HOST
TCPIP$INET_HOSTADDR

and while sending mail, keep reply/enable to check any OPCOM messages.

Hope this helps,
Thanks & regards,
Lokesh
What would you do with your life if you knew you could not fail?
Ronny_7
Regular Advisor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

Hi Everyone,

Thank you very much for the advise and recommendation.

The problem is resolved after removing the last double qoute.

Original setting(not working),
MAIL> set forward/user=SUDIADY.AMINATA "AMDSG4::SMTP%""sudiady.aminata@sgexmta8"""

New setting(working),
MAIL> set forward/user=SUDIADY.AMINATA "AMDSG4::SMTP%""sudiady.aminata@sgexmta8""

Thanks and Regards,
Ronny
Brian Tillman
Occasional Advisor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

>The problem is resolved after removing the
>last double qoute.
>
>Original setting(not working),
>MAIL> set
>forward/user=SUDIADY.AMINATA "AMDSG4::SMTP%
>""sudiady.aminata@sgexmta8"""
>
>New setting(working),
>MAIL> set >forward/user=SUDIADY.AMINATA "AMDSG4::SMTP%
>""sudiady.aminata@sgexmta8""

When using strings inside the MAIL utility, don't double up the quotes. I believe this would also work:

MAIL> set forw/use=sudiady.aminata amdsg4::smtp%"sudiady.aminata@sgexmta8"
Dale A. Marcy
Trusted Contributor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

Brian's response is correct for more recent versions of VMS (which is the case for the original poster), but older versions (I believe V7.1 and earlier) do require the extra quotes in order to work correctly. I have been bitten by this on some of our systems because I forget when switching from older to newer versions.
Ronny_7
Regular Advisor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

Hi Brian and Dale,

Thank you very much for the explanation.

And A Happy New to ALL.

Regards,
Ronny
Ronny_7
Regular Advisor

Re: %MAIL-E-ERRACTRNS and %SYSTEM-E-IVLOGNAM

As per replies.