Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

MSL4048 LTO4 Library issue

 
Gregory Pagan
Occasional Advisor

MSL4048 LTO4 Library issue

We have just installed a fiber channel attached MSL4048 Library with 2 LTO 4 1840 drives.

We did the io find_wwid and io auto commands in sysman with out issue. the sys$devices.dat file has been updated with the correct information. We can see the $2$gga0 robot and the $2$mga0 and $2$mga1 drives using a show command.

N058V1$show device $2$gga

Device Device Error
Name Status Count
$2$GGA0: Online 0
N058V1$show device $2$mga

Device Device Error Volume Free Trans Mnt
Name Status Count Label Space Count Cnt
$2$MGA0: (N058V1) Online 10
$2$MGA1: (N058V1) Online 0

We can move a tape into the drive using the robot commands. When we try to init the tape in the drive we get the following error:

N058V1$init $2$mga0: ha2197
%INIT-F-WRITLCK, write lock error

We are running openvms 8.3 fully patched on a ES40.

We even tried moving the library to an Itanium server running 8.3 1H1 to see if that made a difference but that came up with the same error.

We are thinking that we are missing a patch or other update that adds the missing link to solve our problem but a search could not come up with a solution.

Any help would be greatly appreciated.

Thank you

Greg
Why does this always happen to me?
7 REPLIES 7
The Brit
Honored Contributor

Re: MSL4048 LTO4 Library issue

I know this is a stupid question, but did you check the Writelock tab on the tape cartridge??

Dave.
Gregory Pagan
Occasional Advisor

Re: MSL4048 LTO4 Library issue

Don't worry, the question is not stupid especially since it took us an hour to think of it our selves plus another 2 hours to get he clearence to get back into the data center to physically check the tapes, but no the tapes are not mechanically write locked.

But this is another reason that we think it is a driver type issue since it seems like the init command is reading the write lock value backwards. I suppose that we could try moving the tab to the locked position to see if that has any effect.

Greg
Why does this always happen to me?
Colin Butcher
Esteemed Contributor

Re: MSL4048 LTO4 Library issue

When you set the library up, did you set it to report 6 character tape labels, not 8 (which is, I think, the default setting)?

You need 6 character tape labels for ANSI labelling, which is what VMS uses.

Also, did you use "init
Entia non sunt multiplicanda praeter necessitatem (Occam's razor).
Gregory Pagan
Occasional Advisor

Re: MSL4048 LTO4 Library issue

Colin,

I had not used the /over=(access, expiration) paramaters put they did not help when I tried today.

Thanks for the suggestion though.

Greg
Why does this always happen to me?
Gregory Pagan
Occasional Advisor

Re: MSL4048 LTO4 Library issue

Well, the good folks at HP came up with the answer. Turns out it was the encryption kit that was causing the issue. They suggested I turn off encryption and I am now able to initialize tapes in both VMS and ABS/MDMS.

The folks at HP are still trying to determine if the hardware encrytion is really certified with OpenVMS 8.3 and if it is exactly what we need to do to make it work.

Greg
Why does this always happen to me?
The Brit
Honored Contributor

Re: MSL4048 LTO4 Library issue

Greg,
I (and probably others) would really be interested in HP's response to this since we are investigating using LTO4 Hardware Encryption on OpenVMS.

Dave.
Highlighted
Gregory Pagan
Occasional Advisor

Re: MSL4048 LTO4 Library issue

Well we are now successfully running hardware based encryption on OpenVMS 8.3 on an Alpha class system against the MSL4048 with the encrption pack using ABS/MDMS version 4.5.

After working with HP the source of our write lock issue turned out to be the key PIN. When you use encrption you must create a PIN that locks down the settings. If that PIN is not entered into the system after a library reboot or any other communication issue so the library is logged in, then encrption cannot take place and your backups will fail.

Greg Pagan
Why does this always happen to me?