Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Multiversion RDB errors

 
odwillia
Frequent Advisor

Multiversion RDB errors

I had a similar thread last week. With these errors:
SQLMOD :== $SQL$MOD/ANSI_PARMETER
SQLMOD DBREF:DB_WIP_PAY_SQL.SQLMOD
%SQL-F-ERRATTDEC, Error attaching to database WIP_DATABASE
-RDB-F-WRONG_ODS, the on-disk structure of database filename is not supported by
version of facility being used
-RDMS-F-ROOTMAJVER, database format 60.0 is not compatible with software version 70.1
%SQL-F-ERRATTDEC, Error attaching to database WIP_DATABASE
%SQL-F-ERRATTDEC, Error attaching to database WIP_DATABASE
%SQL-F-ERRATTDEC, Error attaching to database WIP_DATABASE
%SQL-F-ERRATTDEC, Error attaching to database WIP_DATABASE
%SQL-F-ERRATTDEC, Error attaching to database WIP_DATABASE
%SQL-F-ERRATTDEC, Error attaching to database WIP_DATABASE
%MMS-F-ABORT, For target DB_WIP_PAY_SQL.OBJ, CLI returned abort status
Any ideas as to how or why the multiversion has stopped functioning?
4 REPLIES 4
Kris Clippeleyr
Honored Contributor

Re: Multiversion RDB errors

Hi,
This is quite similar to the thread
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1252768
Please, (re)read the answers of my learned colleguaes.
Regards,
Kris (aka Qkcl)
I'm gonna hit the highway like a battering ram on a silver-black phantom bike...
odwillia
Frequent Advisor

Re: Multiversion RDB errors

This is the thread I was reffering to. My question is Can we make the multiversion work? We are ready to upgrade if we have to. I will reread the thread though. Maybe I missed something.
Hoff
Honored Contributor

Re: Multiversion RDB errors

If this multiversion Rdb question has you stymied to the degree that can be inferred here (and no offense is here intended), you might want to call in some more formal help for this, or spend some quality time reading through the Rdb manuals and/or in Rdb-related training. This for RMU and for Rdb database conversions, and for system management and maintenance operations involving your critical data; there could easily be exposures to your Rdb data, or there could be substantial stability or performance improvements and/or service upgrades available to your environment.
Jean-François Piéronne
Trusted Contributor

Re: Multiversion RDB errors

Hello,

what versions are started on your system, you can try:
$ sh sys/proc=rdms_monitor*

If you have a process named RDMS_MONITOR, you can use this version using:

$ @sys$library:RDB$SETVER S

If you have a process named RDMS_MONITOR60, you can use this version using:

$ @sys$library:RDB$SETVER 60

If you only have 7.0 started:
dir sys$startup:RMONSTART*.COM
then
$ @sys$startup:RMONSTART
or
$ @sys$startup:RMONSTART60

depend if you have the 6.0 standard version or the 6.0 multiversion installed.

JF
ps.
6.0 is fairly old, why not convert your database to 7.0 and only use 7.0?