Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Mysql link error

 
SOLVED
Go to solution
Jean-François Piéronne
Trusted Contributor
Solution

Re: Mysql link error

Dario,

Sorry for the inconvenience.

this is a know problem in the 5.1.22 IA64 kit.

It is fixed in 5.1.23 AXP and in the future 5.1.23 IA64 kits.

If you take a look at the log of the repository:
http://hgm.vmspython.dyndns.org/vmsmysql/shortlog
You can view what has be done.

We expect to release a new IA64 kits probably in a few week. We are fixing some others problems.

If you want I can build and put online the correct libraries newt week.

About why it's libraires and not shareable:
Old MySQL kit contains the clients part as a shareables with bot cases symbols. But between version MySQL change a lot (and often) the API and it will be very difficult to maintains a compatible shareable.
This is the reason why I have switch to libraries.
Myy be a separate client kits with a full version number (for examples 5122) can contains shareables.
Using server kit and a client kit will allow to upgrade the server without impacting the client part. And will allow to have many client shareable installed. Open question.

JF
Dario Karlen
Frequent Advisor

Re: Mysql link error

JFP

Thanks a lot for your answer.
I would really appreciate the new libray, but I know you re on holiday, so please enjoy it and don't care about this ;) The problem can still be fixed later.

Wish you a nice holiday.
Jörg Sporer
Occasional Visitor

Re: Mysql link error

Hello,

I have exactly the same problem as Dario. Are there any news about the fixed libraries?

Best regards
Jörg
Highlighted
Dario Karlen
Frequent Advisor

Re: Mysql link error

Hello Jörg

I sent an email to JFP (who ports MySQL to VMS) two weeks ago but no response so far. The only thing we can do at the moment is wait...As soon as I receive a response I will post it here.

Dario
Jean-François Piéronne
Trusted Contributor

Re: Mysql link error

Darion, Jörg,

Sorry I'm busy on others projects.
I have rebuild the libraries using MySQL 5.1.23
Download link:
http://www.pi-net.dyndns.org/anonymous/kits/tmp/ia64/mysqlclient05123_ia64.zip

I haven't done any tests except building the standard clients.

JF
Jörg Sporer
Occasional Visitor

Re: Mysql link error

Hello JFP,

thanks for the lib. Works great!
However I still get two linker errors when using the "upper" olb:
%ILINK-I-UDFSYM, ARRAY_APPEND_STRING_UNIQUE
%ILINK-I-UDFSYM, MY_QSORT

Since I don´t use those functions I can live with it. Just for your information...

Bye Joerg
Jean-François Piéronne
Trusted Contributor

Re: Mysql link error

Joerg,

I will take a look and rebuild a new version.

JF