cancel
Showing results for 
Search instead for 
Did you mean: 

NTP client

 
geir_2
Super Advisor

NTP client

Hi,

I want to configure ntp client on a OpenVMS server. The Openvms is using UCX version 4.1 and OpenVMS V6.2-1H3. I also want to use a show command to verify the config.
I have read through different documents without success. Hope someone can help me.
Thanks
Geir J.
8 REPLIES
EdgarZamora_1
Respected Contributor

Re: NTP client

Someone will help you if you can provide more details. "without success" doesn't give us a lot to go on. Please tell us what you've tried, any error messages you're getting, etc.
Hoff
Honored Contributor

Re: NTP client

There's not much to go on here, in terms of the current situation. Also some details of the ntp environment and the ntp server -- some platforms can offer an sntp server, not an ntp server, for instance.

Please elaborate on what you have done based on the ntp chapter of the TCP/IP Services Management manual, and on what from that material did not work as you expected.

You're back in the dark ages of OpenVMS and of ntp and of TCP/IP Services in general here, and long before the integration of daylight saving time (DST) and timezone differential factor (TDF) handling a variety of other changes that have arrived in more recent releases.

And you're back before the posted manuals, too, which means you'll have to scrounge for older manuals around the net, or on local consolidated documentation CDs.

I'd probably look to plan for an upgrade to V8.3 (several upgrade steps are required), and go from there, or to migrate to OpenVMS I64 given the likely vintage of this AlphaServer box. But that's somewhat longer-term than getting ntp working.

If you must stay on these older releases and on older hardware, please acquire and apply the most current ECO for this release. This as a first step toward resolving ntp issues.

Joseph Huber_1
Honored Contributor

Re: NTP client


I think there is no special configuration for NTP client. There is only the NTP configuration in the server part of UCX/TCPIP.
If I read Your mind correctly, then You ask for an NTP configuration, which only gets time updates from an external server.
In this case the only entry in SYS$SPECIFIC:[TCPIP$NTP]TCPIP$NTP.CONF (or the equivalent file for UCX) must only contain "server" type entries, i.e. NO "peer" entry:
server mytimeprovider
This means NTP gets time from the server(s), and synchronizes the local system time.
http://www.mpp.mpg.de/~huber
geir_2
Super Advisor

Re: NTP client

Hi again,

Thanks for the answer. According to the manual I must do following:

1) Edit SYS$SPECIFIC:[TCPIP$NTP]TCPIP$NTP.CONF, and enter following command
peer IP-address-NTP-server

2) Assume that I must rerun the program that reads the config file. The manual refer to following commands @sys$startup:tcpip$ntp_startup and @sys$startup:tcpip$ntp_shutdown. These commands are not available on my computer. Only ucx$ntpd_shutdown and ucx$ntpd_startup
area available under sys$startup directory.

3) At last, I want to verify the config above. It must be a show command or simular to verify that the the time is synchronized. I tried ucx> show service, without success.


Hope someone can help me.

Thnaks

Geir
Martin Vorlaender
Honored Contributor

Re: NTP client

Geir,

first off: pre-version 5 everything TCP/IP under VMS wasn't called TCPIP, but was called UCX.

1: The file name is SYS$SPECIFIC:[UCX$NTP]UCX$NTP.CONF

With a "peer" command you can synchronize two servers with each other, i.e. they have the same time, but probably not the correct one.

Josef pointed you to the "server" command. If the machine has a connection to the internet, choose one of the public NTP servers at http://support.ntp.org/ and put its IP address (IIRC, *not* the hostname) as a "server" into UCX$NTP.CONF.

2: see above. UCX$NTP_SHUTDOWN.COM and UCX$NTP_STARTUP.COM are the correct files for your version of TCP/IP.

3: I believe there was a command ntpq (or SYS$SYSTEM:UCX$NTPQ.EXE) but I could be wrong.

HTH,
Martin
marsh_1
Honored Contributor

Re: NTP client

geir,

define a foreign command for ntpq and check it's status, substitute ucx for tcpip e.g

PDGOLA::SYMHUNT> ntpq :== "$sys$system:tcpip$ntpq.exe"
PDGOLA::SYMHUNT> ntpq

ntpq> lpeer
remote refid st t when poll reach delay offset jitter
==============================================================================
*10.0.12.1 129.6.15.29 2 u 256 1024 377 0.488 48.153 5.303
+10.0.140.1 129.6.15.29 2 u 182 1024 377 0.488 44.639 6.639
+10.32.12.1 10.0.140.1 3 u 261 1024 377 15.938 46.089 3.129
-10.32.140.1 10.0.140.1 3 u 764 1024 377 15.973 42.520 11.700
ntpq> assoc
ind assID status conf reach auth condition last_event cnt
===========================================================
1 55788 9614 yes yes none sys.peer reachable 1
2 55789 9414 yes yes none candidat reachable 1
3 55790 9414 yes yes none candidat reachable 1
4 55791 9314 yes yes none outlyer reachable 1
ntpq> help
Commands available:
addvars associations authenticate clearvars cooked
debug exit help host hostnames
keyid keytype lassociations lopeers lpassociations
lpeers mreadlist mreadvar ntpversion opeers
passociations passwd peers pstatus quit
raw readlist readvar rmvars showvars
timeout version writelist writevar

good luck

geir_2
Super Advisor

Re: NTP client

Hi again,

1: Only ucx$ntpd_shutdown and ucx$ntpd_startup
are available under sys$startup directory. Is it identical to UCX$NTP_SHUTDOWN.COM and UCX$NTP_STARTUP.COM??

2: ntpq is not available. I have searched through [000000...]*ntpq*.exe without any results. Simular commands that I can use?Thansk again.

Geir
Joseph Huber_1
Honored Contributor

Re: NTP client

I think ucx$ntpd_S*.com is right for UCX 4.
Have a look into ucx$ntpd_startup: in old versions there is a comment about a UCX$NTP_TZ
logical eventually needed.

Also be aware that in VMS 6.2 DST switching was not done by the system, but by UCX/NTP:
verify correct setting: ucx show config time .

And as said, don't define a peer in config if You want the system to be a client only.
http://www.mpp.mpg.de/~huber