HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

No German Letters with IGEL-Powerterm in EVE

 
Lachnitt_1
Frequent Advisor

No German Letters with IGEL-Powerterm in EVE

Hi,

I'm testing with an IGEL-5128 Thin-Client, if they can replace our good old VTs!
They've a builtin Powerterm-Application, which is quiet good. You can manage the Terminal ID (from VT52 untill VT525), and so on.

But there's one problem. We use the german font type (oe, ae, ue). All is fine, untill i open the EVE-Editor.
After that i got "|vd" instead of the German equivalent of "oe, ae, ue".
But if I invoke $ SET TERM/INQ everything is fine again!

Any ideas???

Thx for any answer!
Bye Kuddel
6 REPLIES
Karl Rohwedder
Honored Contributor

Re: No German Letters with IGEL-Powerterm in EVE

Kuddel,

it looks as if the /EIGHT characteristics is not set, if you skip the 8th bit, ö->v.
A SET TERM/INQ is quite usefull during LOGIN for interactive processes.
Check for /EIGHT before the SET TERM/INQ and compare this settings with the Powerterm settings.

mfg Kal
Volker Halle
Honored Contributor

Re: No German Letters with IGEL-Powerterm in EVE

Kuddel,

this looks like a 7/8 bit problem. Somehow bit 8 is being cleared:

o-umlaut = 366 (octal) -> v = 166 (octal)

SET TERM/INQ seems to reset the terminal to Eightbit.

Please check SHOW TERM before and after invoking the EVE editor. And please check all initialization routines automatically invoked in your customized EVE...

Volker.
Lachnitt_1
Frequent Advisor

Re: No German Letters with IGEL-Powerterm in EVE

Show TERM before and after are 100% the same!

Volker checks if Powerterm on A PC shows the same effect!

Kuddel
Volker Halle
Honored Contributor

Re: No German Letters with IGEL-Powerterm in EVE

This behaviour seems to be triggered by some of the escape sequences EVE sends to the PowerTerm Emulator on the thin client.

Running TCPIPTRACE, we could observe, that the correct MCS code (0xF6) for 'o-umlaut' was being sent from the client to the Alpha host and correctly echoed back to the client (if SET TERM/EIGHT had been specified). The character was displayed as a 'd' on the screen of the PowerTerm emulator on the thin client.

A subsequent SET TERM/INQ did not change the character codes sent via TELNET, but caused the character to be correctly displayed on the thin client.

Volker.
Volker Halle
Honored Contributor

Re: No German Letters with IGEL-Powerterm in EVE

The same problem can be reproduced with the Ericom PowerTerm Demo download version V7.1 from a windows system.

Volker.
Lachnitt_1
Frequent Advisor

Re: No German Letters with IGEL-Powerterm in EVE

Hi,

we send this problem to Ericom!

Volker got the Escape-Sequenz, which has caused to this behaviour.

Thx Kuddel