Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Not seeing tape drive

 
Blake Dechant
Occasional Advisor

Not seeing tape drive

Hello,

I'm a fairly new system manager here so, bear with me if any of this seems obvious. There was a TZ87 tape drive connected to one of our VAXs. The tape drive (as well as some other equipment) seem to have gotten fried in a power surge (they can't even be powered on anymore). I found an extra TZ85 tape drive to replace the TZ87, set the SCSI switches to "4" (which is what the TZ87 had used), connected it and turned it on. When I do a
> show dev MKA500:
I get "No such device available" back. MKA500: was the old tape drive's name. I'm not really sure how to proceed. I guess maybe the card that the drive hooks into could be bad too. Or am I missing something obvious here? Also, is the TZ85 going to work as a replacement for the TZ87? (We use DLT III tapes.)

Thanks for any help,
-Blake
8 REPLIES 8
abrsvc
Respected Contributor

Re: Not seeing tape drive

It is possible that the interface is bad, but...

Try issueing the following command from a privileged account:

$ mc sysman io auto

The above will effectively do a hardware discovery and "connect" the drive should it be seen. If the TZ87 was off during the boot process, it could have been skipped as not being responsive to the query.

Post your results here.

Dan
Hoff
Honored Contributor

Re: Not seeing tape drive

Unit 4 is MKA400: device.

Not the MKA500: device. That's unit 5.

Caution:

DKA400: is a fairly common setting for a CD; that's unit 4.

Remove the tape, and terminate the bus.

See if there is a unit at MKA400: or DKA400:, or at MKA500: or DKA500: from the console or from running VMS.

Figure out what's on your SCSI bus.

Unit collisions are bad, and can raise all manor of havoc.

The host itself usually uses unit 6 or unit 7 for the host's SCSI controller. How that's determined depends on the SCSI controller and which particular VAX is involved.

If unit 5 is not occupied, then set your tape to 5 if you want the tape drive to be MKA500:, power-cycle the system and the whole bus setup, and boot.

And I'd wonder if the problem with the old drive was just the unit setting. If that got changed around the time of the lpower glitch.
Blake Dechant
Occasional Advisor

Re: Not seeing tape drive

@Hoff: I was pressing the button on the TZ87 after it went out and couldn't remember if it was on 4 or 5. But I tried changing the TZ85 to 5, and cycling the power on the system and the system still can't see the tape drive.

@abrsvc: I tried your suggestion and the system didn't like it. It told me its an unrecognized command verb \IO\.
Andy Bustamante
Honored Contributor

Re: Not seeing tape drive

On a VAX, use

$ mcr sysgen auto all /log

to scan for devices. As Hoff points out, if your system used MKA500 to reference the drive, the SCSI id should be 5. Are there any DKA devices on the system?

If maintaining this system is a business requirement, you should consider virtualizing to a CHARON VAX platform. Resellers who posts here will probably be by shortly to maintain the hardware. UPS and power filters are usually a good idea for equipment like this.



If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
Bob Blunt
Respected Contributor

Re: Not seeing tape drive

Blake, are you adding the tapedrive to a RUNNING VAX? I'd strongly recommend that you shutdown, remove the fried TZ87 and either power-cycle the VAX or when the system is shutdown to the "chevrons" (>>>) or console prompt issue the following:

>>> halt
>>> unjam
>>> init

THEN, at the console prompt, type "show device" and wait for the output to show your connected devices.

I also didn't notice if you had any recommendations about your existing tape media. You're going to have trouble reusing OR reading data written using the TZ87 with the TZ85 at all. You may even have trouble initializing the tapes to use with the older *and* lower density tape drive. The TZ85 is limited in density to about 2.6gb native whereas the TZ87 is capable of 10gb native (both will hold close to double in compression mode).

So I'd have to answer your last question with a question: How many tapes do your regular backups use with the TZ87 and you should at least double that.

In addition, as Hoff said, if you set the SCSI address to 4 that makes MKA400. Neither the TZ85 nor TZ87 should have been responding at MKA500 using that setting.

bob
Shriniketan Bhagwat
Trusted Contributor

Re: Not seeing tape drive

Hi,

Connecting the external storage device does not get detected automatically. After connecting the external storage, on VAX you need to execute the $ MC SYSGEN AUTOCONFIGURE ALL command. This command automatically connects devices that are physically attached to the system and loads their drivers. You can check for more details and examples from the online help.

As Hoff said, if the unit 4 is already allocated to other devices like disk or CD, then the same unit can not be used. You need to use the unit number which is not in use. Check the already allocated unit numbers by issuing the command $ SHOW DEV D and $ SHOW DEV M.

Check if cabling and terminators are connected properly.

By setting the correct unit number, proper connectivity(cabling/terminator) and doing MC SYSGEN AUTOCONFIGURE ALL you should be able to see the tape device. Rebooting the machine will also detect the tape device, if the unit number and the connectivity are proper. Make sure that the tape device is powered on.

Regards,
Ketan
Blake Dechant
Occasional Advisor

Re: Not seeing tape drive

So I wrote the last post just before leaving work yesterday and I still couldn't see the tape drive. This morning I look at the system and lo and behold I see a tape drive now! Granted it's MKA200: that the system sees, but that's probably because the TZ85 has three switches to use as the bits for the SCSI id and I probably mixed up the "on" and "off" positions -- turning a "5" into a "2". (fyi, there are no other MKx or DKx drives on the system.)

Not entirely sure why it can see the drive now, but at least I know the card isn't bad.

@Bob: Thanks for the input about the differences between the two drives. I will indeed get a replacement TZ87 instead of trying to use the TZ85 I found.

@Andy: Thanks for giving me the command to use on the VAX. Also thanks for the info on the CHARON VAX emulator. This is something worth looking into, although with money being tight around here I doubt I'll be able to get it pushed through.
Blake Dechant
Occasional Advisor

Re: Not seeing tape drive

I got another TZ87 tape drive and the

$ mcr sysgen auto all /log

command found the drive while the system is running. Thanks for your help everyone.