Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Opcom message "%NTP-E-INVRPCTYP, Invalid RPC type" every second.

Opcom message "%NTP-E-INVRPCTYP, Invalid RPC type" every second.

Hello.

I just set NTP service on my cluster. It's running well. Time is synchronizing. But on the console i start receiving this messages.

HPA1:SYSTEM>
%%%%%%%%%%% OPCOM 22-AUG-2008 16:17:50.75 %%%%%%%%%%%
Message from user SYSTEM on SMHPA1
%NTP-E-INVRPCTYP, Invalid RPC type 1107296384 from source 00000000, message disgarded.


HPA1:SYSTEM>
%%%%%%%%%%% OPCOM 22-AUG-2008 16:17:50.75 %%%%%%%%%%%
Message from user SYSTEM on SMHPA1
%NTP-E-INVRPCTYP, Invalid RPC type 1107296384 from source 00000000, message disgarded.


HPA1:SYSTEM>
%%%%%%%%%%% OPCOM 22-AUG-2008 16:17:50.75 %%%%%%%%%%% (from node SMHPA2 at 22-AUG-2008 16:17:50.76)
Message from user SYSTEM on SMHPA2
%NTP-E-INVRPCTYP, Invalid RPC type 1107296384 from source 00000000, message disgarded.


HPA1:SYSTEM>
%%%%%%%%%%% OPCOM 22-AUG-2008 16:17:50.75 %%%%%%%%%%% (from node SMHPA2 at 22-AUG-2008 16:17:50.76)
Message from user SYSTEM on SMHPA2
%NTP-E-INVRPCTYP, Invalid RPC type 1107296384 from source 00000000, message disgarded.

I'm not able to find any information about this message. Thanks for help.
6 REPLIES
Duncan Morris
Honored Contributor

Re: Opcom message "%NTP-E-INVRPCTYP, Invalid RPC type" every second.

I have not seen that message before, but my first action would be to check my setup

$ diff sys$sysroot:[tcpip$ntp]tcpip$ntp.conf SYS$SYSROOT:[TCPIP$NTP]TCPIP$NTP.TEMPLATE

You may still have an "example" server ip address left in there, when they should have been replaced by your own server list.

Are you also using DTSS?

# The following commands allow interoperation of NTP with another time service
# such as DTSS. If enabled (by removing #), NTP will not set the system clock.

# server 127.127.1.0 prefer
# fudge 127.127.1.0 stratum 0

# The following commands allow this node to act as a backup NTP server (or as
# the sole NTP server on an isolated network), using its own system clock as
# the reference source. If enabled (by removing #), this NTP server will
# become active only when all other normal synchronization sources are
# unavailable.

# server 127.127.1.0
# fudge 127.127.1.0 stratum 8


Duncan

Re: Opcom message "%NTP-E-INVRPCTYP, Invalid RPC type" every second.

Hello,

DTSS is not running and in TCPIP$NTP.CONF is only this:

# Copyright 2000 Compaq Computer Corporation
# NTP Configuration File
# This file is modified by P.vd.Aa & W.Schooten
# please do not make any changes to this file
driftfile SYS$SPECIFIC:[TCPIP$NTP]TCPIP$NTP.DRIFT
server 10.224.178.151 prefer
server 10.224.178.152 prefer

Re: Opcom message "%NTP-E-INVRPCTYP, Invalid RPC type" every second.

Any idea?
Wim Van den Wyngaert
Honored Contributor

Re: Opcom message "%NTP-E-INVRPCTYP, Invalid RPC type" every second.

Have no idea and did a search on my whole system disk 7.3 for "rcp type" and found nothing.

Which version of tcp ?

Wim
Wim

Re: Opcom message "%NTP-E-INVRPCTYP, Invalid RPC type" every second.

HP TCP/IP Services for OpenVMS Alpha Version V5.4 - ECO 7
on a COMPAQ AlphaServer DS20E 666 MHz running OpenVMS V7.3-2
Duncan Morris
Honored Contributor

Re: Opcom message "%NTP-E-INVRPCTYP, Invalid RPC type" every second.

Try following some of the procedures in the manuals

http://h71000.www7.hp.com/doc/732final/6526/6526pro_contents_003.html#toc_chapter_13

for setting debug levels for NTP. You can then look in SYS$SPECIFIC:[TCPIP$NTP]TCPIP$NTP_RUN.LOG for the output.

Try using ntpq to check your setting and connections with the time servers.

If all else fails, you will probably want to trace the incoming UDP packets on port 123. Maybe you have some other application trying to use the same port?

Duncan