Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS 7.3-2 L.P Question

Jefferson Humber
Honored Contributor

OpenVMS 7.3-2 L.P Question

What version of DECSet & Compaq C compiler should be used under Alpha 7.3-2 OpenVMS ?

Can the latest versions (12.5 & 6.5) be used, what about support from HP on this ?

Thanks in advance,

Jeff
I like a clean bowl & Never go with the zero
10 REPLIES
Martin P.J. Zinser
Honored Contributor

Re: OpenVMS 7.3-2 L.P Question

Hello Jeff,

the latest version is your best bet. Check the release notes. Often you will find "version xx or higher" in prodcut descriptions.

I have not any indication at all that DECset and/or the C compiler would be unsupported under 7.3-2.

Greetings, Martin
John Gillings
Honored Contributor

Re: OpenVMS 7.3-2 L.P Question

Jeff,

Upwards compatibility is the rule. If a user mode program runs on a particular version of OpenVMS, then it will run on all future versions. No need to recompile or relink. So, even if a layered product doesn't explicitly mention a recent version of OpenVMS, most of the time it will work.

In general it's a good idea to use the latest available compiler for any language, same applies to development tools like DECset. Support is generally only provided for the latest versions of layered products as there is only one "remedial code stream". That doesn't mean you must rush to install the latest version of all products - it's just that the first step in any problem escalation will be to see if the symptom is reproducible on the latest version.

Regarding support: if you have a service contract, you will get "best effort" support from your local CSC on ANY version of any layered product or OpenVMS. However, if you need engineering level support (ie: code changes, bug fixes, patches etc..) then you will need to be running a formally supported version of the product.
A crucible of informative mistakes
Jefferson Humber
Honored Contributor

Re: OpenVMS 7.3-2 L.P Question

Thanks,

The Cover Letters do say '6.2 or higher', but in other places mention 7.3 & 7.3-1.

By looking at the roadmaps, v.6.6 of the C Compiler isn't going to be released for some time. I can't believe HP would leave you high and dry with no compatible compiler for such a period anyway.

The HP testdrive box running 7.3-2 has v.6.5 of the compiler installed.

I will go with the latest versions.

Thanks again,

Jeff
I like a clean bowl & Never go with the zero
FNORD
Occasional Visitor

Re: OpenVMS 7.3-2 L.P Question

kcals itna eht revomer lliw lliw fnrod esu uoy noisrev hcihw rettam ton seod ti ffeJ


1313 ?dronf?
Lokesh_2
Esteemed Contributor

Re: OpenVMS 7.3-2 L.P Question

Hi Fnord,

Can you please translate your reply in English ??

Thanks & regards,
Lokesh Jain
What would you do with your life if you knew you could not fail?
Jan van den Ende
Honored Contributor

Re: OpenVMS 7.3-2 L.P Question

Lokesh,

reading right-to-left will help, but I still don't get the full message

Jan
Don't rust yours pelled jacker to fine doll missed aches.
Willem Grooters
Honored Contributor

Re: OpenVMS 7.3-2 L.P Question

Jeff,

6.5 for C is fine for 7.3-2. AFAIK, a compiler is (on VMS anyway) not dependent on OS version - what may be quite a different story on other OS's. It is depending on the processor (quite obviously).
If Decset 12.5 is the latest on 7.3-1, my guess it will be likewise on 7.3-2. I have not heard of a new release.
I think newest versions will come following 8.2 but I think (hope) the older version will be usable, on Alpha (and VAX), at least for some years.

Willem
Willem Grooters
OpenVMS Developer & System Manager
Martin Kirby
Advisor

Re: OpenVMS 7.3-2 L.P Question

Jeff,

DECset should be V12.5 (but V12.4A should also work).

There was an installation problem with PCA on V7.3 which is why the V12.4A kit was issued, as that was needed for when V7.3 was released. But V12.5 should be good for all V7.3-*.

Since PCA is not just a user mode program it does sometimes have issues on new OpenVMS versions.

Martin
Antoniov.
Honored Contributor

Re: OpenVMS 7.3-2 L.P Question

Original message in reverse order
------------------------------------------
fnord 1313
Jeff it does not matter which version you use dornf will will remover the anti slack
-------------------------------------------
Antonio Vigliotti
Antonio Maria Vigliotti
Antoniov.
Honored Contributor

Re: OpenVMS 7.3-2 L.P Question

Oops Jan,
now I read your answer ...
Sorry
Antonio Vigliotti
Antonio Maria Vigliotti