Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS 7.3-2 upgrade and error with SYS$STARLET_C.TLB

Neil Ashworth_1
Occasional Advisor

OpenVMS 7.3-2 upgrade and error with SYS$STARLET_C.TLB

Hi, I was doing an OpenVMS 7.3-1 to 7.3-2 upgrade today on our tesbed system (which is a copy of production). The upgrade stopped with this error:

PCSI-E-PARUDF, file [SYSLIB]SYS$STARLET_C.TLB was not previously installed, or is present but out of scope, module update skipped.
Termination is strongly recommended.

I have left the console sitting at the termination Y/N prompt while I investigate the problem.

In looking at the production system, SYS$STARLET_C.TLB does exist, and has a September 29th, 2004 date.

$ libr/list SYS$STARLET_C.TLB /full
Directory of TEXT library SYS$COMMON:[SYSLIB]SYS$STARLET_C.TLB;1 on 11-DEC-2006 15:45:59
Creation date: 29-SEP-2004 21:57:44 Creator: Librarian A09-23
Revision date: 29-SEP-2004 21:57:46 Library format: 3.0
Number of modules: 327 Max. key length: 39
Other entries: 0 Preallocated index blocks: 32
Recoverable deleted blocks: 0 Total index blocks used: 14
Max. Number history records: 20 Library history records: 0
Library is in DCX data reduced format

Do you think it is because it is in DCX data reduced format?
3 REPLIES
John Gillings
Honored Contributor

Re: OpenVMS 7.3-2 upgrade and error with SYS$STARLET_C.TLB

Neil,

> Do you think it is because it is in DCX data reduced format?

Definitely NOT.

See HELP/MESSAGE

help/mess parudf

PARUDF, 'object-type' 'object-name' was not previously installed or
is present but out of scope; 'object-type' update skipped

Facility: PCSI, POLYCENTER Software Installation Utility

Explanation: You attempted to update a managed object that either is not
known to the POLYCENTER Software Installation utility or is
known but does not have a compatible scope. For example, a
library module update might fail either because the library
file was not provided by another product or because the file
has product scope instead of global scope.

User Action: Check the product database and your command to verify that you
are trying to update a known managed object.

It sounds like the PCSI data base doesn't recognise that SYS$STARLET_C as the correct file to be upgraded. Has the existing version been updated by anything other than PCSI?

Try extracting the file from the 7.3-2 kit and comparing it with your existing file.
A crucible of informative mistakes
Steven Schweda
Honored Contributor

Re: OpenVMS 7.3-2 upgrade and error with SYS$STARLET_C.TLB

A quick Google search for:

parudf SYS$STARLET_C.TLB

turned up (the not exact, but suggestive):

http://h71000.www7.hp.com/DOC/82FINAL/6674/6674pro_install.html

(See "1.9.3 Error on Upgrade from Version
7.3-1".)

I quote:

Disregard the recommendation to terminate the
upgrade. Answer NO to the prompt Do you want
to terminate? [YES] . The upgrade will
continue successfully.
Kris Clippeleyr
Honored Contributor

Re: OpenVMS 7.3-2 upgrade and error with SYS$STARLET_C.TLB

Neil,
We have seen this error numerous times, and always continued the upgrade.
Haven't had any problems with the systems afterwards.
My guess is that you can safely ignore this error, it's a glitch in the upgrade procedure.
Regards,
Kris (aka Qkcl)
I'm gonna hit the highway like a battering ram on a silver-black phantom bike...