HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

 
Colin Butcher
Esteemed Contributor

OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

I've just upgraded my PWS500au to V8.2 (with all the current patches). Works fine, bar a slight oddity with OPA0: where SET TERM /DEV=VT400/WID=132/PAG=36 (or any SET TERM) produces the error %SET-W-NOTSET, error modifying OPA0: -SYSTEM-F-ILLIOFUNC, illegal I/O function code

Used to work fine on V7.3-1 and on V7.3-2. I assume it's a 'casualty' of the console changes for the Integrity platform.

Workaround is that I just stick the 9pin cable into a different port on the back...


SYSTEM on XDVMS2 $ set term /dev=vt400/wid=132/pag=36
%SET-W-NOTSET, error modifying OPA0:
-SYSTEM-F-ILLIOFUNC, illegal I/O function code
SYSTEM on XDVMS2 $ sho term
Terminal: _OPA0: Device_Type: Unknown Owner: OPA0_SYSTEM
Username: SYSTEM

Input: 9600 LFfill: 0 Width: 80 Parity: None
Output: 9600 CRfill: 0 Page: 24

Terminal Characteristics:
Interactive Echo Type_ahead No Escape
No Hostsync TTsync Lowercase No Tab
Wrap Scope No Remote No Eightbit
No Broadcast No Readsync No Form Fulldup
No Modem No Local_echo No Autobaud No Hangup
No Brdcstmbx No DMA No Altypeahd Set_speed
No Commsync Line Editing Overstrike editing No Fallback
No Dialup No Secure server No Disconnect No Pasthru
No Syspassword No SIXEL Graphics No Soft Characters No Printer Port
Numeric Keypad No ANSI_CRT No Regis No Block_mode
No Advanced_video No Edit_mode No DEC_CRT No DEC_CRT2
No DEC_CRT3 No DEC_CRT4 No DEC_CRT5 No Ansi_Color
VMS Style Input Backspace
SYSTEM on XDVMS2 $
Entia non sunt multiplicanda praeter necessitatem (Occam's razor).
11 REPLIES
Peter Quodling
Trusted Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

Silly question. IS the terminal that you have attached a VT400, or something that is configured to convince the world that it is a VT400?

q
Leave the Money on the Fridge.
Colin Butcher
Esteemed Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

It's PowerTerm in VT420 mode. I'm pretty sure that this is a VMS OPA0 issue, not a "device hanging off the end" issue.

The same DCL command works just fine on a non-OPA0 serial port. It used to work just fine on OPA0 as well prior to V8.2 with the same PowerTerm emulator and terminal emulator setup.

It's the "illegal IO function code" that bothers me. Might be PWS500au specific - as in console hardware related.
Entia non sunt multiplicanda praeter necessitatem (Occam's razor).
Peter Quodling
Trusted Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

HAve you tried another Terminal emulator? Putty or the like.

btw, I have a PWS500au acquired for VMS work, but it's an ex Eunuchs system, so has the IDE CDrom. How did you get around this, or do you have one of the Cypress chipset versions...

Leave the Money on the Fridge.
Robert Brooks_1
Honored Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

Colin wrote . . .

It's the "illegal IO function code" that bothers me. Might be PWS500au specific - as in console hardware related.

Hmmm. ILLIOFUNC is returned by the
device driver's FDT routine if the function code issued is not supported by the driver in question. OPA0 uses OPDRIVER; I'll have a look tomorrow and see if I can reproduce it and if a quick look at the sources reveal anything interesting.

-- Rob
Uwe Zessin
Honored Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

I thought I have seen something similar on old versions and the fix was to add the /PERMANENT qualifier, but I am not 100% sure.
.
David Jones_21
Trusted Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

I seem to recall a similar message when the alpha console variable "GRAPHICS" rather than "SERIAL".
I'm looking for marbles all day long.
David B Sneddon
Honored Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

Colin,

Do you have the latest firware installed?
I have a DPW600au running V8.2 plus all patches
and am not seeing any problems.
(I do however have a problem trying to shadow
my system disk, but that is another story)

Dave
Ian Miller.
Honored Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

how is the console configured in the efi firmware?
____________________
Purely Personal Opinion
Antoniov.
Honored Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

Colin,
IMHO you can't modify console on rx series, because same line is used by MP by Ctrl + B.
I guess, MP may have some trouble by any terminal change.

Antonio Vigliotti
Antonio Maria Vigliotti
Ian Miller.
Honored Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

My mistake - its an alpha not an Itanium. I guess we have to wait until someone with access to the listings can have a look at the console driver
____________________
Purely Personal Opinion
Colin Butcher
Esteemed Contributor

Re: OpenVMS Alpha V8.2 OPA0 - illegal function code with SET TERM

This is very confusing. It seems as if the problem is only post-upgrade from V7.3-1 to V7.3-2 to V8.2.

Booting from the V7.3-2 or V8.2 CD the SET TERM /DEV=VT400 works fine at the $$$ prompt.

It also works fine on a clean unpatched V8.2 system installed from the V8.2 CD as a fresh system disc.

The PWS500au has the latest known firmware (V7.2-1) and uses the Cypress chipset.

Details from console output in attached file.

Very strange. I also tried removing the X25 and WANDD products (don't use them any more on this machine) - and that made no difference.

Something is clearly confused about the OPA0 device capabilities, hence the "illegal function code".
Entia non sunt multiplicanda praeter necessitatem (Occam's razor).