HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS - CMS ignore Error

 
SOLVED
Go to solution
jdKern
Occasional Visitor

OpenVMS - CMS ignore Error

We are using CMS 4.4, Operating System OpenVMS 7.3-2).
The option ignore=notes in

"cms/diff/ignore=notes"

doesn't work.
Is this a known bug? Is there any patch?
4 REPLIES
Volker Halle
Honored Contributor

Re: OpenVMS - CMS ignore Error

jdKern,

welcome to the OpenVMS ITRC forum.

CMS V4.4 is the most recent available version of CMS. There seems to be no patch available for CMS V4.4 in ITRC and the Layered products FTP directory.

Would you care to elaborate or provide an example of the error ?

Volker.
John Gillings
Honored Contributor

Re: OpenVMS - CMS ignore Error

"doesn't work" isn't very precise. Could you please give an example. What you're doing, what you expect, and what you get.

Do the files being compared have the notes attribute enabled?

A crucible of informative mistakes
jdKern
Occasional Visitor

Re: OpenVMS - CMS ignore Error

An Example:

cms fetch nova.com

cms diff /ignore=notes nova.com nova.com/gen=1+ /out=tt

CMS File Comparison Utility
Files Compared By NOVAKER On 30-MAY-2006 07:32:10
(1) WORK_ROOT:[000000]NOVA.COM;1
(2) Element NOVA.COM Generation 7


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
File WORK_ROOT:[000000]NOVA.COM;1 Line 16
1)$ RUN dev_src:[novarwe.steuer.bin]NOVA ! *7

Element NOVA.COM(7) Line 16
2)$ RUN dev_src:[novarwe.steuer.bin]NOVA
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


The file is fetched with notes.
CMS/DIFF doensn't ignore the notes.
Volker Halle
Honored Contributor
Solution

Re: OpenVMS - CMS ignore Error

I've tested the /IGNORE=NOTES with CMS V4.0 and on that version, it seems to work as expected. With both CMS V4.1 and V4.3, it seems to fail in the same way as you've observed (see attached examples).

Please consider to log a call with HP, if you have a support contract covering CMS.

Volker.