Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS SSH/DECWindows X Server refuses connection

 

OpenVMS SSH/DECWindows X Server refuses connection

I am trying to execute a DECWindows client application on one system running OpenVMS Alpha V8.3 with TCP/IP Services for OpenVMS V5.6-9 ECO3 and having it display on the X Server of another system with the same software (OpenVMS Alpha V8.3 w/TCP/IP Services for VMS V5.6-9 ECO3) via ssh as follows:

$ ssh "+X" "-p" 1027 "USERNAME@gateway.company.us"

Welcome to ES45 Development System #1 OpenVMS (TM) Alpha Operating System, Version V8.3
USERNAME's password:

Authentication successful.


Last interactive login on Wednesday, 6-MAY-2009 14:34:49.00
Last non-interactive login on Tuesday, 5-MAY-2009 18:31:48.91

$ RUN SYS$SYSTEM:DECW$CLOCK
Xlib: connection to "_WSA345:" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
X Toolkit Error: Can't Open display
%DWT-F-NOMSG, Message number 03AB8204

$ logout
USERNAME logged out at 6-MAY-2009 15:04:31.88
Connection to gateway.company.us closed.

I thought that all X Windows communication was directed through the SSH tunnel once you authenticated. There are firewalls on both ends of this test. But, again if the tunnel is established, why would there be a problem?

Anyone with a thought?
3 REPLIES 3
Hoff
Honored Contributor

Re: OpenVMS SSH/DECWindows X Server refuses connection

Turn off all security requirements, at least for the purposes of testing. Per one of the folks at HP, OpenVMS does not presently provide for any X security, and this includes (a lack of) MIT Magic Cookie support.

Or ring up HP; this area is somewhat of a quagmire.

Some related reading follows...

"Fun" with XDM and Authentication:

http://www.openvmshobbyist.org/forum/viewthread.php?forum_id=40&thread_id=651

How to do this with Mac OS X and the ssh client:

http://labs.hoffmanlabs.com/node/134

HP planning X and XDM updates? (including a link to HP statement around the lack of MIT Magic Cookie support):

http://labs.hoffmanlabs.com/node/1196

Re: OpenVMS SSH/DECWindows X Server refuses connection

OK. I'm an idiot. The answer is you have to enable the Magic Cookie server access control on the desktop session manager that is running on the OpenVMS system on which you are executing the ssh command. When running the "new" CDE Open Desktop Session Manager, you do this by clicking on the Style Manager Icon on the CDE Control Panel (the one that has the picture of the three button mouse and a color pallete in the foreground). Then, click the icon labeled Security. This will bring up a dialog with a section titled "Server Access Control". In this section there is a check box labeled "Magic Cookie" (which by default is not enabled). Click the "Magic Cookie" check box to enable MIT-MAGIC-COOKIE-1 support for the desktop session. Dismiss the dialog by hitting the OK button. After I did this, I was able to successfully execute remote X window client applications on the remote system targeted by the ssh command and have the resulting X windows displayed on the local OpenVMS desktop session.

Eric
Jan van den Ende
Honored Contributor

Re: OpenVMS SSH/DECWindows X Server refuses connection

Eric,

>>>
OK. I'm an idiot.
<<<

I 'm not so sure about that!
Given the rather underwhelming documentation on SSH and on DecWindows (let alone the combo) someone had to unearth the secret and publish.
And that was YOU!

At least now it is documented for anyone that tries Google for it.
I, and I would suppose many others, owe YOU for that.

THANKS!

Proost.

Have one on me.

jpe
Don't rust yours pelled jacker to fine doll missed aches.