Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS keyboard issues

 
Jim Geier_1
Regular Advisor

OpenVMS keyboard issues

I've been using and managing OpenVMS systems for about 30 years. This problem but surprised me and did not surprise me. We noticed this problem when we rolled out LDAP so user's passwords on the OpenVMS systems are synchronized with Active Directory.

Our users use a couple of terminal emulators and telnet to our OpenVMS systems. Many of our users use the numeric keypad quite a bit, so in their password, they sometimes add an asterisk, hyphen, plus-sign, or slash and in Windows, they use those keys on the numeric keypad. Then, when they use the same keystrokes for their password on the OpenVMS system, the non-numeric keys on the numeric keypad do not work (asterisk, hyphen, plus, or slash). I also notice that with I use the Reflection terminal emulator, those same keys do not work at all in the VMS session, it is not that they do not work at the password prompt, they do not work at all.

Knowing that there are many, many different types of keyboards, this might seem an almost ridiculous question, but is there any way to have those keys be recognized by OpenVMS the same way the are recognized in Windows? And this would have to be when entering one's password, before their process is authenticated, so a fix by making some setting in one's login script is not going to work well.
9 REPLIES 9
Hoff
Honored Contributor

Re: OpenVMS keyboard issues

In no particular order...

Chances are, you're tussling with the terminal emulator, or with the emulator settings. Not VMS. VMS is probably a bystander here.

VMS recognizes those keys just fine when you're using a real VT terminal or a VT-compliant emulator, and when you have that terminal or emulator set to use the numeric keypad and not the application keypad.

You're expecting numeric keypad mode here, with your password prompting requirements.

The default is often application. If it's implemented.

Alternative solution? Ensure the keypad is set to its numeric mode within the terminal or terminal emulator, prior to login. This can often be done via the set-up, or by escape sequence, or both.

Sneaky solution? Buy keyboards that lack the keypad. This given keypads are fading in availability, poorly emulated, and various new systems entirely lack the hardware.

Best solution? Kerberized telnet, or ssh with keys.

Few terminal emulators are truly VT-compliant.

The Freeware package VTstar is the actual VT terminal firmware; it is as good a VT emulation as you'll find, but even it can't deal with differences in the keypad hardware labeling and layout. The "fun" is that there's simply no good emulation possible; you can go by key position, or by the key labels. Either one can cause problems and confusion.

Including a discussion of numeric and application keypad operations. As for your particular terminal emulator, that's your job to sort out.

There are VT manuals here:

http://vt100.net

ITRC glitched again. Reposting this. Apologies on any duplicates.
Steven Schweda
Honored Contributor

Re: OpenVMS keyboard issues

> Our users use a couple of terminal
> emulators [...]

Not a very detailed description.

> Chances are, you're tussling with the
> terminal emulator, or with the emulator
> settings. [...]

Yup. When I'm away from my VMS systems, I
often use a Mac running its xterm terminal
emulator, and, after a little bit of xmodmap
action, I can use EVE (or EDT, or any other
keypad-needing program) with no particular
difficulty. (Of course, a Mac keyboard has
the advantage of having _three_ keys above
the keypad Enter key, but life isn't always
fair.)

Perhaps if you better identified this
mysterious "couple of terminal emulators",
then someone who knows something might be
able to offer a useful suggestion or two. I
normally avoid Windows, but I have dim
memories of using TeraTerm (or something like
that) with some success. I hear that PuTTY
is not completely worthless.

http://www.chiark.greenend.org.uk/~sgtatham/putty/
Jim Geier_1
Regular Advisor

Re: OpenVMS keyboard issues

The terminal emulators in question are (1) Reflection and (2) IDXterm from GE Healthcare (formerly IDX Systems). I use Reflection most of the time, and have found it to be better than Putty , but Reflection costs money, and Putty does not.
Khee Chan
Advisor

Re: OpenVMS keyboard issues

Jim,

The "/","*","-" and "+" keys on the keypad of my PC-101 key keyboard works fine with both NumLock enabled and disabled in my PuTTY terminal emulator window. Do you or your users do a "SET TERMINAL /INQUIRE" in SYLOGIN.COM or LOGIN.COM or at any other time once logged in interactively?

Please see attachment for screenshots of the terminal setup screens for my copy of PuTTY. my PuTTY appears as a VT102 to VMS after "SET TERMINAL /INQUIRE". The PC keypad also maps one-to-one (well, except for one) to my EVE keypad settings for a real LK411. Also the user-defineable F keys map one-to-one also (Ctrl+Shift for F11 to F20)

Technical details are:
PC: PuTTY v0.60, Windows XP Pro SP3
Alpha: DS10, OVMS v8.3
Khee Chan
Advisor

Re: OpenVMS keyboard issues

*** APOLOGIES IF POSTING IS DUPLICATED ***
This one has the attachment.

Jim,

The "/","*","-" and "+" keys on the keypad of my PC-101 key keyboard works fine with both NumLock enabled and disabled in my PuTTY terminal emulator window. Do you or your users do a "SET TERMINAL /INQUIRE" in SYLOGIN.COM or LOGIN.COM or at any other time once logged in interactively?

Please see attachment for screenshots of the terminal setup screens for my copy of PuTTY. my PuTTY appears as a VT102 to VMS after "SET TERMINAL /INQUIRE". The PC keypad also maps one-to-one (well, except for one) to my EVE keypad settings for a real LK411. Also the user-defineable F keys map one-to-one also (Ctrl+Shift for F11 to F20)

Technical details are:
PC: PuTTY v0.60, Windows XP Pro SP3
Alpha: DS10, OVMS v8.3
Jim Geier_1
Regular Advisor

Re: OpenVMS keyboard issues

Basically, it does not matter what occurs after the login, because the problem occurs when entering one's password. So SET TERMINAL/INQUIRE or SET TERMINAL/NUMERIC in the system-wide or one's personal login script are irrelevant.

We did find a setting in IDXterm that forces the numeric keypad to be enabled, and that does solve the problem at the password prompt and throughout the session. About 90% or more of our users use IDXterm. I am not as concerned about Reflection, but I am still looking for the setting there, since even though only about 10%, there are still a good number of users using Reflection.
Bill Pedersen
Regular Advisor

Re: OpenVMS keyboard issues

The biggest problem, at least with Reflection is that the "/", "*", "-" and "+" keys on the application keypad get translated into things like PF2, PF3, PF4 and "-" respectively.

So since LOGIN does not like Escape Sequences in the password this gets a bit messy.

So, you either have to UNMAP the Application Keypad on the emulator or your have to train your users not use the the Application Keypad to enter their passwords. The latter is probably a hopeless task, especially if you work in an environment where they use the Application Keypad like a 10-Key and in many business environments this is not uncommon.

You can re-MAP the keypad on Reflection to be any sort of mapping you want. It might drive you nuts but your users, if they are not used to using the Application Keypad for things like EDT or EVE or similar will probably be OK with it.

As far as the IDXterm I am not familiar with its keyboard mapping function (if it has anything significant) so I can not help there.
Bill Pedersen
CCSS - Computer Consulting System Services, LLC
Oswald Knoppers_1
Valued Contributor

Re: OpenVMS keyboard issues

You might want to add an c in your sys$announce. This will reset the terminal before the username and password are entered.

Oswald
The Brit
Honored Contributor

Re: OpenVMS keyboard issues

Hi Jim,
I'm sure you have already tried this so I apologise in advance.

On the Reflections toolbar, click Setup Menu and select "Terminal". Select a VT terminal type. Under Emulation, Host Char Set = DEC Supplemental, PC Char Set = Windows, Terminal ID = VT100. Under Keyboard & Mouse check what you want, however set Keyboard = Numeric.

These choices work for me, and I use reflections all the time. (however I dont use those particular characters in my passwords).

Alternatively (tongue in cheek), I guess it really doesnt matter what character OpenVMS reads from the Keypad provided that the user SETS the Password using the Keypad, and ALWAYS uses the Keypad for those characters.)

Dave.