Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS multimedia MMOV on the Digital PW 600au

 
SOLVED
Go to solution
Highlighted
Alexey Chupahin
Occasional Advisor

OpenVMS multimedia MMOV on the Digital PW 600au

Hello OpenVMS guru

I wish to start MMOV on the Digital PW 600au to continue my porting libSDL next releases,

MMOV documentation says me it is possible.

But instruction steps in the MMOV docs does not lead me to success, mixer utility cannot see audio device, AUA0: is offline.

Can happy DPW  owners help me with DPW 600au integrated sound card ?

I have OpenVMS 7.3-2, 8.2, 8.3, 8.4

best regards,

Alexey

5 REPLIES 5
Eberhard Heuser
Frequent Advisor

Re: OpenVMS multimedia MMOV on the Digital PW 600au

You should check the entries in file

 

[VMS$COMMON.SYSEXE]SYS$USER_CONFIG.DAT

 

and look if one of these sound device is there in your pci-configuration.

 

Eberhard

 

===========================================================================

! Added on 6-NOV-2002 11:58:17.81 via MMOV_ADD_DEVICE.COM
!
device = "Ensoniq AudioPCI"
name = AU
driver = MMOV$ENSDRIVER
adapter = PCI
id = 0x13711274
end_device

! Added on 6-NOV-2002 11:58:17.96 via MMOV_ADD_DEVICE.COM
!
device = "Microsoft Sound Card"
name = AU
driver = MMOV$MSBDRIVER
adapter = ISA
id = 0x0042534D
end_device

! Added on 6-NOV-2002 11:58:18.07 via MMOV_ADD_DEVICE.COM
!
device = "Microsoft Sound Card"
name = AU
driver = MMOV$MSBDRIVER
adapter = ISA
id = 0x42584350
end_device

! Added on 6-NOV-2002 11:58:18.21 via MMOV_ADD_DEVICE.COM
!
device = "Microsoft Sound Card"
name = AU
driver = MMOV$MSBDRIVER
adapter = ISA
id = "PCXBJ"
end_device

! Added on 6-NOV-2002 11:58:18.38 via MMOV_ADD_DEVICE.COM
!
device = "Microsoft Sound Card"
name = AU
driver = MMOV$MSBDRIVER
adapter = EISA
id = "ISA2000"
end_device

! Added on 6-NOV-2002 11:58:18.56 via MMOV_ADD_DEVICE.COM
!
device = "AV301"
name = VI
driver = MMOV$VIDRIVER
adapter = PCI
id = 0x00131011
end_device

! Added on 6-NOV-2002 11:58:18.77 via MMOV_ADD_DEVICE.COM
!
device = "AV321"
name = VI
driver = MMOV$VIDRIVER
adapter = PCI
id = 0x000E1011
end_device

! Added on 6-NOV-2002 11:58:19.00 via MMOV_ADD_DEVICE.COM
!
device = "AV300-AA"
name = VI
driver = MMOV$VIDRIVER
adapter = TC
id = "AV300-AA"
end_device

!
!
device = "ES18888 Sound Card"
name = AU
driver = MMOV$ESSDRIVER
adapter = XBUS
id = "ES1888"
end_device

 ==========================================================

Alexey Chupahin
Occasional Advisor

Re: OpenVMS multimedia MMOV on the Digital PW 600au

Yes, I have this config, and my section is

device = "ES1888 Sound Card"
name = AU
driver = MMOV$ESSDRIVER
adapter = XBUS
id = "ES1888"
end_device

 

 

but still cant work. In linux on the same machine sound work fine.

Can you  send me step by step instruction how you get working MMOV on it please ?

Alexey Chupahin
Occasional Advisor

Re: OpenVMS multimedia MMOV on the Digital PW 600au

Most exactly, the device AUA0 is not present in system, sorry. It is not offline,but apsent.

 

Alexey Chupahin
Occasional Advisor
Solution

Re: OpenVMS multimedia MMOV on the Digital PW 600au

After analyze system information, clue config and isacfg I get it worked, I hope this may be interested for DPW owners

This is should be executed:

 

$mc sysman io conn aua0: /driver=dka500:[sys0.syslib]MMOV$ESSDRIVER /node=7 /vector=20 /adapter=5 /csr=8144D180
$@sys$startup:mmov$startup

 

dka500 should be replaced with your system disk.

fhsjvl
Frequent Advisor

Re: OpenVMS multimedia MMOV on the Digital PW 600au

Glad to hear you found a solution.

 

Strangely enough, the MC  SYSMAN IO CONN... command is not needed on a Digital Personal Workstation 500au. All one needs to do is to add

 

device = "ES1888 Sound Card"
name = AU
driver = MMOV$ESSDRIVER
adapter = XBUS
id = "ES1888"
end_device

 

in [VMS$COMMON.SYSEXE]SYS$USER_CONFIG.DAT, as mentioned above.

 

Do not forget you have to use MMOV version 2.2-1 on the most recent versions on OpenVMS Alpha.