Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS no inbound ftp

 
SOLVED
Go to solution

Re: OpenVMS no inbound ftp

Problem appears to have been solved.
All I did was execute
@sys$common:[sysexe]TCPIP$FTP_RUN.COM

and I was able to FTP into the node.

Thanks for all the help.
Steven Schweda
Honored Contributor

Re: OpenVMS no inbound ftp

> All I did was [...]

Sounds very like what enabling and starting
the FTP service would have done. At least
until the next re-boot, when there's no
telling whether it'll be restarted. There
are some potential advantages in internal
consistency when you go through the proper
procedures to deal with problems like this.

Didi you ever disclose whether FTP had ever
been working on this system before?
Wim Van den Wyngaert
Honored Contributor

Re: OpenVMS no inbound ftp

Your ucx sho servi shows

User_name: not defined

It should be TCPIP$FTP. Was "file" containing tcpip$system:tcpip$ftp_run.com ?

And did you check the log file mentioned in the service setup ?

Wim
Wim
Peter Zeiszler
Trusted Contributor

Re: OpenVMS no inbound ftp

"Service: FTP
State: Disabled
Port: 21 Protocol: TCP Address: 0.0.0.0
User_name: not defined Process: TCPIP$FTP"

From that it shows state of disabled.
Username "not defined"

Try this:
mc authorize show *ftp*/br
You should have an TCPIP$FTP account. If you don't then run through the setup for FTP server via @sys$manager:tcpip$config. The setup should create the account.

Server components and find ftp.
I think that after the server is enabled the command procedure asks if you want to configure the client.

Re: OpenVMS no inbound ftp

Thanks to all for your suggestions.
You probably guessed that I am not a sys admin or op. I'm just a user who tried to help a friend. And we did help him.
I could run some commands because I do not have AUDIT.
Dave Gudewicz
Valued Contributor

Re: OpenVMS no inbound ftp

I noticed that your TCP/IP services ECO level is 5. ECO 7 is the latest and can be found at:

http://www12.itrc.hp.com/service/patch/patchDetail.do?patchid=DEC-AXPVMS-TCPIP-V0504-15ECO7-1&sel={openvms:alpha:7.3-2,}&BC=main|search|

Dave...

Re: OpenVMS no inbound ftp

And of course, that last reply should have read: "I could NOT run some commands because I do not have AUDIT.

Re: OpenVMS no inbound ftp

See previous comments about TCPIP$FTP_RUN.COM
Ian Miller.
Honored Contributor

Re: OpenVMS no inbound ftp

Now your friend knows who to call - no good deed goes unpunished :-)

Perhaps you can redirect them here or find a local VMS system manager for the next time - luckily VMS systems rarely go wrong.
(I suspect in this case there will be more issues).
____________________
Purely Personal Opinion
Highlighted
Robert Gezelter
Honored Contributor

Re: OpenVMS no inbound ftp

Roger,

I would agree that one should ensure that FTP services will survive a reboot.

Using the *_RUN.COM file will start the service, but it will not ensure that the service will start correctly at reboot. Only ensuring that the service is correctly enabled will do so.

- Bob Gezelter, http://www.rlgsc.com