Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

 
SOLVED
Go to solution
H_Bachner
Regular Advisor

PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

One of my clients has been running a VAX 4000/106 with OpenVMS V6.2 and PATHWORKS V5.0C for years. I could convince them that it was a good idea to upgrade to PATHWORKS V6.1 and install an IP stack (UCX V4.2 ECO5) so they could get rid of some Windows NT 4.0 PCs which had the sole purpose to access PATHWORKS shares or connect the VT320 terminal amulator to the VAX via LAT.

While both the IP stack (telnet, ftp) and PATHWORKS (via DECnet and NetBEUI) work fine, I could net get PATHWORKS to talk to the client PCs via IP.

KNBDAEMON fails with:
bind_a_port(137): t_bind failed: 8

The PWIP ACP logs this message each time KNBDAEMON tries to start:
bindReq : *** IO$_SETMODE set tcp options (NODELAY) call failed *** : 20
(I attach the contents of both logfiles for reference)

What I tried so far:
- define logical names PWRK$KNBDAEMON_DEVICE and _IPADDR
- defined TCPIP$INET_* logical names identically to the existing UCX$INET_* logical names (just in case...)
- checked that port 137 (and 139) are not used by something else ($ UCX SHO DEV only shows two devices - one for port 23 [telnet] and one for port 21 [ftp])
- tried suggestions found elsewhere like shutting down PATHWORKS, restarting the PWIP ACP and starting PATHWORKS again.

I *suspect* that the root cause is in UCX because of the message in the PWIPACP log file. Status code 20 (decimal) would be %SYSTEM-F-BADPARAM. On the other hand, the NODELAY option for the tcp protocol is listed in UCX HELP SET PROTOCOL so it should be known...

I've collected quite some troubleshooting material over the years but am unable to come up with anything useful in this case.

Any ideas (beyond moving to OpenVMS V7.3 and the latest and greatest IP stack - this is not an option)?

Thanks for all and any help,
Hans.
10 REPLIES 10
Andy Bustamante
Honored Contributor

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

Dig into the UCX configuration (sys$manager:ucx$config.com) menu. There's an optional component to run Pathworks over tcp/ip that needs to be enabled. Did you enable this service?

Andy Bustamante
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
H_Bachner
Regular Advisor

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

Andy,

> There's an optional component to run Pathworks over tcp/ip that needs to be
> enabled. Did you enable this service?

Yes, that's the PWIP ACP. It is running and produces the bindReq error message I mentioned in the UCX$PWIPACP_XXXXX.LOG log file.

Hans.
Andy Bustamante
Honored Contributor

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

Did you use ADMIN/CONFIG to enable TCPIP as a network transport in the Pathworks configuration?

Andy Bustamante
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
H_Bachner
Regular Advisor

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

Andy,

> Did you use ADMIN/CONFIG to enable TCPIP as a network transport in the
> Pathworks configuration?

Yes, I did (see the KNBDAEMON error).

Any more ideas?

Thanks,
Hans.
Andy Bustamante
Honored Contributor

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)


The SPD http://docs.hp.com/en/12831/Advancedserver.pdf for Pathworks 6.1 shows VMS 7.3-2 as the minimum supported version. That doesn't mean it won't run, but you're having issues and this isn't a supported configuration.

You could revert back to PW 5.0c or a 5.1 version. These should both work with UCX. Another thing would be to check ftp.itrc.hp.com and make sure the UCX eco is the most current.

Good luck,

Andy
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
Paul Nunez
Respected Contributor
Solution

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

Hi Hans,

Found some history on this in notes and the workaround is to replace the sys$common:[sys$ldr]ucx$pwipdriver.exe and sys$common:[sysexe]ucx$pwipacp.exe images with the same images from the ucx 4.2 eco4 kit.

It was elevated to UCX engineering so I suspect a fix is available...somewhere.

HTH,

Paul

H_Bachner
Regular Advisor

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

Andy,

> The SPD http://docs.hp.com/en/12831/Advancedserver.pdf
> for Pathworks 6.1 shows VMS 7.3-2 as the minimum supported version.

this is true for Advanced Server V7.3B. PATHWORKS V6.1, however, is also supported on OpenVMS 6.2 VAX and Alpha (look a bit further down in the SPD). Also, UCX V4.2 is listed as the appropriate version for OpenVMS V6.2 (Table 3, page 32).

In the meantime, Paul has posted the solution for the problem, see his explanations.

Thanks & regards,
Hans.
H_Bachner
Regular Advisor

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

Paul,

you definitely made my day/week/month! :-)

> ...the workaround is to replace the sys$common:[sys$ldr]ucx$pwipdriver.exe
> and sys$common:[sysexe]ucx$pwipacp.exe images with the same images
> from the ucx 4.2 eco4 kit.

Fortunately, I still had an ECO 4 kit spinning around on an RZ40 disk :-)
I extracted the images you mentioned, put them into place, rebooted and... voila!

E:\Hans>dir \\10.0.0.31\pwutil
Datenträger in Laufwerk \\10.0.0.31\pwutil: ist VAXVMS062
Volumeseriennummer: 0000-0001

Verzeichnis von \\10.0.0.31\pwutil

14.12.2008 02:34 MONITOR
14.12.2008 02:34 431 README.TXT
14.12.2008 02:34 SRVTOOLS
1 Datei(en) 1.967 Bytes
2 Verzeichnis(se), 989.749.248 Bytes frei

E:\Hans>

I still get a "Connect Request failed" error with a 556 status (device timeout) logged in the PWIPACP log file, but this doesn't seem to impact access to the PATHWORKS shares over IP.

Thanks much for your help!

Best regards,
Hans.
H_Bachner
Regular Advisor

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

The workaround mentioned by Paul to revert to UCX 4.2 ECO 4 images for PWIPACP and PWIPDRIVER worked just fine. I wish I cold assign 50 points to his suggestion! :-)

Many thanks & best regards from Austria,
Hans.
Andy Bustamante
Honored Contributor

Re: PATHWORKS V6.1 fails to talk over IP (t_bind to port 137 failed)

Glad to hear I was wrong and there is a fix out there.

Andy
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net