Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

PCSI$COMPRESSED for pre-7.3-2

Doug Phillips
Trusted Contributor

PCSI$COMPRESSED for pre-7.3-2

When needing to install Advanced Server 7.3B on pre-V7.3-2 ovms/axp in the past, I've been able to FTP download the zipped pcsi$compressed file to a newer version, uncompress it to .PCSI, zip it up and FTP it to the older system.

Now, those systems are no longer available to me and it seems the Free OVMS account Alphas that I know which were once usable for such things are either temporarily or permanently not alive.

Anyone know where I could get the uncompressed .PCSI file or have any other suggestions?

PS: I plan to upgrade the current-problem 7.2-1 system to 8.3 but am having trouble finding 7.3-2 media. I do need to solve some of problems not corrected in 7.3-A4 now. The system is now under update support, but the 7.3-2 media kit was pitched during a too-thorough house cleaning. But, that's another story.
8 REPLIES
RBrown_1
Trusted Contributor

Re: PCSI$COMPRESSED for pre-7.3-2

I have used the deathrow cluster telnet://deathrow.vistech.net/ for uncompressing pcsi$compressed files. Decuserve telnet://eisner.decuserve.org/ might also work.
Steven Schweda
Honored Contributor

Re: PCSI$COMPRESSED for pre-7.3-2

Have you installed the PCSI ECO which lets it
cope with a .PCSI$COMPRESSED kit?

ftp://ftp.itrc.hp.com/openvms_patches/alpha/V7.3/VMS73_PCSI-V0200.txt

[...]
7.7 Enable the use of compressed kit

7.7.1 Functionality Description:

The PRODUCT INSTALL command can operate on PCSI kits with a
file type of .PCSI$COMPRESSED in a transparent manner.
[...]
Doug Phillips
Trusted Contributor

Re: PCSI$COMPRESSED for pre-7.3-2

BR: Last I check, deathrow's alpha was down. I'll check again. Haven't tried to prod copy an AXP kit on VAX. Does that work?

SS: Does the 7.3 PCSI ECO install on 7.2-1? Since 7.2-1 is unsupported it's hard to find these things out without trying it and I don't have time for a trial install nor do I have a 7.2-1 play system.
Volker Halle
Honored Contributor

Re: PCSI$COMPRESSED for pre-7.3-2

Doung,

OpenVMS VAX V7.3 does not understand .PCSI$COMPRESSED kits.

EISNER is an OpenVMS Alpha V8.3 system and has been revived. But you need enough diskquota for such a kit decompression.

Advanced Server V7.3B is only supported for V7.3-2 and upwards.

OpenVMS Alpha V7.2-1 has not and will never support compressed PCSI kits.

Volker.

Doug Phillips
Trusted Contributor

Re: PCSI$COMPRESSED for pre-7.3-2

It seems that in my case decompressing the file would be considered "for commercial purposes" so as a law abiding citizen I can't use one of the hobbyist systems.

AFA AS-7.3B not being supported on pre-VMS-7.3-2, it has been working so far on another similar system (to which I no longer have easy access) and since ovms 7.2-1 isn't supported, either, I guess support isn't an issue. I think (from memory) that the changes introduced in VMS 7.2 set the dependency but if someone knows about something else I'd like to hear. Maybe I've just been lucky in the past.

A 10 point reward awaits anyone who can say: get the .pcsi file _here_ or _here_ is a decompress utility that will work.

Otherwise, I'm still looking for some vms 7.3-2 media because upgrading vms to 8.3 is my ultimate goal. Getting enough system time to do that won't happen soon. Upgrading to AS-7.3B should help with a more immediate problem and I can steal enough time to do that any night.

email: dphill46 (at) netscape (dot) net
Volker Halle
Honored Contributor

Re: PCSI$COMPRESSED for pre-7.3-2

Doug,

download the .PCSI$COMPRESSED file to a disk on any of your OpenVMS Alpha systems. Insert the OpenVMS Alpha V8.3 CD and boot from it. Decompress the file and reboot from your original disk. Just needs a 'little bit' of downtime.

Alternatively - if you cannot allow any downtime - try using PersonalAlpha:

- create a LD container file on your OpenVMS system, INIT and MOUNT it and copy the .PCSI$COMPRESSED file onto it. Dismount and LD DISC it and copy it to a Windows system - as a .VDISK file.
- download and install PersonalAlpha
- configure PersonalALpha to use your local CDrom and the .vdisk file
- put the OpenVMS Alpha V8.3 CD into your CDrom drive and boot from it
- MOUNT the .vdisk and decompress
- shutdown PersonalAlpha
- copy the .vdisk file back to your OpenVMS system and LD CONNECT it and mount it from OpenVMS

Volker.
Doug Phillips
Trusted Contributor

Re: PCSI$COMPRESSED for pre-7.3-2

I was able to copy the decompressed file from a v7.3-2 alpha to a Windows server (that unfortunately limits what I can do remotely on that network) and then get it from there to my local PC and then kermit it over to the v7.2-1 system. A major PITA but it didn't require additional down time or tools I don't have.

Thanks to all for your replies.
Doug Phillips
Trusted Contributor

Re: PCSI$COMPRESSED for pre-7.3-2

Closed.