Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

PHP5 for OpenVMS

 
Robert Atkinson
Respected Contributor

Re: PHP5 for OpenVMS

The latest HP release of PHP 5 does have a number of 'features', so make sure you thoroughly test it before letting it near your Production systems.

Rob.
Simon L Jackson
Occasional Advisor

Re: PHP5 for OpenVMS

HP have just released CSWS_PHP 2.1 at http://h71000.www7.hp.com/openvms/products/ips/apache/csws_php.html for which they have also released the sources at http://h71000.www7.hp.com/openvms/products/ips/apache/csws_php_source.html

Now to build PHP_SOAP...
Robert Atkinson
Respected Contributor

Re: PHP5 for OpenVMS

Top release notes, I see :-

"New features included in CSWS_PHP V2.1 are as follows:

· CSWS_PHP V2.1 provides improved performance, enhanced GD extension, and enhanced session extension. It works with the HP Secure Web Server Version 1.3-1 and 2.1 and higher. It does not work with SWS Version 2.0."
Simon L Jackson
Occasional Advisor

Re: PHP5 for OpenVMS

Yes.

I couldn't actually discern what has changes since 2.0 back in May other than the source now being available, which is not even mentioned in the highlights.

I have unpacked the sources and php_soap is present, so I am hopeful at this stage that it might be possible to build it. I wish HP would start adding some more modules now they have built PHP5.

My wish list includes:

php_soap
http (pecl)
ps (pecl)

Any other requests out there?
RF Thomas
Frequent Advisor

Re: PHP5 for OpenVMS

We have been using PHP 2.1 since its release was posted on this thread. The only problem that has come up involved some in-house code the needed to have the file locations in opns changed due to a change in (correction of???) the file name parsing.

The new version has allowed us to install and test several software packages that either needed heavy patching or would not run at all under the prior version.

The MySQL support is vastly improved allowing fuller use of MySQL 5.1

A problem area involves the implementation of the PHP email functions. Many of the packages that we have installed can not properly interface with the SMTP and VMS Mail systems.
Robert Atkinson
Respected Contributor

Re: PHP5 for OpenVMS

Personally, I'd like to see more VMS integration.

Ability to read VMS files by index would be great. Integration with some of the main lexical functions, especially management of queues and UAF.

I could probably give a 50 page list!!
Simon L Jackson
Occasional Advisor

Re: PHP5 for OpenVMS

Re sending emails.

We have found on OpenVMS and other platforms (including Linux and Tru64) that the PEAR Mail packages are better than the inbuilt API. As PEAR doesn't seem to be part of CSWS_PHP 2.1 (must add that to the list) I tend to PEAR install stuff on a Linux or Tru64 machine and just copy the appropriate scripts onto OpenVMS. This approach worked under PHP4 and I will be testing it shortly under PHP5.
Highlighted
Simon L Jackson
Occasional Advisor

Re: PHP5 for OpenVMS

We have also built some of the missing pieces.

See http://www.sysworks.biz/swpub_php.php for some details.

Please note that we had to extend PHPSHR by adding vectors for the additional shareable images to use. The HTTP and SOAP extensions seem to work well with web services written in PHP and Ruby on Linux. If anyone needs more information or is interested in other extensions, please don't hesitate to contact me.