Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Pathworks 7.3A on OpenVMS Alpha 7.3-1

Peter Harper_5
Occasional Advisor

Pathworks 7.3A on OpenVMS Alpha 7.3-1

Hello,

I have a small problem with the transfer of files from a SAP system to an OpenVMS Pathworks share. The files are small (approx 40-50K) and seem to copy fine, however it seems like the file is not being closed for up to 30 seconds e.g if i do a DIR/SIZE=ALL on VMS i see the 0/20 allocation for a period of time and after the delay the file closes. I have found a patch on the HP web site which looks like it might address the problem but when i download it, decompress it and then verify it I get the attached errors.

Any help would be appreciated
8 REPLIES
Paul Nunez
Respected Contributor

Re: Pathworks 7.3A on OpenVMS Alpha 7.3-1

Hi Peter,

You need to disable Opportunistic Locking (aka OpLocks):

$ edit pwrk$commonroot:[000000]pwrk.ini

add these lines (if they don't exist);

[LMSRV]
ENABLE_OPLOCKING = 0 ! Disables OpLocks

then restart AdvSrv when you can.

As for the error in the eco1 kit, I'm not familiar with that. I take it you downloaded it from the public FTP site? Do other PRODUCT commands also fail, ie.,


$ PRODUCT EXTRACT RELEASE_NOTES ADVANCEDSERVER

I've seen some recent internal postings about corruption in some of the ECOs kits posted on the FTP site, so perhaps this kit is corrupted too (though this is the first time I'm hearing of the problem for this ECO kit).

Let us know...

Paul Nunez
HP Services
Brad McCusker
Respected Contributor

Re: Pathworks 7.3A on OpenVMS Alpha 7.3-1

Paul's note about OpLocks should solve the immediate problem you report, with or without the ECO.

However, you definitiely should get that ECO installed. It will be worth your time to find out what went wrong and get that kit installed.

Brad McCusker
Brad McCusker
Software Concepts International
Edwin Gersbach_1
Occasional Visitor

Re: Pathworks 7.3A on OpenVMS Alpha 7.3-1

The release notes say [PLM] section for this parameter rather than [LMSRV] !?!
[PLM] has wirked for me.
Edwin Gersbach_1
Occasional Visitor

Re: Pathworks 7.3A on OpenVMS Alpha 7.3-1

The release notes say [PLM] section for this parameter rather than [LMSRV] !?!
[PLM] has worked for me.
Peter Harper_5
Occasional Advisor

Re: Pathworks 7.3A on OpenVMS Alpha 7.3-1

Many Thanks all, turning off oportunistic locking solved the problem. Just need to look into getting an un-corrupted version of the ECO kit now.

Thanks Again
Peter Harper_5
Occasional Advisor

Re: Pathworks 7.3A on OpenVMS Alpha 7.3-1

Many Thanks all, turning off oportunistic locking solved the problem. Just need to look into getting an un-corrupted version of the ECO kit now.

Thanks Again
Paul Nunez
Respected Contributor

Re: Pathworks 7.3A on OpenVMS Alpha 7.3-1

Hi Edwin,

Thanks - I goofed on the section. It's definitely [PLM], not [LMSRV].

Sorry for any confusion I've caused...

Paul
Paul Nunez
Respected Contributor

Re: Pathworks 7.3A on OpenVMS Alpha 7.3-1

I should also mention that you can confirm whether oplocking is enabled/disabled by searching the server log file:

$ search pwrk$lmlogs:pwrk$lmsrv_.log oplocking

Paul