Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Please enter date and time with frozen keyboard

 
SOLVED
Go to solution
gbarcalow
Occasional Advisor

Please enter date and time with frozen keyboard

I am working on an HP I64 RX2660 with OpenVMS V8.4

 

Last night I was trying to install/enable ACME DLAP authentication to work with Windows AD on our new used server (not yet in production). Twice I was able to reboot after installing the software without issue, once as part of the install process, and once to make sure the ACME process started on boot. Later, while attempting to whole process to work I also use the 'set time' because the vms server and the windows network were off by more than 8 minutes. Later, after being frustrated at my lack of progress, I decided to reboot to see if that would change anything and boy did it. The server didn't come back up. When I went to the console I saw the words 'please enter date and time (format)' repeating over and over. I tried to enter the date and time but the keyboard didn't work. Seeing no other options, I powered the machine off then back on. Same result, 'please enter date and time' and no keyboard input. powered off again, this time at the boot menu I decided to try the keyboard, and it worked. I was able to successfully navigate the the bios and set the date and time there (for lack of something better to try.) Continued the boot, same result. 'please enter date and time' and no keyboard. My last ditch effort from the internet was to try changing the CMOS battery, with the same results. So, I am completly at a loss as to what to do; I am not really what you would call VMS proficient. Any advise would be greatly appreciated.

 

*** UPDATE ***

I attached my laptop to the console port on the server. I was able to see the EFI boot menu, but once VMS started to boot my serial connection was lost. It feels to me like the prompt is presented before the USB drivers are loaded for the keyboard. I also disconnected the standard USB keyboard (part of the kvm) is see if it was interfering.

5 REPLIES 5
Steven Schweda
Honored Contributor
Solution

Re: Please enter date and time with frozen keyboard

   My most modern system is an rx2600 (with an "Integrated Lights-Out
for HP Integrity and HP 9000 - Management Processor (MP)"), so I know
nothing, and I normally Telnet into the ILO for console access to the
thing, so I wouldn't bet on my info being useful in your situation,
but...

   First, "an HP I64 RX2660" doesn't tell me much about the
configuration of your system, or what you're using as a console
terminal, or how it's connected.  But, if VMS can't hear your keyboard,
then I'd try to discover what the system thinks is the console, and if
that looks dicey, then I'd play with it.  It's been a long time since I
tried to use a serial port for a console connection on mine, but I may
dimly recall that it needs to be configured properly.  The actual system
and/or VMS docs may say more, but you may need to have the right (one)
device/configuration selected for VMS to find it.

   Around here, if I get into the "EFI Boot Manager ver 1.10 [14.61]
Firmware ver 2.31 [4411]", and select "Boot Option Maintenance Menu",
then I can look at and "Select Active Console {Output|Input|Error}
Devices", where I see stuff like:

 

EFI Boot Maintenance Manager ver 1.10 [14.61]

Select the Console Input Device(s)

      Acpi(PNP0501,0)/Uart(9600 N81)/VenMsg(PcAnsi)                 
      Acpi(PNP0501,0)/Uart(9600 N81)/VenMsg(Vt100)                  
      Acpi(PNP0501,0)/Uart(9600 N81)/VenMsg(Vt100+)                 
      Acpi(PNP0501,0)/Uart(9600 N81)/VenMsg(VtUtf8)                 
      Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(PcAnsi)      
    * Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(Vt100)       
      Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(Vt100+)      
      Acpi(HWP0002,700)/Pci(1|1)/Uart(9600 N81)/VenMsg(VtUtf8)      
    Save Settings to NVRAM                                          
    Exit                                                            

   I don't remember what's what in that list, but apparently, the
HWP0002 stuff could be associated with the ILO gizmo, so perhaps the
PNP0501 stuff would be associated with a normal (non-ILO?) serial port
(if there is such a thing).

   If I were desperate, and couldn't find the right manual, I'd try

selecting _one_ of those Vt100 things (and the corresponding one in the
Output and Error menus), and see if it makes any difference.  (My very
dim recollection is that you can't have more than one device selected
(on each menu), but that could be more false-memory syndrome.)

   If you don't wish to rely on your readers' psychic powers (mine are
weak), then copy+paste is your friend.  For example, I don't know what
"the boot menu" means to you.  To me, these things offer a menu-rich
environment, and most of them are related somehow to booting.  Actual
quotation tends to be more helpful than vague descriptions or
interpretations.

Hoff
Honored Contributor

Re: Please enter date and time with frozen keyboard

Chances are, you're on the wrong serial port, or the console ports are not set up correctly.   Get the MP working and connect that way; don't try to use the COM ports, if there's an iLO around.  Also see this thread for an errant five-year-sanity-check bug that hits OpenVMS I64 including down-revision V8.4, which may well be the root issue here, too.

gbarcalow
Occasional Advisor

Re: Please enter date and time with frozen keyboard

In the EFI boot menu there were only two options for Console. The first read VGA and was set as primary, the second read serial and was set as secondary. I swapped them so that serial was primary, rebooted, connected using the serial cable and was able to enter the date and time at the prompt. But for some reason on this boot VMS loaded the GUI, it's not done that before.

 

I tried plugging the iLo port into the switch and setting it's ip/network settings via the serial MP, but I have not been able to make a connection via telnet, ssh or using a web brower.

gbarcalow
Occasional Advisor

Re: Please enter date and time with frozen keyboard

Upon reboot I ran into the problem again 'Please enter date and time'. A little more digging and I found these sites:

 

http://h71000.www7.hp.com/doc/84final/6048/6048pro_103.html

http://www.openvmshobbyist.com/forum/viewthread.php?forum_id=150&thread_id=1357

 

SYSGEN> SHOW TIMEPROMPTWAIT

 

My parameter's value was 65535

 

Changes the parameter, rebooted and no prompt.  Except for that whole GUI thing, I am back in business.

 

$ SET DEF SYS$SYSTEM

$ RUN SYSGEN

SYSGEN> USE CURRENT
SYSGEN> SET TIMEPROMPTWAIT 0
SYSGEN> WRITE CURRENT

 

 

Bob Blunt
Respected Contributor

Re: Please enter date and time with frozen keyboard

I didn't see this in any of the links.  If you review closely system management info about installing and setting up an Integrity system for OpenVMS there's mention that the VGA interface is NOT supported as a console.  I don't recall the exact wording but IF you have an Integrity console setup for VGA this is precisely what'll happen.  When your system is in the process of booting OpenVMS and prompts for anything (including, of course, date/time) the system will hang and you won't be able to see the prompt or enter the correct data to answer the prompt.  As long as you don't get a prompt you're FINE and the system will boot as expected.  The expectation is that an Integrity running OpenVMS will be setup with that console parameter set to "serial."

bob