Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem installing OVMS 8.3A Update 11

 
SOLVED
Go to solution
EdgarZamora_1
Respected Contributor

Problem installing OVMS 8.3A Update 11

VMS83A_UPDATE-V1100 came out two days ago. I just tried installing it on a system that hadn't been patched in about 6 months and got an error. The installed patches on this system are (just showing the recent ones):

------------------------------------ ----------- ----------- --- -----------
PRODUCT KIT TYPE OPERATION VAL DATE
------------------------------------ ----------- ----------- --- -----------
DEC AXPVMS VMS83A_ACRTL V5.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_DELETE V1.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_DRIVER V2.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_FIBRE_SCSI V6.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_IPC V1.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_MAILSHR V2.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_NETACP V1.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_SHADOWING V3.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_SYS V10.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_TZ V1.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_UPDATE V9.0 Patch Install Val 25-MAY-2009
DEC AXPVMS VMS83A_USB V1.0 Patch Install Val 25-MAY-2009
HP AXPVMS AVAIL_MAN_ANA_SRVR V3.0-2 Full LP Install Val 20-MAY-2009
HP VMS AVAIL_MAN_COL V3.0-2A Full LP Install Val 20-MAY-2009
DEC AXPVMS TCPIP V5.6-9ECO3 Full LP Install Val 20-JAN-2009
DEC AXPVMS TCPIP V5.6-9ECO2 Full LP Remove - 20-JAN-2009

Here's the error I got:

CLCC1> prod install *

Performing product kit validation of signed kits ...
%PCSI-I-VALPASSED, validation of $1$DGA169:[USERS.][EZAMORA.PATCHES]DEC-AXPVMS-V
MS83A_UPDATE-V1100--4.PCSI$COMPRESSED;1 succeeded

The following product has been selected:
DEC AXPVMS VMS83A_UPDATE V11.0 Patch (remedial update)

Do you want to continue? [YES]

Configuration phase starting ...

You will be asked to choose options, if any, for each selected product and for
any products that may be installed to satisfy software dependency requirements.

Configuring DEC AXPVMS VMS83A_UPDATE V11.0: OpenVMS Alpha V8.3 UPDATE V11.0

Recovery data will be saved which will allow you to un-install
this kit. In the past, kit installations provided some level
of recovery capability by renaming all replaced files to
file_name.ext_OLD. If you wish, you can continue to do this.

Note that this will triple the disk space required for
this kit - one for the installed files, once for the saved
recovery data and once for the file_name.ext_OLD files.

Do you wish to have replaced files renamed
to file_name.ext_OLD [NO] ?:

Files will not be renamed

* This product does not have any configuration options.

Special Installation Instructions


In addition to the reboot, some kits that have been included in the
VMS83A_UPDATE-V1100 kit have specific steps that must be performed before
or after the installation of the VMS83A_UPDATE-V1100 patch kit. Refer to
section 7.5 "Special Installation Instructions" in the VMS83A_UPDATE-V1100
release notes for any such requirements BEFORE attempting to install the
VMS83A_UPDATE-V1100 patch kit.


Do you want to continue? [YES]

<< System Disk Backup >>


This kit will make functional changes to your system.
Before installing this kit you should make a backup
copy of your system disk. If you do not make a copy
of your system disk you will not be able to restore
your system to a pre-kit installation state.


Do you want to continue? [YES]

Installing this patch kit requires a reboot.


Hewlett Packard strongly recommends that you reboot your
system immediately after installation of this kit. The
images in this kit will not fully take effect until the
system is rebooted. However, if you do not re-boot
immediately after kit installation, the system may become
unstable and may not function as expected.

If you have other nodes in your VMS cluster, they must also
be rebooted in order to make use of the new image(s). If it
is not possible or convenient to reboot the entire cluster
at this time, a rolling re-boot (kit installation and reboot
on one node at a time) may be performed.


Do you want to continue? [YES]

Execution phase starting ...

The following product will be installed to destination:
DEC AXPVMS VMS83A_UPDATE V11.0 DISK$DEVSYS:[VMS$COMMON.]
%PCSI-I-RETAIN, file [SYSHLP]VMS83A_HYPERSORT-V0100.RELEASE_NOTES was not replac
ed because file from kit has lower generation number
%PCSI-I-RETAIN, file [SYSHLP]VMS83A_MOUNT96-V0100.RELEASE_NOTES was not replaced
because file from kit has lower generation number

Portion done: 0%...10%...20%...30%...40%...50%...60%...70%...80%
%PCSI-I-PRCOUTPUT, output from subprocess follows ...
%IMGACT-F-SYMVECMIS, shareable image symbol vector table mismatch
-IMGACT-F-FIXUPERR, error when PTHREAD$RTL referenced SYS$BASE_IMAGE

%PCSI-E-INSTALLERR, error executing DCL INSTALL command
-IMGACT-F-SYMVECMIS, shareable image symbol vector table mismatch
%PCSI-E-OPFAILED, operation failed
Terminating is strongly recommended. Do you want to terminate? [YES]
%PCSI-E-CANCEL_WIP, termination resulted in an incomplete modification to the sy
stem
%PCSI-E-S_OPCAN, operation cancelled by request

Recovery pass starting ...


Recovery pass concluded

%PCSI-E-S_OPFAIL, operation failed
%PCSIUI-E-ABORT, operation terminated due to an unrecoverable error condition

Looks like it has something to do with PTHREAD. Just posting this as a warning to be careful... I'm still digging deeper.
33 REPLIES 33
EdgarZamora_1
Respected Contributor

Re: Problem installing OVMS 8.3A Update 11

My initial guess, from quickly looking at this, is that I need to be patched to at least VMS83A_SYS V12.0 for this to work. I will try to install an earlier update kit then reinstall this update kit.
Willem Grooters
Honored Contributor

Re: Problem installing OVMS 8.3A Update 11

Your remark makes me think: if there is such a dependency, it should have been mentioned in the relase notes; and perhaps you may overlooked it?
If it isn't there, it's one more thing that needs to be 'tuned' in Bangalore.
Willem Grooters
OpenVMS Developer & System Manager
Hoff
Honored Contributor
Solution

Re: Problem installing OVMS 8.3A Update 11

It's time to ring up the HP support center. At a minimum, the kit appears to be missing a prerequisite kit check. (And it appears this update kit either isn't cumulative, or there's something odd in your local environment.)

pthread$rtl was linked against a different system image. Probably newer, but...

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1362613

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1367672

The obvious test here would be VMS83A_SYS-V1300 followed by a reboot, followed by VMS83A_UPDATE-V1100.

And on the subject of release notes, there's no release notes file included alongside the VMS83A_UPDATE-V1100 kit, either. Looks like I'll have to download it and unpack it and see if there's a copy included inside.
EdgarZamora_1
Respected Contributor

Re: Problem installing OVMS 8.3A Update 11

Ok... here's what I did... restored the system disk from backup... installed VMS83A_UPDATE V10.0 then rebooted... tried to install VMS83A_UPDATE V11.0... it failed again with the same error. I then installed VMS83A_SYS-V1300 (per Hoff's suggestion)... rebooted... then installed VMS83A_UPDATE V11.0 with no problem.

There is nothing in the Update 11 Release Notes that states this pre-requisite.
Volker Halle
Honored Contributor

Re: Problem installing OVMS 8.3A Update 11

Edgar,

the quality of the OpenVMS patches seems to have severely dropped in the last couple of months. Is it only me noticing that ? Please consider to raise this issue with your HP OpenVMS service representatives.

Volker.
EdgarZamora_1
Respected Contributor

Re: Problem installing OVMS 8.3A Update 11

Volker, yes I have noticed that. I started a "project" in September to patch our systems to current levels. I encountered (and also read about) problems with patches around that time and decided to put my patching on hold. I even told my management I was holding off on patches because of quality problems with the patches. When I saw the Update 11 come out two days ago, I figured maybe HP fixed those problems with this update. I guess I was wrong.

I have a big meeting with HP people next Thursday. I will surely bring this up with the OVMS Ambassador who will be there.
Hoff
Honored Contributor

Re: Problem installing OVMS 8.3A Update 11

>I have a big meeting with HP people next Thursday. I will surely bring this up with the OVMS Ambassador who will be there.

Say hello for Volker and I. :-)
Jan van den Boogaard_1
Frequent Advisor

Re: Problem installing OVMS 8.3A Update 11

I saw exactly the same error. Normally the ONLY prerequisite for UPDATE kits of all flavours is the latest VMSxyz_PCSI patch.
To my believe the UPDATE kit is buggy once again, as Volker pointed out.

Re: Problem installing OVMS 8.3A Update 11

Hi Edgar,

Thanks for reporting this. We have now put this kit on hold. We will work on this and release a new kit.

Best Regards,
Sandeep
Jon Pinkley
Honored Contributor

Re: Problem installing OVMS 8.3A Update 11

The VMS83A_PTHEAD-V0200 patch is picky.

I just upgraded a system for 7.3-2 to 8.3 and applied the then current VMS83A_UPDATE-v1000 and then all the other patches that were not included (only latest versions). I had scripted updates, and put PTHREAD last, but it failed. Logging out and back in wasn't sufficient, it required a reboot before PTHREAD would install. But I was then able to install TCPIP 56 ECO4 without a reboot. So there was the AUTOGEN reboot, then applied PCSI, loggedout and back in, applied system update 10, rebooted, then applied VMS83A_TZ, VMS83A_JOBCTL, VMS83A_LOGIN, VMS83A_BACKUP, VMS83A_TDF, VMS83A_XFC, VMS83A_SHADOWING, VMS83A_FIBRE_SCSI, VMS83A_RMS, VMS83A_SYS.

REBOOT required here

Then installed VMS83A_PTHREAD, TCPIP 5.6-9ECO4

Reboot, then other layered products.

Attached is a product show history and the command procedure I used to apply the post update 10 patches.

This seemed to work.
it depends

Re: Problem installing OVMS 8.3A Update 11

Jon,

PTHREAD kit has a dependency on SYS and TDF kits. The SYS kit, however, requires are reboot. Hence, the system should be rebooted before installing the PTHREAD kit (and after installing SYS kit).

Best Regards,
Sandeep
EdgarZamora_1
Respected Contributor

Re: Problem installing OVMS 8.3A Update 11

"Thanks for reporting this. We have now put this kit on hold. We will work on this and release a new kit."


Sandeep, thank you for the quick response. We appreciate HP engineering listening to us here.
EdgarZamora_1
Respected Contributor

Re: Problem installing OVMS 8.3A Update 11

To close out this thread... FYI, HP updated the release notes of VMS83A_UPDATE-V1100 basically saying if you encounter this error, ignore the error message and continue with the installation...

7.5 Special Installation Instructions:

During the installation of this UPDATE kit, you may see the
following error during the installation of PTHREAD kit.

%PCSI-I-PRCOUTPUT, output from subprocess follows ...
%IMGACT-F-SYMVECMIS, shareable image symbol vector table mismatch
-IMGACT-F-FIXUPERR, error when PTHREAD$RTL referenced
SYS$BASE_IMAGE

%PCSI-E-INSTALLERR, error executing DCL INSTALL command
-IMGACT-F-SYMVECMIS, shareable image symbol vector table mismatch
%PCSI-E-OPFAILED, operation failed Terminating is strongly
recommended. Do you want to terminate? [YES]

You should answer "NO" to this question and allow the installation
to continue. PTHREAD kit has a dependency on the SYS kit. PTHREAD
kit expects that the system be rebooted after installing SYS kit.
The error is thrown as both the dependent kits are part of the same
UPDATE kit, and there is no interim reboot of the system.

It is important to note that once the UPDATE kit is installed and
the system is rebooted, this error will not impact the system and
the correct images will be in use.
Hoff
Honored Contributor

Re: Problem installing OVMS 8.3A Update 11

So we have a kit that tosses an error, and (not having looked) we probably now have two different V11 kits around now with two sets of checksums, differing by the release notes?
EdgarZamora_1
Respected Contributor

Re: Problem installing OVMS 8.3A Update 11

Well I have the original kit and the new kit so I checked the checksums and yes, they are different (as expected).

Re: Problem installing OVMS 8.3A Update 11

Just wondering why HP would release a patch with an error in it and then tell the customer to ignore it? Why not fix the patch to handle the error?
Hoff
Honored Contributor

Re: Problem installing OVMS 8.3A Update 11

It looks like the PCSI kit is trying to install an image, and it's detecting a mismatch. The install will be invoked again at bootstrap. Things might get hairy if you kept running after loading this patch, though.
Jan van den Boogaard_1
Frequent Advisor

Re: Problem installing OVMS 8.3A Update 11

No errors were seen when updating 1 of our systems with the patch order below ( one reboot after SYS V16 en one reboot after UPDATE V11 and INSTALL REPLACE SYS$LIBRARY:PTHREAD$RTL.EXE after installing PTHREAD V2 (no reboot) )


$ prod sh hist
------------------------------------ ----------- ----------- --- -----------
PRODUCT KIT TYPE OPERATION VAL DATE
------------------------------------ ----------- ----------- --- -----------
DEC AXPVMS VMS83A_UPDATE V11.0 Patch Install Val 14-DEC-2009
DEC AXPVMS VMS83A_PTHREAD V2.0 Patch Install Val 14-DEC-2009
DEC AXPVMS VMS83A_TDF V1.0 Patch Install Val 14-DEC-2009
DEC AXPVMS VMS83A_SYS V16.0 Patch Install Val 14-DEC-2009
DEC AXPVMS TCPIP V5.6-9ECO4 Full LP Install Val 14-OCT-2009
DEC AXPVMS TCPIP V5.6-9ECO3 Full LP Remove - 14-OCT-2009
HP VMS TDC V2.3-18 Full LP Install Val 09-JUL-2009
DEC AXPVMS VMS83A_LOGIN V2.0 Patch Install Val 09-JUL-2009
DEC AXPVMS VMS83A_JOBCTL V3.0 Patch Install Val 09-JUL-2009
DEC AXPVMS VMS83A_SHADOWING V3.0 Patch Install Val 09-JUL-2009
DEC AXPVMS VMS83A_TZ V1.0 Patch Install Val 09-JUL-2009
DEC AXPVMS VMS83A_COPY V2.0 Patch Install Val 09-JUL-2009
DEC AXPVMS VMS83A_UPDATE V10.0 Patch Install Val 09-JUL-2009
EdgarZamora_1
Respected Contributor

Re: Problem installing OVMS 8.3A Update 11

> No errors were seen when updating 1 of our systems with the patch
> order below ( one reboot after SYS V16 en one reboot after
> UPDATE V11 and INSTALL REPLACE SYS$LIBRARY:PTHREAD$RTL.EXE
> after installing PTHREAD V2 (no reboot) )
> $ prod sh hist
> ------------------------------------ ----------- ----------- --- -----------
> PRODUCT KIT TYPE OPERATION VAL DATE
> ------------------------------------ ----------- ----------- --- -----------
> DEC AXPVMS VMS83A_UPDATE V11.0 Patch > Install Val 14-DEC-2009
> DEC AXPVMS VMS83A_PTHREAD V2.0 Patch Install Val 14-DEC-2009
> DEC AXPVMS VMS83A_TDF V1.0 Patch Install Val 14-DEC-2009
> DEC AXPVMS VMS83A_SYS V16.0 Patch Install Val 14-DEC-2009

Right... but you really don't need to install PTHREAD and TDF separately since they're in the UPDATE kit. Install SYS V16, reboot, then install Update V11 will work fine.

EdgarZamora_1
Respected Contributor

Re: Problem installing OVMS 8.3A Update 11

It's a Monday... please disregard my previous reply... that totally won't work.

The easiest way to do this is actually just install UPDATE V11 and if you get the PTHREAD mismatch error, just elect to continue. Then reboot after that.
Hoff
Honored Contributor

Re: Problem installing OVMS 8.3A Update 11

There's a report in c.o.v. of %PCSI-W-NOTFNDKIT errors arising with the second V11.0 kit, when the previous V11 kit was installed on the box.
Steve Reece_3
Trusted Contributor

Re: Problem installing OVMS 8.3A Update 11

Is there any reason why the second Update V11 kit shouldn't have been v12 since they have different checksums? Surely it would have made for better clarity...?
Rich Hearn
Regular Advisor

Re: Problem installing OVMS 8.3A Update 11

I did a browse of all VMS patches and did not see any vms83a_update-v* kits as of 14:00 (utc)17-Dec-2009. Has it/they been "piulled" again?

Tnx,
Rich
_
Volker Halle
Honored Contributor

Re: Problem installing OVMS 8.3A Update 11

Rich,

yes, there were new problems with the re-released VMS83A_UPDATE-V1100 kit (see recent post in comp.os.vms).

Volker.