Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem starting DECwindows Motif on a PC X-Server

SOLVED
Go to solution
Derek Gorman
Occasional Contributor

Problem starting DECwindows Motif on a PC X-Server

I am running DECwindows Motif V1.6 using the New Desktop on an Alphaserver DS10 under OpenVMS V8.3. My PC X-Server is X-Deep/32 and is networked to the DS10 using TCP/IP.

TCP/IP services are configured and operational under VMS and the XDM service is enabled. I created and edited decw$private_apps_setup.com to include the following lines after "do_default":

set display/create/transport=tcpip -
/executive_mode/node=192.... my_display
define/system/exec my_display 'f$trnlnm("my_display")

XDMCP is configured in the indirect mode within X-Deep/32 and when I start X-Deep/32 the DECwindows login screen does not appear. If I login to the system at the console and execute the following commands:

define decw$display my_display
@sys$manager:decw$startsm

a DECwindows desktop (old style) appears on the PC's X-Server. If I logout of that session, the New Desktop login screen appears and I can login to the New Desktop and everything runs fine, even stoping and restarting X-Deep/32, until the DS10 is rebooted.

My question is how do I configure DECwindows correctly on the DS10 to allow that process to happen automatically when I start X-Deep/32 on the PC? I realize that the above happens to work for one PC to DECwindows connection and I would like to have the system configured to allow multiple PC's connections. Any help would be greatly appreciated. Thanks.
4 REPLIES
Joseph Huber_1
Honored Contributor
Solution

Re: Problem starting DECwindows Motif on a PC X-Server


I don't know X-Deep, but the mode "indirect" could be the reason.
Did You try a direct mode , maybe called "node query" or "broadcast", and You have to select the DS10 node amongst the list of responding nodes ?
http://www.mpp.mpg.de/~huber
Steve-Thompson
Regular Advisor

Re: Problem starting DECwindows Motif on a PC X-Server

Hi Derek

I had a few problems with something similar.
I got round them looking at the messages that my Xserver produced on the PC.
It's your best bet!

Could even be a exit somewhere in SYLOGIN thats blocking you!
Joseph Huber_1
Honored Contributor

Re: Problem starting DECwindows Motif on a PC X-Server


Almost forgot: on the VMS side there must be of course XDM enabled using tcpip$config, and afterwards the access control setup in
sys$specific:[tcpip$xdm]:
see the *.template files there, copy to *.txt, and edit the *.txt files to reflect Your environment.
http://www.mpp.mpg.de/~huber
Steve-Thompson
Regular Advisor

Re: Problem starting DECwindows Motif on a PC X-Server

Hi Derek

As I said previously I resolved other "X" problems looking at the log output!

XDM
On the VMS box do a $netstat (@tcpip$define_commands) and you should see an active connection at 177.
If you dont, as Joseph correctly says you have to configure the various "X" files.
Just rename the files and restart the service and it should work!

Next on the PC, does your Xprogram have a "Xbrowser".... You should see any server offering XDM.
With no changes made, my VMS box appeared as "XDMCP:query" .... and "Willing to Manage".

Saludos
Steven