Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem starting TOMCAT

Jack Trachtman
Super Advisor

Problem starting TOMCAT

I just downloaded and installed CSWS, CSWS_PHP, CSWS_PERL, and CSWS_JAVA (v3.0)to a VMS V8.2 system. The first three start up and I can get to the confirming test pages.

When I try to start TOMCAT from the menu(w/CSWS down per doc), the log shows the following error:

...
$ j_cmd "-V" "NLA0:" "-V" "sys$scratch:apache$jakarta_secparamfile.00000EB6" -
"org.apache.catalina.startup.Bootstrap" -
"-V" "NLA0:" "start"

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/catalina/startup/Bootstrap (Unsupported major.minor version 48.0)
...

Can anyone explain and help me with this?

TIA
4 REPLIES
Wim Van den Wyngaert
Honored Contributor

Re: Problem starting TOMCAT

I would say that your java version is too low.

Wim

Wim
Jack Trachtman
Super Advisor

Re: Problem starting TOMCAT

$ PROD SHO HIST *JAVA*
....
.... CSWS_JAVA v3.0 .....
.... JAVA150 V1.5-1 ...
....
ptrskg
Frequent Advisor

Re: Problem starting TOMCAT

Hi Jack,

In the release notes, http://h71000.www7.hp.com/openvms/products/ips/apache/csws_java_relnotes.html - Software Prerequisites, I see that JAVA 1.4.2 is the prefered version.
We have some problems with the 1.5 version so I recommend you to try the latest 1.4.2 version.

Peter
Jack Trachtman
Super Advisor

Re: Problem starting TOMCAT

Found my problem.

I noticed that when running APACHE$JAKARTA.COM, that some info scrolled off the screen. Looking at that info I saw that an old JAVA kit was being accessed.

Looking in APACHE$JAKARTA_CONFIG.COM, I saw that this script was looking in SYS$COMMON for JAVA kits, and I had installed the JAVA SDK on another disk. Since I couldn't see how to pass the other disk location, I made a temp edit to the script to hard code the JDK location and reran it. TOMCAT starts now.

Thanks for the feedback.