Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem upgrading bl860c from OpenVMS 8.3-1H1 to OpenVMS 8.4.

 
SOLVED
Go to solution
The Brit
Honored Contributor

Problem upgrading bl860c from OpenVMS 8.3-1H1 to OpenVMS 8.4.

45 minutes in to the UPGRADE (on bl860c), I get the following message.

 

Portion done: 0%...10%...20%...30%...40%...50%
 
%PCSI-E-WRITEERR, error writing DISK$SYSI64_V84:[VMS$COMMON.][SYSHLP]HELPLIB.HLB;2
-LBR-E-DUPKEY, duplicate key in index
%PCSI-E-OPFAILED, operation failed


Terminating is strongly recommended.  Do you want to terminate? [YES]

 

I seem to recall seeing somewhere that this can be overruled!!      Can anyone shed light on how I should deal with this.

 

Thanks in advance for any help

 

Dave 

4 REPLIES 4
The Brit
Honored Contributor
Solution

Re: Problem upgrading bl860c from OpenVMS 8.3-1H1 to OpenVMS 8.4.

From HP Support:::

 

Issue
When upgrading from V8.3-1H1 to V8.4 the following error message is displayed:

error writing DISK$ROCVMSSYS2:[VMS$COMMON.][SYSHLP]HELPLIB.HLB;5 
-LBR-E-DUPKEY, duplicate key in index 
%PCSI-E-OPFAILED, operation failed 
 
The issue was caused by duplicate entries in the library as seen from the original 8.3-1H1 library prior to the upgrade.
 
$ LIBRARY/LIST HELPLIB.HLB;4(pre-upgrade library)

TN3270           inserted 21-DEC-2008 16:29:10
traceroute       inserted 28-JAN-2008 20:38:37ß
traceroute       inserted 28-JAN-2008 20:47:04ß
traceroute       inserted 21-DEC-2008 16:29:10ß
TYPE             inserted 10-NOV-2010 18:43:15
 
The installation was not aborted but allowed to continue.     After the upgrade there were no duplicate entries on the new 8.4 system.

TN3270           inserted 19-DEC-2010 14:32:26
traceroute       inserted 19-DEC-2010 14:32:26
TYPE             inserted 19-DEC-2010 14:25:51
 
 
Solution
 
In this case there is no need for further action as the system help library is now in order.
This symptom is currently under review in OpenVMS Engineering.
 
NOTE:     If the installation was aborted a possible workaround as tested, based on data collected namely original system help library SYS$HELP:HELPLIB.HLB could be:
 
Use a temporary directory and copy the system help library to it.

$library/extract=*/output=myhelp HELPLIB.HLB
 
Doing comparisons on the 3 sets of help text showed no differences.     It is then possible to use the first set of text beginning with:

       1  traceroute
          SYNOPSIS 
 
Edit MYHELP.HLP and remove the double entries for traceroute text.

$library/create/help HELPLIB.HLB;99 MYHELP.HLP;2
 
Set security settings so that they match the existing sys$help:helplib.hlb
 
$ set file/protection=(System:RWED,Owner:RWED,Group:RE,World:RE)/owner=SYSTEM helplib.hlb;99

$ copy/log helplib.hlb;99 SYS$COMMON:[SYSHLP]HELPLIB.HLB;0
 
The repaired help library is now available for use without duplicate entries e.g extract from lib/list
TFF
TN3270
traceroute
TYPE
UCM
John Gillings
Honored Contributor

Re: Problem upgrading bl860c from OpenVMS 8.3-1H1 to OpenVMS 8.4.

Dave,

 

   HELPLIB is not critical. Worst case is you might have some help text which is out of date. That's not something that's likely to jeapordise production processing. In the past this type of error has occurred against various libraries, including STARLET. Even then, it's not a big deal on a system which isn't used for development  (especially since most programs link against IMAGELIB these days).

 

   If you ever see this again, look at the library being reported. If it's not something you know is critical for your system, I'd carry on and worry about patching it up later.

 

A crucible of informative mistakes
Maurizio De Tommaso_
Valued Contributor

Re: Problem upgrading bl860c from OpenVMS 8.3-1H1 to OpenVMS 8.4.

or in alternative you had to install the patch VMS831H1I_LIBRAR-V0100 before to start the upgrade to release V8.4 :

 

****************************
       ECO SUMMARY INFORMATION
    ****************************

    Release Date: 16-MAR-2011
    Kit Applies To: OpenVMS for Integrity Servers V8.3-1H1
    Approximate Kit Size: 509 blocks
    Installation Rating: INSTALL_3
    Reboot Required: No
    Special Install Instructions: No
    Superseded Kits: None
    Mandatory Kit Dependencies: VMS831H1I_UPDATE-V0800 or later
                                                           VMS831H1I_PCSI-V0200 or later
    Optional Kit Dependencies: None

    Checksums:
    VMS831H1I_LIBRAR-V0100.ZIPEXE

   Checksum: 3850198318
    HP-I64VMS-VMS831H1I_LIBRAR-V0100--4.PCSI$COMPRESSED Checksum: 879925802
    VMS831H1I_LIBRAR-V0100.ZIPEXE MD5 Checksum: 0987A67E82425A760CB73A2724A74A4E
    HP-I64VMS-VMS831H1I_LIBRAR-V0100--4.PCSI$COMPRESSED MD5 Checksum: 

    27050399AF85853FEF724A5D9C3C3BD9

 

.....

 

5.2.5  Librarian may insert duplicate help modules during a
                 replace operation.


               5.2.5.1  Problem Description:

               Librarian may insert duplicate help modules during a
               replace operation.  for eg.
               $LIBRARY/REPLACE/HELP  SYS$COMMON:[SYSHLP]HELPLIB.HLB;1
               TCPIP$TOP_LEVEL_HELP.HLP;1 /lo
               %LIBRAR-S-REPLACED, module TCPIP_Services replaced in
               SYS$COMMON:[SYSHLP]HELPLIB.HLB;1
               %LIBRAR-S-REPLACED, module tcpdump replaced in SYS$COMMON:[SYSHLP]HELPLIB.HLB;1
               %LIBRAR-S-INSERTED, module traceroute inserted in
               SYS$COMMON:[SYSHLP]HELPLIB.HLB;1 ==>**** Insert ***
               %LIBRAR-S-REPLACED, module TCPTRACE replaced in SYS$COMMON:[SYSHLP]HELPLIB.HLB;1
               %LIBRAR-S-REPLACED, module RPCGEN replaced in SYS$COMMON:[SYSHLP]HELPLIB.HLB;1
               %LIBRAR-S-REPLACED, module FINGER replaced in SYS$COMMON:[SYSHLP]HELPLIB.HLB;1

               This issue can  manifest as  below :

               1. Multiple help information displayed for a command or topic

               2. During an upgrade to 8.4 the following error may be reported.

               %PCSI-E-WRITEERR, error writing DISK$DEVSYS:[VMS$COMMON.][SYSHLP]HELPLIB.HLB;4
               -LBR-E-DUPKEY, duplicate key in index
               %PCSI-E-OPFAILED, operation failed
               Terminating is strongly recommended.  Do you want to terminate? [YES]

               3. Library/list provides multiple listings of the specific file.

               Images Affected:

                -  [SYSLIB]LBRSHR.EXE

 

               5.2.5.2  Quix and PTR cases reporting this problem:

 

                    5.2.5.2.1  Quix Cases

 

                    QXCM1001092445


                    5.2.5.2.2  PTR(s)

                    None.


               5.2.5.3  Release Version of  OpenVMS  that  will  contain this change:

 

               Next release of OpenVMS Integrity after V8.3-1h1


               5.2.5.4  Work-arounds:

               None.

 

6  FILES PATCHED OR REPLACED:


      o  [SYSLIB]LBRSHR.EXE (new image)

         Image Identification Information
         
         Image name: "LBRSHR"
         Image file identification: "I01-42"
         Image build identification: "0090090003"
         linker identification:  "Linker T02-28"
         Link Date/Time: 28-JAN-2011 14:05:07.65
         Overall Image Checksum: 3717C2E9

 

....

 

The Brit
Honored Contributor

Re: Problem upgrading bl860c from OpenVMS 8.3-1H1 to OpenVMS 8.4.

Hi Maurizio,

       Your answer was relevant, but not entirely a solution.      The system that I was upgrading DID have this patch installed,

 

HP I64VMS VMS831H1I_LIBRAR V1.0     Patch     Install     Val     17-MAY-2011

 

However, it seems that it didn't fix any previously existing multiple entries,  it only stopped future duplication.   (at least that is my assessment.

 

Dave.