Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with CSWS (with Perl) -- won't startup

David B Sneddon
Honored Contributor

Problem with CSWS (with Perl) -- won't startup

Situation is:
AlphaServer DS20
OpenVMS V8.3 (fully patched as of last Friday)
CSWS V2.1-1 + CSWS211_UPDATE
CSWS_PERL V2.1 +CSWS_PERL21_UPDATE
PERL V5.8-6 + PERL586_UPDATE

$ @sys$startup:apache$startup
Syntax error on line 13 of /apache$root/conf/mod_perl.conf:
Can't locate API module structure `perl_module' in file /apache$root/
000000/modules/mod_perl.exe: function not implemented

$ dire apache$root:[modules]mod_perl.exe

Directory APACHE$COMMON:[MODULES]

MOD_PERL.EXE;1 394/396 21-OCT-2007
21:16:59.12

Total of 1 file, 394/396 blocks.

Can someone explain exactly what the above message means?
The module exists and an analysis of the executable reveals the
symbol "PERL_MODULE" does exist.

I have a similar problem on another system but that one is referring
to a different module (log_config_module).

Any assistance would be appreciated.

Dave
4 REPLIES
David B Sneddon
Honored Contributor

Re: Problem with CSWS (with Perl) -- won't startup

Problem solved... the issue was an incorrectly defined logical.

Dave
Volker Halle
Honored Contributor

Re: Problem with CSWS (with Perl) -- won't startup

Dave,

I'm seeing the same error message (in APACHE$SWS.LOG) after installing the same products (current versions) as you have done. I've tried to follow the book (installation guides) during the installation. May I be running into the same problem as you have ? Do you remember the 'wrong logical' ?

Syntax error on line 13 of /apache$common/conf/mod_perl.conf:
Can't locate API module structure `perl_module' in file /apache$root/000000/modules/mod_perl.exe: function not implemented

$ dir apache$root:[000000.modules]mod_perl.exe

Directory APACHE$COMMON:[000000.MODULES]

MOD_PERL.EXE;1 394 5-JUN-2006 17:40:22.08

PERL logicals:

"PERLSHR" [exec] = "PERL_ROOT:[000000]PERLSHR.EXE"
"PERL_ROOT" [exec] = "DSA0:[VMS$COMMON.PERL5_8_6.]" [concealed]

Volker.
David B Sneddon
Honored Contributor

Re: Problem with CSWS (with Perl) -- won't startup

Hi Volker,

In my case, what had happened was that when the stuff was originally installed, it was not on the system disk and my perl_root logical was something like dsa6200:[software.perl_6_5.].
When I did the upgrade to 8.6 I changed the logical by replacing perl_6_5 with perl_8_6 but forgot about the device... I also had a process logical for perl_root which was correct.
As a result of the dodgey edit, from the context of my process, everything looked fine, I could see the executable, but the apache process was looking at a nonexistent directory.
So maybe check that everything is looking in the same place with regard to the perl_root logical.

Dave
Volker Halle
Honored Contributor

Re: Problem with CSWS (with Perl) -- won't startup

Dave,

thanks a lot, you at least guided me in the right direction. The logical was o.k., but as this error message seems to be a generic way of saying: file access failure, I checked the protection and ownership of MOD_PERL.EXE:

$ dir apache$common:mod_perl.exe/sec

Directory APACHE$COMMON:

MOD_PERL.EXE;1 394 5-JUN-2006 17:40:22.08 [SYSTEM]
(RWED,RWED,,)
(IDENTIFIER=APACHE$EXECUTE,ACCESS=READ+EXECUTE)

All other MOD_*.EXE files in that directory are owned by APACHE$WWW, so after a little

$ SET FILE/OWN=APACHE$WWW MOD_PERL.EXE

everything worked as expected.

Thanks,

Volker.