Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with IMAP Server (HP TCPIP Services)

 
SOLVED
Go to solution
Mark Iline
Occasional Advisor

Problem with IMAP Server (HP TCPIP Services)

Hi All,

I've been experiencing a problem where the HP TCPIP Services IMAP server refuses connections.

For a small number of users it works fine, but when the numbers increase, mail clients are unable to connect, or see existing connections fail.

When this happens, attempting to telnet to port 143 on the server node returns:
$ tel imap 143
%TELNET-I-TRYING, Trying ... 128.40.54.7
%TELNET-E-CONNFAIL, Failed to connect to remote host
-SYSTEM-F-REJECT, connect to network object rejected

[The node in question will still accept regular telnet sessions, incoming smtp mail, etc.]

Restarting the IMAP server fixes the problem until the next time, which may be a few hours later.

This has been seen on a number of versions of TCPIP Services, and OpenVMS. In an attempt to fix the problem, we have upgraded to HP TCP/IP Services for OpenVMS Alpha Version V5.6 - ECO 2 on an AlphaServer DS20 500 MHz running OpenVMS V8.2.

Any ideas ?


2 REPLIES
Bill Hall
Honored Contributor
Solution

Re: Problem with IMAP Server (HP TCPIP Services)

Mark,

First guess would be IMAP service connection limit. Each "TCPIP Services" service has it's own connection limit. $Tcpip show service imap /full. Check limit, current and peak connections.

If not connection limit, then possibly account quotas need tuned for the TCPIP$IMAP account?

Bill
Bill Hall
Mark Iline
Occasional Advisor

Re: Problem with IMAP Server (HP TCPIP Services)

>>> First guess would be IMAP service connection limit. Each "TCPIP Services" service has it's own connection limit. $Tcpip show service imap /full. Check limit, current and peak connections.

Thanks Bill.

'Limit' & 'Peak' both being 16 do rather suggest that's what the problem is...