Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with NFS mount on OpenVMS 7.3-2

SOLVED
Go to solution
Karen Lee_3
Frequent Advisor

Problem with NFS mount on OpenVMS 7.3-2

I am trying to configure NFS - I have enabled and started portmapper, but my service 'mount' is disabled and won't let me enable it. I keep getting

Message from user INTERnet on CAMVMS
INTERnet ACP Error during process startup, Nolisten Service Disabled - MOUNT Ser

can anyone help?
7 REPLIES
Karl Rohwedder
Honored Contributor

Re: Problem with NFS mount on OpenVMS 7.3-2

Karen,

did you use the TCPIP$NFS_STARTUP/SHUTDOWN procedures under SYS$MANAGER to start the service?

regards Kalle
Karen Lee_3
Frequent Advisor

Re: Problem with NFS mount on OpenVMS 7.3-2

yes i did you that shutdown startup under tcpip$config utility
Karen Lee_3
Frequent Advisor

Re: Problem with NFS mount on OpenVMS 7.3-2

here are the messages

TCPIP-E-STARTERROR, error starting PCNFS service
%%%%%%%%%%% OPCOM 23-OCT-2006 16:42:39.53 %%%%%%%%%%%
Message from user INTERnet on CAMVMS
INTERnet ACP NOLISTEN Process creation success: Service - NFS

-TCPIP-E-BADVALUE, value Service User_name is incorrect
%%%%%%%%%%% OPCOM 23-OCT-2006 16:42:39.54 %%%%%%%%%%%
Message from user INTERnet on CAMVMS
INTERnet ACP Activate MOUNT Server

-RMS-E-RNF, record not found
%%%%%%%%%%% OPCOM 23-OCT-2006 16:42:39.54 %%%%%%%%%%%
Message from user INTERnet on CAMVMS
INTERnet ACP NOLISTEN Process creation success: Service - MOUNT

%TCPIP-E-STARTERROR, error starting PCNFS service
%%%%%%%%%%% OPCOM 23-OCT-2006 16:42:39.54 %%%%%%%%%%%
Message from user INTERnet on CAMVMS
INTERnet ACP Activate MOUNT Server

-RMS-E-RNF, record not found
%%%%%%%%%%% OPCOM 23-OCT-2006 16:42:39.66 %%%%%%%%%%%
Message from user NFS Server on CAMVMS
Process 0001004E configured as an NFS server
Karl Rohwedder
Honored Contributor
Solution

Re: Problem with NFS mount on OpenVMS 7.3-2

When I enable/start the service PCNFS using TCPIP$CONFIG, the procedure creates a user TCPIP$PCNFS. Did that happen on your system (MC AUTHORIZE SHO TCPIP$PCNFS) and is this the user defined for the service (TCPIP SH SERV PCNFS /FU)?

regards kalle
Steven Schweda
Honored Contributor

Re: Problem with NFS mount on OpenVMS 7.3-2

Note that PCNFS is not needed for normal NFS
to work. If you enabled PCNFS without
configuring it properly, you could be making
extra trouble for yourself.
Karen Lee_3
Frequent Advisor

Re: Problem with NFS mount on OpenVMS 7.3-2

This problem was driving me crazy so i called HP support (mike green) - he spotted the problem right away - no world read on the sylogin.com

WHO KNEW -
Mike Smith_33
Super Advisor

Re: Problem with NFS mount on OpenVMS 7.3-2

This one has bitten me about 3 times. Usually when I set up a new cluster.