Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

PuTTY and OpenVMS

HOLVOET
Occasional Contributor

PuTTY and OpenVMS

I have OpenVMS 7.3-2 with TCPIP 5.4 ECO 4 on Alpha
I have PuTTY on my PC (Win XP Pro SP2)
The problem : when I use SCP from my PC, the transfert is OK, but I task never finish, I have not the Prompt unless I type CTRL C.

Idea ? Problem on PC? on VMS ?
In verbose mode on PC the last line is
"Sent EOF Message"
9 REPLIES
Jan van den Ende
Honored Contributor

Re: PuTTY and OpenVMS

Hello Holvoet.

Let me start with

"Welcome to the VMS forum!"

I can not confirm your experience on WXP,
but using PuTTY from W2000 to access Alpha VMS 7.3-2 with TCPIP 5.4 ECO 2 presents no problem whatsoever.

I hardly suspect ECO 4 to have introduced this kind of trouble, and it _IS_ well known that SP2 for WXP has brought many extra 'security' features, which _ARE_ known to have broken quite a few applications.

-- do you have any facility to test PuTTY from any other PC, running maybe WXP without SP2, or whatever, to confirm the correct workings of the VMS side? I do not expect ECO4 to be the issue, but it is just good to have it confirmed.

-- as far as I know, most extra security features in SP2 are adjustable. That would mean that you will have to know where to look and how to adjust.


There is also a forum for Microsoft stuff, with a XP category.
For info on XP settings I think you can better cross-post there.

If you get it solved, will you post the answer (or the pointer to it) here as well, please?

Sante.

Have one on me.

Jan
Don't rust yours pelled jacker to fine doll missed aches.
Wim Van den Wyngaert
Honored Contributor

Re: PuTTY and OpenVMS

There still are some issues ...
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=772977

Could it be that the VMS side aborted while the PC site was expecting an answer ? Check the VMS log files and accounting. After a long time there could be a (keepalive)timeout message.

Wim (without 5.4 and SCP)
Wim
HOLVOET
Occasional Contributor

Re: PuTTY and OpenVMS

Precision on my problem : I have tested on Windows 2000 SP4, same problem, more difficult to test TCPIP 5.4 ECO2
labadie_1
Honored Contributor

Re: PuTTY and OpenVMS

Bonjour Denis :-)

You should take a trace and analyze it with ethereal (www.ethereal.com)

gerard
Ian Miller.
Honored Contributor

Re: PuTTY and OpenVMS

I see the same with Win XP (no service patches but current patches) and TCPIP V5.4 no ECO.

I can transfer files with psftp; as long as they are in Stream_LF format :-(

psftp is supplied with putty
____________________
Purely Personal Opinion
labadie_1
Honored Contributor

Re: PuTTY and OpenVMS

The following might help


[TCP/IP] How to Capture and Decode TCP/IP Packets on OpenVMS

http://h18000.www1.hp.com/support/asktima/communications/CHAMP_SRC020427000391.html
HOLVOET
Occasional Contributor

Re: PuTTY and OpenVMS

It was a VMS problem, HP send me new exe files for SSH and it works.Then will be in the next ECO (I hope so)
Enjoy.
Jan van den Ende
Honored Contributor

Re: PuTTY and OpenVMS

Denis,

Thanks for finding out!

(Guess you had rather not!!).

So we wil wait for the next patch (and read the realease notes carefully!)

Proost.

Have one on me.

Jan
Don't rust yours pelled jacker to fine doll missed aches.
Ian Miller.
Honored Contributor

Re: PuTTY and OpenVMS

if you can't wait then log a call with hp and ask for the fixed files. I hope they come out as an ECO kit soon.
____________________
Purely Personal Opinion