Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Rdb SQL IMPORT fails with " %RMS-W-RTB, 8224 byte record too large for user's buffer"

 
SOLVED
Go to solution
Navipa
Frequent Advisor

Re: Rdb SQL IMPORT fails with " %RMS-W-RTB, 8224 byte record too large for user's buffer"

Hi Volker,
....We use DSSI disks, and VAX4108 comes with 2 DSSI controllers and not necessarily load any driver and virtual tape MUA and MUB.

Config file contents....
...
.....
load TQK50 MUA address = 017774500
set MUA containter[0]="d:\tel_tapes\tape_mua0.mtd"
load TQK50 MUB container=017760404
set MUB container[0] ="d:\tel_tapes\tape_mub0.mtd"

#Configure DSSI disk, vax4108 comes with 2 DSSI controllers
set paa mscp_allocation_class[0]=2 scs_node_name[0]="DISK0"
set paa container[0]="d:\tel_vdisks\dia0.vdisk"
....
.....
# I have configured 12 vdisks and it works totally.

Volker,
Mainly I would like to resolve the vdisk issue (must), but I have 2nd question for the future, seems I have 2 virt.tapes MUA and MUB.  But I never used virt.tapes for backup, as I don't know how to define its size and its max size, is it possible to have 12 GB or 16 GB tapes and can I avoid the above said error by replaing vdisk with vtapes?

Navipa
Frequent Advisor

Re: Rdb SQL IMPORT fails with " %RMS-W-RTB, 8224 byte record too large for user's buffer"

Thanks Hein.
I am unable to understand your suggestions clearly... Do you want to me mount source or destination volume? can you please give some details on this bound volume. seems I can make it work for few years without patching, .....

 

Hein van den Heuvel
Honored Contributor
Solution

Re: Rdb SQL IMPORT fails with " %RMS-W-RTB, 8224 byte record too large for user's buffer"

 

 

Read my replies again, and read slowly. And open up the OpenVMS manuals

1) RMU/Backup works but RMU restore doesn't, the sameway the EXPORT works, but IMPORT doesn't.

Clearly the import commands does not succceed, but it is NOT broken, OpenVMS is to blame.

2) As I wrote, the ancient OpenVMS version you work with has a maximum (scsi) disk size of : 16777215 blocks of 512 bytes = 8589934080 = 8 GiB (gibibyte) = 8.6 GB  - What's not clear about that?

3) If a file larger than the about 16.7 M blocks is needed, as it is, then you can use a BOUND VOLUME SET to combine multiple physical disks. You create one with a command similar to MOUNT/SYS/BIND=bigdisk  dka200,dka300 label2,label3  after an INIT DKA200 label2; INIT DKA300 label3. - This structure can hold the target of the export / source for the import

>> seems I can make it work for few years without patching, .....

Yes, I think so.

Hein

abrsvc
Respected Contributor

Re: Rdb SQL IMPORT fails with " %RMS-W-RTB, 8224 byte record too large for user's buffer"

re-wording and summarizing what Hein posted:

An individual SCSI disk limitation of 8GB disk supported by this OpenVMS version is the problem here.  Using bound volume sets avoids the problem by allowing for a "disk" larger than that limit.  The volume set will appear as a singular disk to the application but is handled as a group of smaller disks at the OS and hardware levels (in concept) which will prevent you from hitting the limit mentioned before.

Look up volume sets in the documentation.  For your specific case, I would bind at least 3 disks together to create a set of 24GB total.  That should give you some breathing space.

Dan

Navipa
Frequent Advisor

Re: Rdb SQL IMPORT fails with " %RMS-W-RTB, 8224 byte record too large for user's buffer"

Thanks Hein and Dan (abrsvc).
You are great!!! that bound volume set I created using 2x 8GB (16777215) resolved one issue which is RMU/RESTORE, but still I have a issue with IMPORT, but this time with different error (below). I have created a new post with that error. Expecting your assistance to resolve that IMPORT issues either with BOUND volume or some other way as my DB size keeps growing without resolving this EXPORT/IMPORT issues.

IMPORTing table tccd
%SQL-F-NODATRES, remaining data for this relation will be ignored
%RDB-F-SYS_REQUEST, error from system services request
-RDMS-F-FILACCERR, error extending file SYS$SYSROOT:[RDM$RUJ]teldb$00B0712182776E40.RUJ;1
-SYSTEM-F-BADPARAM, bad parameter value
%RDB-F-SYS_REQUEST, error from system services request
-RDMS-F-FILACCERR, error extending file SYS$SYSROOT:[RDM$RUJ]teldb$00B0712182776E40.RUJ;1
-SYSTEM-F-BADPARAM, bad parameter value

IMPORTing table tcop
%SQL-F-NORELRES, unable to import table tcop
%RDB-F-SYS_REQUEST, error from system services request
-RDB-E-NO_META_UPDATE, metadata update failed
-RDMS-F-FILACCERR, error extending file SYS$SYSROOT:[RDM$RUJ]teldb$00B0712182776E40.RUJ;1
-SYSTEM-F-BADPARAM, bad parameter value
%RDMS-I-BUGCHKDMP, generating bugcheck dump file SYS$SYSROOT:[SYSMGR]RDSBUGCHK.DMP;27

Thanks
Navipa

 

Navipa
Frequent Advisor

Re: Rdb SQL IMPORT fails with " %RMS-W-RTB, 8224 byte record too large for user's buffer"

Dear Hein,
Sorry for the delayed response. Your suggestion resolved larger vdisk issue.

Thanks
Navipa