Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Relay problems, Sending SMTP mails from OpenVms7.3 Tcpip5.1-4 to Ms-Exchange Server Relay

 
Maurizio Rondina
Frequent Advisor

Relay problems, Sending SMTP mails from OpenVms7.3 Tcpip5.1-4 to Ms-Exchange Server Relay

Following previous thread (see for more informations): MAIL-E-OPENOUT insufficient privilege or file protection violation
http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1420381

since the previous configuration (sending directly from OpenVms System) still not work with continuity (may be dns problems), i try to use as relay system an existing SMTP server (Ms Exchange on Windows Server system) on the same lan, the Mail Server that manage without problems all other mails of the company.

OpenVms system name and domain "a1.custom" (managed by me), Ms-Exchange system name and domain "e2.custom.local" (housed and managed by an external company), both machines are in the same lan.

From a1.custom i can do "ping e2.custom.local" with normal replies

actual tcpip SMTP configuration is the following

SMTP Configuration
Options
Initial interval: 0 00:30:00.00 Address_max: 16 NOEIGHT_BIT
Retry interval: 0 01:00:00.00 Hop_count_max: 16 RELAY
Maximum interval: 3 00:00:00.00 TOP_HEADERS

Timeout Initial Mail Receipt Data Terminate
Send: 5 5 5 3 10
Receive: 5

Alternate gateway: e2.custom.local
General gateway: e2.custom.local

Substitute domain: not defined
Zone: not defined

Postmaster: TCPIP$SMTP
Log file: SYS$SPECIFIC:[TCPIP$SMTP]TCPIP$SMTP_LOGFILE.LOG

Generic queue Queues Participating nodes

TCPIP$SMTP_A1_00 1 A1




This settings don't work well.. sending a SMTP message nothing happen, no messages also on the SYS$SPECIFIC:[TCPIP$SMTP]TCPIP$SMTP_LOGFILE.LOG
also with the TRACE flag

(LNM$SYSTEM_TABLE)

"TCPIP$SMTP_SYMB_TRACE" = "1"


2 REPLIES 2
Houcmant Philippe
Occasional Advisor

Re: Relay problems, Sending SMTP mails from OpenVms7.3 Tcpip5.1-4 to Ms-Exchange Server Relay

On the exchange server, you must authorize the VMS server.

Depending on the security policy in your organization, it is possible that mail adress must respect some rules.

Example:
exchange expect sender adress of type: "name@society.land"

Vms computer send a sender adress "vmsusername@a1.custom"

In this case, you must define a substitute domain "society.land" in the configuration of SMTP on your VMS computer.

Look also at the logical name
"TCPIP$SMTP_NO_SUBS_DOMAIN_INBOUND" = "YES"
Maurizio Rondina
Frequent Advisor

Re: Relay problems, Sending SMTP mails from OpenVms7.3 Tcpip5.1-4 to Ms-Exchange Server Relay

Now i change the configuration as follow

SMTP Configuration
Options
Initial interval: 0 00:30:00.00 Address_max: 16 EIGHT_BIT
Retry interval: 0 01:00:00.00 Hop_count_max: 16 RELAY
Maximum interval: 3 00:00:00.00 TOP_HEADERS

Timeout Initial Mail Receipt Data Terminate
Send: 5 5 5 3 10
Receive: 5

Alternate gateway: none
General gateway: none

Substitute domain: not defined
Zone: e2.custom.local

Postmaster: TCPIP$SMTP
Log file: SYS$SPECIFIC:[TCPIP$SMTP]TCPIP$SMTP_LOGFILE.LOG

Generic queue Queues Participating nodes

TCPIP$SMTP_A1_00 1 A1

Then the outsourcer who manage e2.custom.local give authorizations to a1.custom and delete all antispam's and antivirus's filters.

Exchange mail server, has two ip address, a LAN ip address (e2.custom.local) and a WAN ip address (smtp.outsourcer.it).

Sending an email, on the first line of the LOG (with trace option) i found
220 server smtp.ousourcer.it

and the mail was not sent, error:
554 spam message

if i give the following command (to put a forced route on the local hosts file)
tcpip> set host /Address=[ipLanAddress] smtp.outsourcer.it

and send a new mail, the first line become
220 e2.custom.local

and so, the mail was sent to email destination address of domain @custom.it

sending instead to other public domains the mail was not sent, error:
554 spam message

OpenVms Server must to be a SMTP Server only inside his LAN, and must use only e2.custom.local for all the destination domains.

How can I configure SMTP to force all outgoing mails to e2.custom.local ?