Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Remove DTSS forever!

SOLVED
Go to solution
Barry Alford
Frequent Advisor

Remove DTSS forever!

How can I disable DTSS permanently? I can use:

$ MC NCL DISABLE DTSS

in a LOGIN.COM procedure to do this, but I need it disabled before login to prevent loads of these messages scrolling up the console:

%%%%%%%%%%% OPCOM 22-AUG-2007 22:45:52.69 %%%%%%%%%%%
Message from user SYSTEM on A1
Event: Too Few Servers Detected from: Node LOCAL:.A1 DTSS,
at: 2007-08-22-22:45:52.693+01:00Iinf
Number Detected=0,
Number Required=1
eventUid 6FCF1E22-5101-11DC-A3A3-413120202020
entityUid A6CBD9E0-50AE-11DC-854B-AA0004000104
streamUid A6A162AF-50AE-11DC-8524-AA0004000104

I have tried putting the line in SYSTARTUP_VMS.COM but it does not seem to have any effect.

A permanent setting to not start DTSS at all would be the best solution, but a quick search of SYS$MANAGER:*.COM did not show anything obvious.

I know someone out there will know immediately!
4 REPLIES
Heinz W Genhart
Honored Contributor
Solution

Re: Remove DTSS forever!

Hi Barry

$ MC NCL DISABLE DTSS
$ MC NCL DELETE DTSS

You then have to define the logical

$ DEFINE/SYS/EXEC NET$DISABLE_DTSS TRUE

in SYLOGICALS.COM

This disable DTSS Startup for your machine

Hope that helps

regards

Geni
Daniel Fernandez Illan
Trusted Contributor

Re: Remove DTSS forever!

Barry

You migth also modify the file SYS$STARTUP:NET$DTSS_CLERK_STARTUP.NCL and comment line ENABLE DTSS ...

Saludos.
Daniel

Barry Alford
Frequent Advisor

Re: Remove DTSS forever!

Thanks, Geni -- that sounds just like what I was looking for! I will see if it works when I next reboot (I can't do it now!)

Daniel - If Geni's solution does not work, I will try your suggestion (although it has the danger of being superseded on a VMS upgrade)

Thanks you both for your quick responses!

[I will award points and close this thread after I have rebooted and tested...]
Barry Alford
Frequent Advisor

Re: Remove DTSS forever!

Geni's solution worked on another Alpha with the same configuration which I could reboot to verify that no more DTSS messages appeared.

I did not therefore try Daniel's suggestion but I believe it would work if SYS$STARTUP:NET$DTSS_CLERK_STARTUP.NCL is the file used to start DTSS. As I originally searched in *.COM I did not find the line to comment out!

Thanks to all who contribute to this forum!

Barry