Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Run secure FTP on a legacy VAX cluster (OVMS 6.2)

 
Russ Carraro
Regular Advisor

Run secure FTP on a legacy VAX cluster (OVMS 6.2)

Customer has a legacy VAX cluster running OpenVMS 6.2 and UCX 4.1-5 and needs to start running secure FTP. Anyone know if it's possible to run SFTP on this cluster (or single node) as configured? If not, can you tell me which versions of which software is required? Thank you.
10 REPLIES 10
Thomas Ritter
Respected Contributor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

You will need to install a third party product.
We use Process Software SSH for OpenVMS. Support is very good.

Here is a link

http://www.process.com/tcpip/ssh.html
Russ Carraro
Regular Advisor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

Thanks Thomas. Okay, for the current configuration they need third party software. Does HP have SSH if they upgrade to the latest versions of the OS and TCPIP? Which do you think is the better solution?
Robert Gezelter
Honored Contributor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

Russ,

The latest version of OpenVMS on VAX is 7.3, with the corresponding TCP/IP release being 5.3 (see http://h71000.www7.hp.com/network/tcpip_matrix.html for details).

The documentation for TCP/IP 5.3 is at http://h71000.www7.hp.com/doc/tcpip53.html .

- Bob Gezelter, http://www.rlgsc.com
Robert Gezelter
Honored Contributor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

Russ,

The SSL kit Open Source kit is also referenced at http://h71000.www7.hp.com/opensource/opensource.html#ssl

- Bob Gezelter, http://www.rlgsc.com
Steven Schweda
Honored Contributor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

> The SSL kit [...]

SSL and SSH are spelled differently for a
reason, and SSH is what you need for SFTP.
Hoff
Honored Contributor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

>Does HP have SSH if they upgrade to the latest versions of the OS and TCPIP?

Yes. See: http://www.hp.com/go/openvms/doc

> Which do you think is the better solution?

That depends highly on the customer, and the customer's environment. Some will operate unnecessarily on older releases, and miss out on features and fixes. Others necessarily sit on same. Some customers have a contactual Right To Upgrade established with HP, and others would have to pay full fare for the "new" software releases. You're in the best position to differentiate which applies here.

The customer has a far bigger issue here, as this legacy cluster is increasingly falling off the power and cooling and maintenance and performance product curves. There are options for refurbishing and sparing and keeping the older gear alive, of course. But sooner or later, they're going to get to decide to port off or to port forward.

labs.hoffmanlabs.com/node/225
labs.hoffmanlabs.com/node/226

When my desktop Mac (or a comparable Windows or Linux or BSD box, or buying one of the US$300 rx2600 boxes off eBay and purchasing the pieces and the HP FOE licenses) is vastly faster than the first big VAXcluster I managed (multiple VAX 8800-class boxes) and when I can hang a couple of terabytes off the box for less than a kilobuck and when I have a run-time of most of an hour on a stock 1500 watt UPS with the Mac, there are obvious problems with (still) running that VAXcluster. No matter how reliable it's been. And a smart CEO tends to notice these details, and will ask.

But sftp? Sure. If you're not tweaking any stuff and if you're not spending anything on the application(s) here, then get the Process Software ssh and sftp add-on. If you're looking to pay a bit more attention to the software and hardware, upgrade to current, or be prepared to port or to migrate. But you better have a plan for rendering this cluster surplus well underway for your customer.
Russ Carraro
Regular Advisor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

Thanks guys. I'm a neophyte at this secure stuff so please bear with me. I looked at TCPIP 5.3 and I can't find a reference to SSH (or SFTP). TCPIP 5.4 does have SSH but it's only for OpenVMS for Alpha. I interpret this to mean there is no SSH (or SFTP) for OpenVMS VAX. Can this be correct?
Steven Schweda
Honored Contributor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

> [...] Can this be correct?

It must be pretty close to correct. The
release notes for TCPIP V5.4 say things like:

[...]

1.2 Secure Shell (SSH)

This release includes the Secure Shell (SSH) client and server, providing secure login, remote command execution, and file
transfer. This implementation is based on SSH2 software from SSH Communications Security Corp., Version 2.4.1.

Note

If the TCP/IP Services V5.3 Early Adopter's Kit (EAK) for SSH for OpenVMS is installed on
the system, you must use the PCSI command PRODUCT REMOVE to remove the EAK
before you install TCP/IP Services V5.4.

[...]

http://h71000.www7.hp.com/doc/732FINAL/TCP_RN/TCP_RNPRO.HTML

I haven't tried to find that EAK, but even if
it was available for VAX, it sounds like a
sub-ideal path.


Note that the HTML Release Notes for V5.3 are
corrupt.
Hoff
Honored Contributor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

Or configure any operating system of your choosing out in front of this cluster, and use it as a drop box for sftp for the cluster. An OpenVMS I64 box with V8.3-1H1 and current TCP/IP Services, a Mac or Windows or Linux box, whatever. Transfer the files via periodic DCL processing, or whatever might be deemed appropriate for the local environment.

If you do set up sftp in an OpenVMS cluster, you'll likely also need to set up the keys appropriately via ssh known hosts files TCPIP$SSH_DEVICE:[TCPIP$SSH.SSH2.KNOWNHOSTS]

http://labs.hoffmanlabs.com/node/1116
Russ Carraro
Regular Advisor

Re: Run secure FTP on a legacy VAX cluster (OVMS 6.2)

Going to try third party software.