cancel
Showing results for 
Search instead for 
Did you mean: 

SLS problem

Lokesh_2
Esteemed Contributor

SLS problem

Hi ,

I am facing problem with SLS . This is not a problem as such , but it is annoying as it is consuming lot of time. Let me describe you the problem in detail :

On one of my system , when I want to restore any disk, then I go to SLSOPER menu and select option no. 3 ( i.e. Full Disk Restore ) , it will give you the prompt "Disk to be restored (?=List):" . The problem is that here when I give question mark (?) to display the disk list, it takes about 20-25 minutes, just to display the list . And after that when I give any disk name here to find the restore tapes, then it give me listing from year 2000 till date and it also takes 20-25 minutes. Now, I don't want the list from way back 2000, as we keep our backup for last 45 days only. So, is there any way to clear up these old entries and keep the entries for last 60 days or so . I have ran SYSCLN but with no success . I have also defragmented the disk where SLS database is present, but this also hasn't improved the performance ( as you can see it takes about 45-50 minutes just to find the tape for restore operation ) .

I am attaching the relevant output here.

Many thanks & regards,
Lokesh Jain



What would you do with your life if you knew you could not fail?
5 REPLIES

Re: SLS problem

Hi Lokesh,

It's been a while since I've used SLS, but I ran into a problem with SYSCLN; if I didn't run it on all nodes in a cluster, it would not remove "expired" backup information, nor would it release expired tapes back to the scratch pool.

You didn't state you were running in a cluster; if you are, try running SYSCLN on all your cluster nodes.

HTH

--Brad
Lokesh_2
Esteemed Contributor

Re: SLS problem

Hi Bradford,

my environment is three node VAX cluster on CI . As suggested by you I have ran SYSCLN from all the three nodes. Then afterwards, I have shutdown and restarted SLS on all the three nodes. In addition i did convert for file TAPEUSE.DAT for all the three nodes. But this has NOT solved by problem.

Any ideas how to proceed ??

Best regards,
Lokesh
What would you do with your life if you knew you could not fail?

Re: SLS problem

I'm fresh out of ideas - :-)

That said, if you have a support contract, I suggest you continue with the fine folks at HP; otherwise, wait for someone else to respond here, or try comp.os.vms - there is at least one regular poster there who is familiar with SLS, and a regular posting vendor who supports TAPESYS, SLS's "predecessor".

Good luck!

Re: SLS problem

Apologies for following up my own post -

I just thought of something else. How "comfortable" are you with BACKUP?

I was using BACKUP long before using SLS. I found the SLS restore "procedures" to be cumbersome and time-consuming; I ended up using SLS to identify the tape(s) I would need to do a restore, and then use the BACKUP utility to restore the file(s) or disk(s) "Manually". Much faster!
Lokesh_2
Esteemed Contributor

Re: SLS problem

Hi Bradford,

I am remotely managing this system. Backup/restore is done by local operators which uses this menu driven SLS!! So, I cannot get rid SLS...

Regards,
Lokesh
What would you do with your life if you knew you could not fail?