Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

%SYSTEM-F-EXLNMQUOTA, logical name table is full

 
SOLVED
Go to solution
Lucie
Frequent Advisor

%SYSTEM-F-EXLNMQUOTA, logical name table is full

We have a weekly job that checks the disk space of all disks in the cluster. If run successfully it will provide some of the following information:

SYS0 on _DSA1: has consumed the following disk space:
Grand total of 2520 directories, 98021 files, 13.22GB

SYS1 on _DSA1: has consumed the following disk space:
Grand total of 2529 directories, 87154 files, 13.15GB

SYS2 on _DSA1: has consumed the following disk space:
Grand total of 2501 directories, 95270 files, 11.84GB

SYSLOST on _DSA1: has consumed the following disk space:
Grand total of 1 directory, 15 files, 59KB

TCPIP$FTP on _DSA1: has consumed the following disk space:
Grand total of 1 directory, 7 files, 1.32MB
……
Today it failed with %SYSTEM-F-EXLNMQUOTA, logical name table is full. I checked JTQUOTA for the SYSTEM account in AUTHORIZE and PQL_MJTQUOTA in sysman - both are set to 8192. Is there a way I look at the logical table involved? Could there be "old" logical in the table?
5 REPLIES 5
Hoff
Honored Contributor
Solution

Re: %SYSTEM-F-EXLNMQUOTA, logical name table is full

Raise the quota.

You have one memory page set aside for this stuff, and if increasing that value is a problem, you have a vastly larger problem than the size of the logical name table.

I've been known to reserve (gasp!) ten memory pages.

Or (bigger gasp!) more.

:-)

Chances are, you've been making changes elsewhere in a login or such, and (if you really want to invest the thought and investigation into this) you've added enough to push this (and possibly some other jobs) over the edge.

It's also possible there's a logical name leak, but the fastest way to determine if that's the case here is to double or quadruple the quota setting, and see if the problem reoccurs. If you slam into the limit again, you have a leak. Otherwise, probably not.
Volker Halle
Honored Contributor

Re: %SYSTEM-F-EXLNMQUOTA, logical name table is full

Lucie,

$ SHOW LOGICAL/JOB/FULL will show the logicals, the remaining quota and the quota itself:

$ sho log/job/full

(LNM$JOB_82CB1880) [kernel] [shareable] [Quota=(3120,4096)]
[Protection=(RWCD,RWCD,,)] [Owner=[VMS,HALLE]]
...

Add some of these commands at appropriate locations in the DCL procedure for further troubleshooting.

Volker.
Robert Gezelter
Honored Contributor

Re: %SYSTEM-F-EXLNMQUOTA, logical name table is full

Lucie,

As previously noted, SHOW LOGICAL/TABLE=/FULL will display information relating to the usage and quota for a name table.

The name for the Job logical name table depends on your job, but the alias LNM$JOB is defined to make it easier to reference. The corresponding quota for a name table is set with the CREATE/NAME_TABLE command. In the case of LNM$JOB, it is implicitly set when your job is created using the value JTQUOTA.

- Bob Gezelter, http://www.rlgsc.com
Richard Brodie_1
Honored Contributor

Re: %SYSTEM-F-EXLNMQUOTA, logical name table is full

It should be the job table, you can inspect it with:

show logical/table=LNM$JOB_.

You would need to schedule another job to do this whilst the main job is running. As Hoff says, it's a very small quantity of memory to worry about though.



Lucie
Frequent Advisor

Re: %SYSTEM-F-EXLNMQUOTA, logical name table is full

Thanks Gentlemen for a quick response!

I will increase the quota as recommended and will also keep in mind the information SHOW LOGICAL/TABLE=/FULL to troubeshoot the problem if it occurs again