Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Sending Mail Error

mkayhan
Occasional Advisor

Sending Mail Error

Hello,

When I want to send mail to an another user ( for example I am online(my username) and I want to send mail to myself.

Mail> send
To: online
Subj: hello
Enter your message below. Press CTRL/Z when complete, or CTRL/C to quit:
Hello!
CTRL+Z

then I got this message ;

%MAIL-E-SENDERR, error sending to user ONLINE
-MAIL-E-OPENOUT, error opening USER$DISK:[ERDEMIR_VMS]MAIL.MAI as output
-SYSTEM-F-IVDEVNAM, invalid device name

And when I searh there is no queue which name is sys$print. Do you think is it a problem? and what do u think? How Can I solve this.

Thanks.

16 REPLIES
Craig A
Valued Contributor

Re: Sending Mail Error

Is USER$DISK: a valid device (or logical name)

What does the UAF record for ONLINE look like?

Craig
mkayhan
Occasional Advisor

Re: Sending Mail Error

"USER$DISK" = "USER_DISK:[USER.]"
"USER_DISK" = "$1$DGA1:"

it is logical name and ONLINE is an administrator.it has all privileges.
Joseph Huber_1
Honored Contributor

Re: Sending Mail Error

>>
"USER$DISK" = "USER_DISK:[USER.]"
"USER_DISK" = "$1$DGA1:"
<<

User disk is a concealed logical name consisting of another logical name.
This works indeed if the concealed logical is not TERMINAL.
And also the mode (/EXEC ?) of the l;ogical may be important for MAIL, while a DIR USER$DISK:[ERDEMIR_VMS] may succeed.

Show the the result of show logical/full of the two USER* logicals.
http://www.mpp.mpg.de/~huber
Joseph Huber_1
Honored Contributor

Re: Sending Mail Error

And the existance of a queue sys$print is irrelevant for mail, it just means You have to add the /QUEUE to every PRINT command, or set the default queue via SET QUEUE in MAIL>

And also in VMS general there is no requirement for a sys$print queue: it is just the default queue for commands like PRINT, SUBMIT/PRINT etc.
For locations with many distributed printers it may even be better not to have sys$print, so every user has to explicitly specify a queue.
http://www.mpp.mpg.de/~huber
mkayhan
Occasional Advisor

Re: Sending Mail Error

$ SHOW LOGICAL/FULL USER*

(LNM$PROCESS_TABLE) [kernel]
[no protection information]

(LNM$JOB_820D1200) [kernel] [shareable] [Quota=(3520,4096)]
[Protection=(RWCD,RWCD,,)] [Owner=[ERDEMIR_VMS]]

(LNM$GROUP_000100) [kernel] [shareable,group]
[Protection=(RWCD,R,R,)] [Owner=[100,*]]

(LNM$SYSTEM_TABLE) [kernel] [shareable,system]
[Protection=(RWC,RWC,R,R)] [Owner=[SYSTEM]]

"USER$DISK" [exec] = "USER_DISK:[USER.]" [concealed]
"USER_DISK" [super] = "$1$DGA1:"

(LNM$SYSCLUSTER_TABLE) [kernel] [shareable,system]
[Protection=(RWC,RWC,R,R)] [Owner=[SYSTEM]]

(DECW$LOGICAL_NAMES) [exec] [shareable]
[Protection=(RWCD,RWCD,R,R)] [Owner=[SYSTEM]]



i am starter at vms...I would be grateful if you tell me what I should do elaborately..
The Brit
Honored Contributor

Re: Sending Mail Error

Could you show the output from

$ dir USER$DISK:[ERDEMIR_VMS]

Dave
The Brit
Honored Contributor

Re: Sending Mail Error

Sorry, Ignore!!

Dave.
Joseph Huber_1
Honored Contributor

Re: Sending Mail Error

>>
"USER$DISK" [exec] = "USER_DISK:[USER.]" [concealed]
"USER_DISK" [super] = "$1$DGA1:"
<<

USER_DISK must as well be an /EXEC logical !
http://www.mpp.mpg.de/~huber
The Brit
Honored Contributor

Re: Sending Mail Error

Can you post the output from

MAIL> show all


and, is USER$DISK:[ERDEMIR_VMS] the login directory for user ONLINE?

Dave.
mkayhan
Occasional Advisor

Re: Sending Mail Error

MAIL> show all
Your mail file directory is USER$DISK:[ERDEMIR_VMS].
%MAIL-E-OPENIN, error opening USER$DISK:[ERDEMIR_VMS]MAIL.MAI as input
-RMS-E-FNF, file not found
%MAIL-E-NOMSGS, no messages

You have not set a forwarding address.
You have not set a personal name.
Your editor is TPU.
CC prompting is disabled.
Automatic copies to yourself are disabled.
Automatic deleted message purge is enabled.
Your default print queue is SYS$PRINT.
You have not specified a default print form.
You have not specified a default signature file.


yes it is the login directory of online..
mkayhan
Occasional Advisor

Re: Sending Mail Error

How can I make the USER_DISK an /EXEC logical ?
Craig A
Valued Contributor

Re: Sending Mail Error

Use /EXEC on the DEFINE/SYS or ASSIGN/SYS command.

But you will need SYSNAM or SYSPRV privilege.

Don't forget to fix it in the system startup, too.

Craig
Joseph Huber_1
Honored Contributor

Re: Sending Mail Error

DEFINE/SYSTEM/EXEC logical equivalence

See HELP DEFINE,
and maybe a thing at least once to read through the VMS manual "DCL dictionary" and "VMS users guide".
See the links to HP VMS docs on the OpenVMS furum main page (bottom).
http://www.mpp.mpg.de/~huber
mkayhan
Occasional Advisor

Re: Sending Mail Error

I tried to make something. But I think I made some mistakes.

I did ;

$Define/sys/execute
_Log name: USER_DISK
_Equ name: $1$DGA1:

and something else...

then when I do

$show logical/full user*

(LNM$PROCESS_TABLE) [kernel]
[no protection information]

"USER$DISK" [exec] = "USER_DISK"
"USER_DISK" [super] = "$1$DGA1:"

(LNM$JOB_820E1EC0) [kernel] [shareable] [Quota=(3520,4096)]
[Protection=(RWCD,RWCD,,)] [Owner=[ERDEMIR_VMS]]

(LNM$GROUP_000100) [kernel] [shareable,group]
[Protection=(RWCD,R,R,)] [Owner=[100,*]]

(LNM$SYSTEM_TABLE) [kernel] [shareable,system]
[Protection=(RWC,RWC,R,R)] [Owner=[SYSTEM]]

"USER$DISK" [exec] = "USER_DISK"
"USER_DISK" [super] = "$1$DGA1:"

(LNM$SYSCLUSTER_TABLE) [kernel] [shareable,system]
[Protection=(RWC,RWC,R,R)] [Owner=[SYSTEM]]

(DECW$LOGICAL_NAMES) [exec] [shareable]
[Protection=(RWCD,RWCD,R,R)] [Owner=[SYSTEM]]




and when I logout and login again.. There is nothing under the (LNM$PROCESS_TABLE) ..

And the important problem.
$ dir
%DIRECT-E-OPENIN, error opening $1$DGA1:[ERDEMIR_VMS]*.*;* as input
-RMS-E-DNF, directory not found
-SYSTEM-W-NOSUCHFILE, no such file


I cannot reach. the name was changed but it should be USER$DISK:[ERDEMIR_VMS]

How can I change it again? It is so important:(




mkayhan
Occasional Advisor

Re: Sending Mail Error

Okk I solved it. but still have mail problem...
Joseph Huber_1
Honored Contributor

Re: Sending Mail Error

You did NOT define user_disk in /EXECUTIVE mode,
probably ignored the error message ?
And in addition should remove the /PROCESS logicals of the user$disk and user_disk:
deassign/process user$disk
deassign/process user_disk

Your directory is not in $1$DGA1:[ERDEMIR_VMS],
but supposedly in $1$DGA1:[USER.ERDEMIR_VMS].

The real problem still is the wrong definition of USER_DISK.
deassign/system user_disk
and do
define/system/exec/trans=(conceal,terminal) user_disk $1$DGA1:

And at all either get rid of user_disk at all:
the disk $1$DGA1 gets a (concealed,terminal) logical associated at MOUNT time, usually DISK$label , where "label" is the volume label of of $1$DGA1; use SHOW DEVICE $1$DGA1: to see the volume label.

So either use this logical in the definition of disk$user
or better define disk$user as
define/system/exec/trans=conceal disk$user $1$DGA1:[user.]

and even better, don't use the logical disk$user, because this will be in conflict with a possible disk volume labeled "USER".
http://www.mpp.mpg.de/~huber