Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Setting ewa0_mode while running OpenVMS

Howard_24
Advisor

Setting ewa0_mode while running OpenVMS

I have a DS25 running OpenVMS version 8.2 and we are getting poor network performance. I have the gigE (ewa0) card set to auto negotiate in SRM, but it is set to 100 full duplex at the switch. The system is at a remote site so I was wondering if there was a way I could set this card to full duplex while running VMS. I tried setting it to full duplex in lancp using the following command:

set device ewa0/full but it still reads
No Full duplex operational in lancp.

Thanks,

Howard
13 REPLIES
Hoff
Honored Contributor

Re: Setting ewa0_mode while running OpenVMS

I'd expect that LANCP can switch the value on-line, so there seems to be something odd with this configuration. Or a bug in LANCP?

Some command examples from the HP documentation for the A7011A and A7012A series NICs:

http://www.docs.hp.com/en/5971-4261/ch02s02.html

And if you've hard-locked the switch, you'll want to hard-lock the console setting.

I'd probably next take a good long look at the ECO level for the OpenVMS Alpha V8.2 host, and at the revision of whatever firmware is operating in whatever NIC is involved here. (And there are some older DE-class NICs around that don't do all that well with negotiation, regardless of the host and the NIC firmware. The DE500 series has one or two of these recalcitrant NICs.)

Andy Bustamante
Honored Contributor

Re: Setting ewa0_mode while running OpenVMS

Try setting /speed=100 and /duplex=full. You'll also want to DEFINE these values for the next reboot.

As Hoff states, you should also look for ECOs which may apply.


Andy
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
Howard_24
Advisor

Re: Setting ewa0_mode while running OpenVMS

I forgot to mention that this card is the internal card that comes with the DS25. It's a internal 1gig card. The switch that it is connecting to is presently at 100/full and I am trying to get them to set it to auto. It is a 1gig switch with 1gig ports and from the reading I have done 1gig cards seem to negotiate fine. I would think once they set the switch port to auto I would have to go into lancp and set it by doing:

mcr lancp set device ewa0/autonegotiate

Does this sound right?

Thanks,

Howard
Robert Brooks_1
Honored Contributor

Re: Setting ewa0_mode while running OpenVMS

I have a different opinion -- assuming a properly-performing switch and modern version of VMS, you should simply set the switch port and device (at the console level) to autonegotiate. In this context, "modern" means V7.3-2 and above.

There appears to be some hand-waving FUD that claims there are problems with VMS and autonegotiation.

The current ethernet driver developer within VMS Engineering, who's been writing LAN drivers for decades, has repeated stated that he's interested in hearing about examples of VMS not correctly working with autonegotiate set on both ends of the wire, since he's quite confident that it should "just work", and has spent a considerable amount of time and effort to make it work.

-- Rob
Howard_24
Advisor

Re: Setting ewa0_mode while running OpenVMS

Rob,

Thanks, I'm in the process of getting them to change the switch port to auto now. The server is presently set to auto so once both sides are set I'll let you know if setting both the switch and server to auto fixes the issue. At the present time having the switch set to 100/full and the server (ds25) set to auto is causing network performance issues.

Howard
Hoff
Honored Contributor

Re: Setting ewa0_mode while running OpenVMS

Rob, do ask the LAN Engineer about the earliest of the DE500 NICs. If that's FUD, I'd like to hear about it and will happily go fix the FAQ. :-)

But (more) seriously and with NICs newer than the oldest of the DE500, these negotiation problems tend to be transient. I've hit a few negotiation lock-ups, but have never been able to reproduce them.

And the latest diagnostics that the LAN Engineer has added into the V8.* drivers really help. Say hello to him for me, too.


Robert Brooks_1
Honored Contributor

Re: Setting ewa0_mode while running OpenVMS

Steve wrote . . .

Rob, do ask the LAN Engineer about the earliest of the DE500 NICs. If that's FUD, I'd like to hear about it and will happily go fix the FAQ. :-)

--

I'll check with Dick; note that there are three variants of the DE500; the -AA, the -XA, and the -BA (that's in order from oldest to newest, with "newest" being relatively ancient by hardware standards. There are definitely quite different operating characteristics amongst the three, so it's probably a mistake to lump together in any generalisation. But you probably knew that :-)

I know from experience that those drivers are still maintained; I'll check with Dick to get the final word on autonegotiation and the old, crufty ethernet adapters.

-- Rob
Jim_McKinney
Honored Contributor

Re: Setting ewa0_mode while running OpenVMS

If one end of the connection is set to AUTONEGOTIATE the correct setting for the other end is also AUTONEGOTIATE. However, this autonegotiation of speed and mode only occurs during startup so changes made on the fly will not be noticed until the next boot. To enact useful changes on the fly, autonegotation should be defined in LANCP's permanent database and the current speed/mode of the switch should be set in the volatile/active database.
Willem Grooters
Honored Contributor

Re: Setting ewa0_mode while running OpenVMS

Howard,

This is an issue that has been around for as long as I contribute to the ITRC, and IIRC it's often a matter of mismatch between the NIC and switch in the auto-negotiation. The brand and type of switch is part of the equation. Some combinations do work, some don't, using older NICs in particular. The suggestion given from the beginning is to set both SWITCH and NIC to the same setting, in your case set the NIC to 100Mb FD since the switch is set that way.

Changing the NICs characteristics like you described might require a restart of the device. If you're connecting using ewa0, don't do this online because it would render the system inaccessable over that NIC (connectiosn will be dropped immediately). Use a batchjob (and keep your fingers crossed it will come back).

BTW: The display of TCPIP SHOW INTERFACE is confusing. On my system it shows the interface is set to 100Mb SIMPLEX, though both the (old, crufty DE500 NIC) and switch conntol LEDs tell me 100Mb FD.

Poor network can also be caused by other issues that have nothing to to do with NIC or switch. Network saturation is one possibility (is somebody GHOSTing, or running Windows BACKUP over the network? It is my experience that this blows traffic performance to pieces, except for themselves). DNS mismatches can cause problems as well, depending on what you're trying to do.

@Robert: these DE500 NICs may be considered "old, crufty ethernet adapters" but I wouldn't want to pay those that still (have to) relay on them. So I'm glad the drivers are still maintained....
Willem Grooters
OpenVMS Developer & System Manager
Robert Atkinson
Respected Contributor

Re: Setting ewa0_mode while running OpenVMS

My 2-penny worth......

I've been through a number of DR tests using various DE500 and DE602 cards, and generally found problems when trying to use AUTO on either end. We always set both ends to FastFD to ensure no problems.

After upgrading to Gig cards, I tried the same, but it wouldn't work. After chatting with the engineers and doing some tests, we're now happy that Gig cards should always be set to AUTO for both ends.

Rob.
Jon Pinkley
Honored Contributor

Re: Setting ewa0_mode while running OpenVMS

Both the switch and the embedded NIC are 1Gbps capable.

Autonegotiation should work, and is always recommended for 1Gbps devices.

Yes, there were problems with early switches and NICs that interpreted the autonegotiation specs differently, but the whole discussion about 10/100 devices has no bearing on this discussion.

The switch should be set to Auto, and your problems should go away. Jim's note about autonegotiation only happening at boot (init?) time is news to me, but we generally don't disconnect the cables, so I have no first hand knowledge concerning whether or not autonegotiation works after boot. I would have expected it to work if the cable was unplugged and reconnected.
it depends
Jim_McKinney
Honored Contributor

Re: Setting ewa0_mode while running OpenVMS

Some systems can/do autonegotiate every time a cable is unplugged and then plugged. However, to the best of my knowledge, VMS does not do so. My understanding is that the autonegotiation occurs when the system is initialized and then again when VMS boots and not again after that. I don't currently have the means to test/prove whether this is true.
Richard Stockdale
Frequent Advisor

Re: Setting ewa0_mode while running OpenVMS

set device ewa/full/noauto - you have to turn off auto-negotiation otherwise it will just auto-negotiate again and get the same result (100 mbit half-duplex).

Note that setting the device to what is already set does not result in redoing auto-negotiation (so set dev/full is setting it to the same setting, i.e., enabling full-duplex and having auto-negotiation enabled).

Note that setting the device to anything different from what is set causes the device to be reset (if necessary) and new settings applied. You can reset the device by doing LANCP UPDATE DEVICE/RESET, but that is never necessary to cause new settings to be applied. You can reset the device to cause auto-negotiation to be redone.

Note that any link bounce (of sufficient duration) causes auto-negotiation to be redone. So unplugging and plugging in the cable again causes auto-negotiation to be redone.

Note the most modern devices do auto-negotiation in hardware without driver interaction, with a few exceptions, like the DEGXA-SA (or any fiber variants of Broadcom 570x devices).