Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

T4 Itanium OpenVMS V8.3-1H1 [MON.MODE]User Mode zero?

 
Hein van den Heuvel
Honored Contributor

T4 Itanium OpenVMS V8.3-1H1 [MON.MODE]User Mode zero?


When trying to help analyze performance for an 8-core RX6600 using T4, the USER MODE, counters were reported as zero in the CSV file.

The global counter "[MON.MODE]User Mode", as well as individual counters like "[MON.MODES]Cpu 14 User mode" remained 0 throughout.

Let me assure you there was User mode being burned. Looking 'live' with "MONI MODE" during the same time window showed well over 900% usermode.

The T4 files currently at my disposal were all taken with Hyperthreading enabled, but I _believe_ to have seen this before we issued our "SYS$TEST:HTHREADS on" to flip the flag and rebooted to get the extra processors.

I can not get to my own system just now to try, and testdrive does not have t4 running just now, so I was wondering whether a reader could perhaps give me a 'heads up'?

Does anyone else see ZERO usermode in T4?
under what conditions?

Has anyone seen non-ZERO T4 Usermode data on 8.3-H1 Itanium, with or without hyperthreading?
(no need to reply you have seen usermode on Aplha 8.3 and such... I've seen that too :-)

Thanks,
Hein.

3 REPLIES 3
Ian Miller.
Honored Contributor

Re: T4 Itanium OpenVMS V8.3-1H1 [MON.MODE]User Mode zero?

could be a T4$EXTRACT problem.

Is the MONITOR data file in OpenVMS V8.3-1H1 a different version ?
(the version is in the first record).
____________________
Purely Personal Opinion
Willem Grooters
Honored Contributor

Re: T4 Itanium OpenVMS V8.3-1H1 [MON.MODE]User Mode zero?

I cannot try since I don't have an Itanium at hand :(. But this might point to the problem:

Since T4 relies on MONITOR output (as you know) what is shown:

* if you play back the monitor recording from which the CSV files has been derived
* if you use MONITOR interactively

Since the MONITOR recording format is documented (at least, it once was), you could check in the recording file itself if these values are really zero. If so, the data is not recorded - the next question is why: Does MONITOR skip this data (in certain situations, perhaps) of does it skip this data at all? The interactive run (simultaniously recorded) should tell; playing back should present the same results.

Another possibility is of course that enabling or disabling hyperthreading could trigger another execution path within MONITOR, causing these values to be interpreted as, or set to, zero.
Willem Grooters
OpenVMS Developer & System Manager
Hein van den Heuvel
Honored Contributor

Re: T4 Itanium OpenVMS V8.3-1H1 [MON.MODE]User Mode zero?

Update:
Replaying the captured raw monitor file on the server with $MONITOR/INPUT does show the user-mode ativity. So it is captured fine.

The corresponding columns in the CSV file are all 0.

That leaves the T4-extract process in the middle. I'll check it out if anf when I get a free minute at home.

later...
Hein.