HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

TCP/IP product installation

 
SOLVED
Go to solution
simon_164
Super Advisor

TCP/IP product installation

Dear All,
I have Open VMS V.7.2-2 , on the same CD there is the TCP/IP v5.1-15. Now i need to install this layered product. Whenever i am trying to install i get a product dependency error. I tried to install Open VMS from scratch and include the option to install TCP/IP, the package wasn't installed.
When i try (SHOW NETWORK) i get the error: "NO network information available". I will include in the attachement the errors I am getting.
Any Ideas??
Regards,
14 REPLIES
Ian Miller.
Honored Contributor

Re: TCP/IP product installation

simon, can you post the whole result of
$ PRODUCT INSTALL TCPIP
____________________
Purely Personal Opinion
Andy Bustamante
Honored Contributor

Re: TCP/IP product installation

Do you have a UCX/TCPIP/NAS license installed on the system? TCPIP is a layered product, most Alphas were shipped with a license for TCPIP, but it still needs to be entered before the product is installed.
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
John Gillings
Honored Contributor

Re: TCP/IP product installation

Simon,

When reporting errors, please always post the EXACT command issued and the EXACT and COMPLETE error message (preferably a cut and paste). Your attachment is close, but it's missing the vital detail that tells us what's wrong.

The installation would have included a listing of dependencies earlier in the transcript.
A crucible of informative mistakes
Kris Clippeleyr
Honored Contributor

Re: TCP/IP product installation

Simon,

You do seem to have trouble getting TCP/IP installed on an OpenVMS system.
(similar threads http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=777541 and http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=775922 )
AFAIK, the installation procedure of VMS for Alpha (i.e. booting your Alpha from the distribution CD, and selecting option 1 from the menu), not only installs VMS, but also asks if TCP/IP must be installed (it doesn't care about licenses at that point). If you answer affirmative to that question, TCP/IP is installed on the system. The only thing you have to do thereafter is registering & loading the appropriate licences and configuring TCP/IP and your in business.

Kris (aka Qkcl)
I'm gonna hit the highway like a battering ram on a silver-black phantom bike...
Antoniov.
Honored Contributor

Re: TCP/IP product installation

Hi Simon,
may you remove tcp/up software, which does mean it drop all tcp/ip databases?
If yes, you could:
1) view tcp/ip product with:
$ PRODUCT SHOW PROD *
the tcp/ip suite is tcpip o ucx
2) drop full version of previous installation
$ PROD REMOVE
3) Check for licensing
$ SH LICENSE
4) After of this you can reinstall
$ PROD INSTALL /SOURCE=

Antonio Vigliotti
Antonio Maria Vigliotti
simon_164
Super Advisor

Re: TCP/IP product installation

Dear All,
I have: OPENVMS-ALPHA; OPENVMS-ALPHA-USER; UCX; UCX-IP-CLIENT licenses.
Do you think i will need any other licenses?
By the way what's the differences between these?
I will try today to reformat the disks and install openvms from the start and there i will try to install TCPIP. about the error log it is attached to this thread.
Regards,
Kris Clippeleyr
Honored Contributor
Solution

Re: TCP/IP product installation

Simon,

As for the licenses, that seems enough.
As for the errors:

%PCSI-W-SFTREF, product DEC AXPVMS TCPIP V5.1-15 references DEC AXPVMS VMS
-PCSI-W-SFTRF1, referenced product is not installed and a kit is not available

This could mean that the PCSI database is somehow corrupt. "DEC AXPVMS VMS" is normally the last in the list (meaning the first installed) if you do a PRODUCT SHOZ HISTORY.

Kris (aka Qkcl)
I'm gonna hit the highway like a battering ram on a silver-black phantom bike...
Kris Clippeleyr
Honored Contributor

Re: TCP/IP product installation

Simon,

Sorry, made a typo.
Should be
PRODUCT SHOW HISTORY

Kris (aka Qkcl)
I'm gonna hit the highway like a battering ram on a silver-black phantom bike...
simon_164
Super Advisor

Re: TCP/IP product installation

for PRODUCT SHOW HIST there is : product register, then product removed, then registered then removed. because i did all these stuff. However when PRODUCT SHOW PROD i get the insdeperror. Do you think that the package is corrupt? if it is, how to install tcpip. I badly need to telnet the system. Because in the company we have only one ALPHA system and two of us have to learn it.
Kris Clippeleyr
Honored Contributor

Re: TCP/IP product installation

Simon,

What I would do:
1. Shut down the Alpha
2. Boot it from the installation CD
3. Install VMS & DECnet & TCPIP from the CD (Option 1 from the menu presented)
4. Once the installation procedure prompts for it, specify INITIALIZE, __NOT__ PRESERVE.
5. After the installation, reboot the Alpha from the newly created system disk.
6. Log in using the SYSTEM account.
7. Configure TCP/IP using @SYS$MANAGER:TCPIP$CONFIG

See also the OpenVMS Alpha Upgrade and Installation Manal.

Good luck,

Kris (aka Qkcl)
I'm gonna hit the highway like a battering ram on a silver-black phantom bike...
simon_164
Super Advisor

Re: TCP/IP product installation

Now I got the version 7.3-2 and i'll try that, Although I have tried it before with the previous version but i wasn't sure about the CD.
Regards,
simon_164
Super Advisor

Re: TCP/IP product installation

Thx all,
now i have the system installed with TCP/IP installed and all licenses loaded.
Regards,
Anton van Ruitenbeek
Trusted Contributor

Re: TCP/IP product installation

Andy

Maybe not enough licence ?

All the products of VMS can be installed without any license. Only the IVP will fail (of course).
When starting up the process(es) you need the licenses.

AvR
NL: Meten is weten, maar je moet weten hoe te meten! - UK: Measuremets is knowledge, but you need to know how to measure !
simon_164
Super Advisor

Re: TCP/IP product installation

guys, the problem was with the CD. Maybe something was corrupt.
The new CD OpenVMS 7.3-2 has no problem and the operation went throught smoothly.