Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

TCPIP$CONFIG Questions/Issues

 
SOLVED
Go to solution
Warren G Landrum
Frequent Advisor

TCPIP$CONFIG Questions/Issues

Gentlemen,

Am having a problem running TCPIP$CONFIG. Running VMS 8.3 on Alpha.

Here's the deal. After completing this initial configuration of the server, I wanted to change the Host Name of this server before having it added into DNS by our newtork people.
So I ran TCPIP$CONFIG, bu instead of just going into #2 Interfaces and just changing the name, I deleted the configuration from in there and deleted the name.

But here's the major problem now. Whenever I try to run TCPIP$CONFIG, when I do the 5 options: #1 Domain - # 2 Interfaces #3 Routing, #4 Bind and #5 Time Zone, it won't let me do #2 Interfaces. Kicks me out with following error after it brings up the Interface & Address Configuration Menu:

%DCL-W-NOQUAL, qualifiers not allowed - supply only verb and parameters \JOB\

Then it kicks me to DCL.

So I tried to config the interface directly thru UCX with the SET INTERFACE we0 and SET COFIG INTERFACE we0 commands. It took these one time and I was able to telnet in and out of that box. But by the time I got back to my desk, it would not let me telnet into the box.

I rebooted system,and since then it only kept the info set up by the SET CONFIG INTERFACE WE0 but when I try to do a SET INTERFACE WE0, it tells me the internet driver is not loaded.

So seems as tho I've got 2 different issues here.

Has anyone ever had problems with the menu like I explained above? If yes, what did you do to fix? I have not loaded any patches on this system yet, so I need to download the latest one, but at this point, I guess I'll have to download to another system and either xfer it by tape or Decnet, which I have not set up yet.

PLEASE HELP!!!

Warren
3 REPLIES 3
Jim_McKinney
Honored Contributor
Solution

Re: TCPIP$CONFIG Questions/Issues

The code seems to protect against redefinition of DEFINE and DEASSIGN which are both invoked with the /JOB qualifier. But, the code then goes on to use abbreviated forms of those verbs. Any chance that you have a wildcarded symbol definition for DEF*INE or DEAS*SIGN? Or maybe just DEF or DEASS symbol definitions? If so, try deleting those symbols and retrying.

$ search sys$manager:tcpip$config.com "dclcmds:" /window=(0,7)
$set_dclcmds:
$backup := backup
$call := call
$close := close
$copy := copy
$create := create
$deassign := deassign
$define := define
$ search sys$manager:tcpip$config.com "/job"
define /job tcpip$fsafe_pgflquo &_pgflquo)
$deass /job tcpip$fsafe_pgflquo
_var = f$element(0, " ", _line) ; def/job tcpip$_var &_var)
$deass/job tcpip$_var
def/job/nolog tcpip$_var &_line)
$deass/job tcpip$_var
def/job tcpip$_refcnt &_refcnt)
$deass/job tcpip$_refcnt
def/job tcpip$_interface &_interface)
$deass/job tcpip$_interface
def/job tcpip$_interface &_interface)
$deass/job tcpip$_interface
def/job tcpip$def_netmask &_netm)
$deass/job tcpip$def_netmask
def/job tcpip$def_netmask &_netm)
$deass/job tcpip$def_netmask
def/job tcpip$_config &_line)
$deass/job tcpip$_config
Warren G Landrum
Frequent Advisor

Re: TCPIP$CONFIG Questions/Issues

Jim,

You it the nail on the head!!! I had DEF defined in my login.com and as soon as I deleted it and ran tcpip$config, the Interface section worked perfectly.

Thanks for getting back to me so quickly. Wish I could give you 20 points instead of 10 !!!

Warren
Warren G Landrum
Frequent Advisor

Re: TCPIP$CONFIG Questions/Issues

Jim bailed me ou - as I was in apparent brainlock!!