Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

TCPIP Name_Service : Local domain: * Mismatch *

Dirk Bogaerts
Frequent Advisor

TCPIP Name_Service : Local domain: * Mismatch *

Hi folks,

after having changed my node & cluster IP-addresses (and nothing else) on a 2-node cluster running OpenVMS V7.2-1 / TCPIP V5.1 - ECO 5, I have the following 'Mismatch' problem when I do TCPIP> SHOW NAME :
TCPIP> show name

BIND Resolver Parameters

Local domain: * Mismatch *

System

State: Started, Enabled

Transport: UDP
Domain: LOCAL.B.C
Retry: 4
Timeout: 4
Servers: dns1.A.B.C, dns2.A.B.C
Path: LOCAL.B.C, A.B.C

Process

State: Enabled


The DNS servers are W2K-servers. I changed the IP's in TCPIP$CONFIG before shutdown and W2K DNS was updated before rebooted of the cluster.
During TCP/IP startup, I had a lot of errors which weren't there before :
%TCPIP-I-INFO, TCP/IP Services startup beginning at 31-MAR-2004 14:32:05.00
%TCPIP-I-NORMAL, timezone information verified
%RUN-S-PROC_ID, identification of created process is 20200219
%TCPIP-I-SETLOCAL, setting domain and/or local host
%TCPIP-E-INETERROR, internet interface error
-TCPIP-E-INVQUAL, invalid qualifier value for /LOCAL_HOST
-RMS-E-RNF, record not found
%TCPIP-I-STARTCOMM, starting communication
%TCPIP-I-SETPROTP, setting protocol parameters
%TCPIP-I-NOMORE, parameter or qualifier for ALL COMMUNICATION OPTIONS no longer
supported; see the documentation for valid options and re-enter command
%TCPIP-I-DEFINTE, defining interfaces
%TCPIP-I-STARTNAME, starting name service
%TCPIP-E-NAMEERROR, error processing name service request
-TCPIP-E-INSBINDDATA, insufficient data to enable BIND
%TCPIP-S-STARTDONE, TCP/IP Kernel startup completed

After startup the BIND was Disabled, Stopped.
Although enabling& starting in TCPIP$CONFIG showed 'Enabled Started' in the Server components overview, in TCPIP Show Name still indicated "State: Started, Disabled". With a SET NAME /ENABLE in TCPIP this was resolved, but I still have the mismatch message (disabling&stopping + enabling,starting) does not help. Next step is rebooting, but this has the be planned, so for the moment the 'mismatch' keeps appearing.


All help is very welcome !!
15 REPLIES
Ian Miller.
Honored Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Ensure the local host name is defined in the host table by
UCX SHOW HOST xxxxx
you may need to get rid of the name then redefine it
UCX SET HOST xxxxx/addr=n.n.n.n
then check address in
UCX SHOW INTERFACE
and domain name in
UCX SHOW COMM

Simplest may be to delete name then use TCPIP$CONFIG and define the IP address of the interface once more.
____________________
Purely Personal Opinion
Martin P.J. Zinser
Honored Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Hello Dirk,

the "record not found" smells like a problem with your hostname in the local database. You might want to check the startup procedures to see in which context the /local_host qualifier is used (tried to do that on my system, but it seems not to be there in tcpip 5.4)

Greetings, Martin
Mike Naime
Honored Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Dirk:

Ian is correct. In order to change your IP address, you must first blow it away in the local hosts table, then you can change the IP addresses through TCPIP$CONFIG.
VMS SAN mechanic
Dirk Bogaerts
Frequent Advisor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Ian, Mike,

after changing the IP's in TCPIP$CONFIG & rebooting, the local host contained automatically fully qualified (uppercase) entries for the cluster & it's nodes with the new IP's:
nn.nn.nn.n1 CLUSTERNAME.LOCAL.B.C
nn.nn.nn.n2 NODE1NAME.LOCAL.B.C
nn.nn.nn.n3 NODE2NAME.LOCAL.B.C
These entries replaced the old manually entered entries :
oldnn.nn.n1 CLUSTERNAME, clustername
oldnn.nn.n2 NODE1NAME, node1name
oldnn.nn.n3 NODE2NAME, node2name

Some weeks ago I did exactly the same procedure (=only TCPIP$CONFIG for Routing & Interfaces, followed by reboot) to change the IP-addresses on a standalone system and everything was OK right away.

On the cluster, I've in the mean time added in the local host some aliases so that it now contains lower & upprcase (I'm not sure it's needed ??) and fully qualified & unqualif. formats, so all possible variants are covered. Afterwards, I've stopped&disabled + enabled&started BIND, but the 'MISMATCH' keeps appearing in SHOW NAME_SERVICE.

I also notice now with SHOW COMM that the nodename on the standalone system is in uppercase and on the clusternodes in lowercase. Is TCPIP case-sensitive ??? Anyway, I didn't touch these names as they haven't changed for years. And these upper/lower-case differences didn't prevent the Name_service from working correctly before.


Martin, I've searched the /LOCAL_HOST in TCPIP$STARTUP.COM and in several procedures called from there, but no luck...



Maybe rebooting the cluster will clear this situation (but need to wait a week or 2), but if anybody can pinpoint in the meantime the exact origin of the 'Mismatch' message, I can rule out any remaining misconfig's, so help is still much appreciated.
Lokesh_2
Esteemed Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Hi,

Check for logical TCPIP$INET_HOST & TCPIP$INET_HOSTADDR. These logicals are set with tcpip set comm comand.

Best regards,
Lokesh
What would you do with your life if you knew you could not fail?
Ian Miller.
Honored Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

try
TCPIP SET NAME/SYS/DOMAIN=a.b.c
____________________
Purely Personal Opinion
Martin P.J. Zinser
Honored Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Hi,

you do want to have both UPPER and lowercase enries. IIRC gethostbyname barfs if you only have the uppercase version.

Greetings, Martin

P.S. Does TCPIP$BIND_DOMAIN point at the correct value?
Dirk Bogaerts
Frequent Advisor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Martin,
thanks for the info, that most likely explains why Oracle failed to start just after the changes & reboot:
ORA-27300: OS system dependent operation:gethostbyname failed with status: 0

After having replaced the local host entry containing only the fully qualified uppercase hostname, with an unqualified upperuppercase + lowercase alias entry, the database started again.
Dirk Bogaerts
Frequent Advisor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Here are some logicals, all seems to be ok :
"TCPIP$INET_DOMAIN" = "LOCAL.B.C" in uppercase
"TCPIP$INET_HOST" = "nodename" in lowercase
"TCPIP$BIND_DOMAIN" = "LOCAL.B.C" in uppercase


Using TCPIP SET NAME/SYS/DOMAIN=LOCAL.B.C didn't change anything, before and after same result :
TCPIP> show name

BIND Resolver Parameters

Local domain: * Mismatch *

System

State: Started, Enabled

Transport: UDP
Domain: LOCAL.B.C
Lokesh_2
Esteemed Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Hi,

On my system TCPIP$INET_DOMAIN is in lowercase.

Anyway, can you do one thing. Rename all the sys$system:tcpip$*.dat files and reconfigure TCP/IP from scratch. This may resolve the issue without a reboot.

Thanks & regards,
Lokesh Jain
What would you do with your life if you knew you could not fail?
Ian Miller.
Honored Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

to start with a new config can use the TCPIP CREATE commands or just rename the old ones
(RENANE SYS$SYSTEM:TCPIP$*.DAT .DATOLD)
and execute TCPIP$CONFIG again.
____________________
Purely Personal Opinion
Martin P.J. Zinser
Honored Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

TCPIP$INET_DOMAIN is lowercase for me too. Changing this might be worth a try.

Greetings, Martin
Jeremy Stubbs
Occasional Advisor

Re: TCPIP Name_Service : Local domain: * Mismatch *

You need to check what the config in the database is:

The /LOCAL_HOST during boot refers to whats displayed against "Local host" in $ TCPIP SHO CONFIG COMM

You then need to check that this host name is in the local host database TCPIP SHO HO

Finally you'll then need to check the name resolver config
$ TCPIP SHO CONFIG NAME
failing that you should log a call ;0)
Willem Grooters
Honored Contributor

Re: TCPIP Name_Service : Local domain: * Mismatch *

One thing I learned anyway - from Unix - is to specify the host you're on in both uppercase and lowercase, in the local HOST file (TCPIP SET HOST "name" /ALIAS="NAME" ...) and in DNS. That way, you can avoid problems caused by case-sensitivity.

I think otehrs mentioned this as well:
What domain shows up when:

$ TCPIP SHOW COMMUNICATION
$ TCPIP SHOW CONFIGURATION NAME_SERVICE /FULL
$ TCPIP SHOW NAME_SERVICE
$ SHOW LOG TCPIP$BIND

and check the domain- and host info against your BIND configuration files.

Willem
Willem Grooters
OpenVMS Developer & System Manager
Dirk Bogaerts
Frequent Advisor

Re: TCPIP Name_Service : Local domain: * Mismatch *

Thanks guys for all the extra tips.

I didn't take up the suggestions to start from scratch (the cluster has high uptime requirements, I try to limit drastic changes as much as possible).
All other tips regarding TCPIP SHOW & SHOW LOGICAL commands revealed nothing abnormal.

I suspect that the inital uppercase-only LOCAL HOST entries might be the source of my problem. This was the only thing I've modified (by including lowercase hostnames) since my initial reboot to activate the new IP adresses. Although subsequent stop/start of BIND didn't make the '*Mismatch*' go away, a complete stop/start of TCPIP on one node, some two weeks later, did solve the problem on that node. The other nodes still shows the '*Mismatch*' in TCPIP SHOW NAME.

By the way, the reboot of one node was an unplanned one; thanks Compaq for designing the DS20E with N+1 triple redundant power-supplies, but only one power-cord. All it took was a tripped circuit-breaker, to powerdown the system.

Greetings