Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

TCPIP> SHOW HOST doesn't work with Tru64 UNIX Bind Server

 
john Dite
Frequent Advisor

TCPIP> SHOW HOST doesn't work with Tru64 UNIX Bind Server

I've set up a Tru64 UNIX(V5.1 Rev. 732) Bind Server V8.2.2. My Bind Resolver is an OpenVMS 7.3-2 with TCPIP V5.4 ECO2.

Previously I was running the Bind Server on another OpenVMS 7.3-2 System with TCPIP V5.4 ECO2.

Previously the command
TCPIP> SHOW HOST worked

Now I an individual
TCPIP> SHOW HOST myhost
works but a
TCPIP> SHOW HOST
doesn't.
I get a display of the HOSTS in the LOCAL Database and the following error:
%TCPIP-W-NORECORD, information not found
-TCPIP-E-BIND_NO_ZONEXFR, zone transfer was unsuccessful

Looking at the daemon log on the Tru64 UNIX System I see the following entries:
Oct 25 17:55:23 manix named[70140]: unapproved AXFR from [16.185.64.50].49182 for "fkr.cpqcorp.net" (not authoritative)
Oct 25 17:55:24 manix named[70140]: unapproved AXFR from [16.185.64.50].49183 for "fkr.cpqcorp.net" (not authoritative)

I've found a few hints in the Web that tell me
" indicates that your name server denied a zone transfer of ?.?.??.???.in-addr.arpa, probably because of a syntax error or illegal domain name in the zone".

Now the question is this a feature of the OpenVMS BIND Server or can one configure the Tru64 UNIX or any other V8 BIND Server to support this?

Any hints would be appreciated.
John
2 REPLIES
john Dite
Frequent Advisor

Re: TCPIP> SHOW HOST doesn't work with Tru64 UNIX Bind Server

Even though the OpenVMS Documentation (See TCP/IP Management Chapter 6.5.3.6.3 Access Control Options allow-transfer) may allude one to believe that the default "is to allow to transfer to all hosts", this does not seem to be the case for the Tru64 UNIX Bind 8 implementation.

I got it to work in that I set in the OPTIONS statement the allow-transfer attribute with subnets that were going to query the BIND V8 server. After I had done that I got the results that I had been looking for. The equivalent statement in the Tru64 UNIX daemon log file should look like this:

Oct 26 15:27:47 manix named[70140]: Ready to answer queries.
Oct 26 15:28:03 manix named[70140]: approved AXFR from [16.185.64.50].49208 for "fkr.cpqcorp.net"
Oct 26 15:28:03 manix named[70140]: zone transfer (AXFR) of "fkr.cpqcorp.net" (IN) to [16.185.64.50].49208

Looking at the cause of the problem I would have expected a BIND ACL error message rather than "not authoritative".
john Dite
Frequent Advisor

Re: TCPIP> SHOW HOST doesn't work with Tru64 UNIX Bind Server

see last reply