HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

TTA0 to Lat port settings..

 
Nigel Wright_1
Frequent Advisor

TTA0 to Lat port settings..

We have a device TTA0:, which I think is a DZQ11 type device in a VAX. This used to direct talk to external device.

We now need to talk to a device - the same device - but in another room onsite. We have a DECServer located there and I have been atempting to set this up to the same task.

Here is the TTA0:

sho dev/full tta0:

Terminal TTA0:, device type unknown, is online, record-oriented device, carriage
control.

Error count 0 Operations completed 1154653563
Owner process "" Owner UIC [SYSTEM]
Owner process ID 00000000 Dev Prot S:RWPL,O:RWPL,G,W:RW
Reference count 0 Default buffer size 80



sho term/full tta0:
Terminal: _TTA0: Device_Type: Unknown Owner: No Owner

Input: 9600 LFfill: 0 Width: 80 Parity: Even
Output: 9600 CRfill: 0 Page: 24 Terminate on parity errors

Terminal Characteristics:
Interactive Echo Type_ahead No Escape
No Hostsync TTsync Lowercase No Tab
No Wrap Scope No Remote Eightbit
No Broadcast No Readsync No Form Fulldup
No Modem No Local_echo No Autobaud No Hangup
No Brdcstmbx No DMA No Altypeahd Set_speed
No Commsync Line Editing Overstrike editing No Fallback
No Dialup Secure server No Disconnect No Pasthru
No Syspassword No SIXEL Graphics No Soft Characters No Printer Port
Numeric Keypad No ANSI_CRT No Regis No Block_mode
No Advanced_video No Edit_mode No DEC_CRT No DEC_CRT2
No DEC_CRT3 No DEC_CRT4 No DEC_CRT5 No Ansi_Color
VMS Style Input

We have alloacted LTA888 to this, which is as below:-

sho dev/full lta888

Terminal LTA888:, device type unknown, is online, record-oriented device,
carriage control.

Error count 0 Operations completed 161
Owner process "" Owner UIC [SYSTEM]
Owner process ID 00000000 Dev Prot S:RWPL,O,G,W:RWPL
Reference count 0 Default buffer size 80

sho term/full lta888
Terminal: _LTA888: Device_Type: Unknown Owner: No Owner

Input: 9600 LFfill: 0 Width: 80 Parity: Even
Output: 9600 CRfill: 0 Page: 24 Terminate on parity errors

Terminal Characteristics:
Interactive Echo Type_ahead No Escape
No Hostsync TTsync Lowercase No Tab
No Wrap Scope No Remote Eightbit
No Broadcast No Readsync No Form Fulldup
No Modem No Local_echo No Autobaud No Hangup
No Brdcstmbx No DMA No Altypeahd Set_speed
No Commsync Line Editing Overstrike editing No Fallback
No Dialup Secure server No Disconnect No Pasthru
No Syspassword No SIXEL Graphics No Soft Characters No Printer Port
Numeric Keypad No ANSI_CRT No Regis No Block_mode
No Advanced_video No Edit_mode No DEC_CRT No DEC_CRT2
No DEC_CRT3 No DEC_CRT4 No DEC_CRT5 No Ansi_Color
VMS Style Input


We are getting data set hangup error.

Any ideas what is wrong and what the DECServer port details should be?

Many Thanks Nigel

18 REPLIES
Volker Halle
Honored Contributor

Re: TTA0 to Lat port settings..

Nigel,

without first looking at all the different settings... Can you communicate with the port on the DECserver ?

$ COPY some_file LTA888:/LOG

If this fails, you can't even establish a LAT connection to the remote port. The port must be set to 'access remote' and the DECserver and port name must be set with LATCP> set port lta888:/node=xxx/port=yyy

Volker.
Nigel Wright_1
Frequent Advisor

Re: TTA0 to Lat port settings..

I tried:-

> copy/log login.com; lat888:
%COPY-E-OPENOUT, error opening LAT888:[SYSMGR].; as output
-RMS-F-DEV, error in device name or inappropriate device type for operation
> copy/log login.com; lta888:
%COPY-E-WRITEERR, error writing LTA888:[]LOGIN.COM;39
-RMS-F-WER, file write error
-SYSTEM-F-HANGUP, data set hang-up
%COPY-W-NOTCMPLT, SYS$COMMON:[SYSMGR]LOGIN.COM;39 not completely copied
>

I did a connect via ncp and instead of letting in by typing access and then your in - it just let me try 3 times and then chucked me out! - eg locked session I had to do a control d to get out.

Steve-Thompson
Regular Advisor

Re: TTA0 to Lat port settings..

Hi Nigel

You havent mentioned the configuration of the port connected to remote device.
(Modem or whatever) ie. the DECserver.
What model of DECserver is it?

Connect to the DECserver and look at the port in question.
The DECserver will have to support DTR signalling for modem control or you will need to configure for XON.

If the port doesnt coincide with the remote device then it will give the problems you are seeing.

You will need obviouly the speed/stop-bits/parity to conicide.

Access = remote

If XON isnt enough
set privilege (you'll need the password)
Signal control = enable
signal select = cts-dtr (or RI-DCD)

Have a look at these issues
Regards
Steven
Heinz W Genhart
Honored Contributor

Re: TTA0 to Lat port settings..

Hi Niggel

what kind of cable ar you using. Straight or crossover?

Regards

Geni
Volker Halle
Honored Contributor

Re: TTA0 to Lat port settings..

Nigel,

you can't communicate via LAT with the desired port on the terminal server (SS$_HANGUP is telling you this).

You need to check MC LATCP SHOW PORT LTA888: and the terminal server (name ?) and port settings (access remote ?) first.

Then worry about modem settings etc.

Volker.
Nigel Wright_1
Frequent Advisor

Re: TTA0 to Lat port settings..

That many replies don't know where to start.

Its a lovely (old) DS200/MC

> MC LATCP SHOW PORT LTA888:

Local Port Name: _LTA888: Local Port Type: Application (Queued)
Local Port State: Inactive
Connected Link:

Target Port Name: PORT_2 Actual Port Name:
Target Node Name: Actual Node Name:
Target Service Name: Actual Service Name:

The real problem I have is not being able to do a mc ncp connect node DS2D9B

It's in the ncp database.

> mc ncp sho node DS2D9B


Node Volatile Summary as of 11-JUN-2007 12:45:09

Node State Active Delay Circuit Next node
Links

4.209 (DS2D9B) 1.103 (xxxx)
>

On the cable - just checking.

Many thanks for your help and support.

Nigel.









Volker Halle
Honored Contributor

Re: TTA0 to Lat port settings..

Nigel,

there is Node name in the LATCP database for port LTA888: - no wonder you can't connect via LAT...

Volker.
Steve-Thompson
Regular Advisor

Re: TTA0 to Lat port settings..

Hi Nigel

(and good morning Volke)

Try using the MAC address
MC NCP CONN VIA EWA-0 PHY ADDR 08-00-2B-2D-9A-9D

Substitue the NCP circuit name "ewa-0" to whatever you need.

Regards
Nigel Wright_1
Frequent Advisor

Re: TTA0 to Lat port settings..

On more thing that might be relevant.

The network guys tell me they allowed the LAT protocol through to this port - by that I mean the port the DECSever plugs into - The DS200 boots (MOP - Loads) but does that prove that LAT is enabled?

Also I can plug a VT in and connect to a LAT service = node, so I suppose it must be working ok.

Not sure.

Thanks Nigel.

Volker Halle
Honored Contributor

Re: TTA0 to Lat port settings..

Nigel,

if the server is loaded via MOP and you can connect from the DECserver to your VMS system, the network seems to be o.k.

You need to set up the NODE name in your LATCP database:

$ MC LATCP SET PORT LTA888:/NODE=DS2D9B/PORT=PORT_2

Then check with Local> SHOW SERVER that the server name is set correctly. And check PORT_2 for access=remote. If you would plug in your VT to Port 2, then you should see on the screen, whatever you (successfully) copy to LTA888: from your VMS system.

Volker.
Steve-Thompson
Regular Advisor

Re: TTA0 to Lat port settings..

Hi again Nigel

If you can connect to a LAT service SOMEWHERE on the net then thats a very good start. You have incoming connectivity.
We can assume then, your VT connects to the VAX in question!

So you should continue with the suggestions you already have to get the required "outging" connectivity.

Start with the LATCP checks, Port config, and the cable too!

Steven


Ian Miller.
Honored Contributor

Re: TTA0 to Lat port settings..

Note that to do NCP CONNECT then your LAN has to allow the MOP-RC protocol. This is a different ethernet protocol type than LAT.
____________________
Purely Personal Opinion
Nigel Wright_1
Frequent Advisor

Re: TTA0 to Lat port settings..

Another node boots the DECServer.

I have now defined the node in NCP and now get:-
> MC LATCP SHOW PORT LTA888:

Local Port Name: _LTA888: Local Port Type: Application (Queued)
Local Port State: Inactive
Connected Link:

Target Port Name: PORT_2 Actual Port Name:
Target Node Name: DS2D9B Actual Node Name:
Target Service Name: Actual Service Name:

>

We also have on the node with LTA88 try to do the comms link:-

> mc ncp sho node DS2D9B


Node Volatile Summary as of 11-JUN-2007 13:38:12

Node State Active Delay Circuit Next node
Links

4.209 (DS2D9B) 1.103 (xxxx)
>

> mc latcp sho port lta888

Local Port Name: _LTA888: Local Port Type: Application (Queued)
Local Port State: Inactive
Connected Link:

Target Port Name: PORT_2 Actual Port Name:
Target Node Name: DS2D9B Actual Node Name:
Target Service Name: Actual Service Name:

>

This happens:-

> mc ncp sho know cir


Known Circuit Volatile Summary as of 11-JUN-2007 13:40:13

Circuit State Loopback Adjacent
Name Routing Node

ISA-0 on

> mc ncp CONN VIA ISA-0 PHY ADDR 08-00-2B-1D-F6-2F
%SYSTEM-F-ILLCNTRFUNC, illegal ACP control function
>

Still trying to connect remotely as it is very difficult visit where it is as it is in a production area screened off to visitors.

Thanks Nigel.




Steve-Thompson
Regular Advisor

Re: TTA0 to Lat port settings..

.... connect to the node that does the MOP load of the DS in question and try
$mc ncp conn via....
from there???
Volker Halle
Honored Contributor

Re: TTA0 to Lat port settings..

Nigel,

defining the DECserver in the DECnet node database, does NOT help at all with LAT connectivity. Now that you've defined the node for LTA888:, what does the COPY file LTA888: command report ?

The ILLCNTRFUNC error may indicate, that you're running DECnet-OSI on that node. If so, you would need the SET HOST/MOP command.

Volker.
Nigel Wright_1
Frequent Advisor

Re: TTA0 to Lat port settings..

Thanks to everyone for their detailed replies - I am busy now, but I will get back to everyone about this tomorrow.

Many Thanks again for the excellent response.

Nigel.

Dean McGorrill
Valued Contributor

Re: TTA0 to Lat port settings..

Hi Nigel,
if its phase V, connecting to the terminal server would look something like..

$ SET HOST/MOP/CIR=CSMACD-0/ADDRESS=08-00-2B-XX-XX-XX

..I used to go to the server to enter
port settings. I've included some dcl
that creates the commands. edit as needed
or use any of it, if helps you - Dean


Nigel Wright_1
Frequent Advisor

Re: TTA0 to Lat port settings..

Thanks for everyone for help I received in getting the ports working.