Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to install DFU on OpenVMS V8.4-2L1

 
SOLVED
Go to solution
JeradMason
Occasional Advisor

Trying to install DFU on OpenVMS V8.4-2L1

Good afternoon,

I'm trying to install DFU on OpenVMS V8.4-2L1 from https://www.digiater.nl/dfu.html

I've added it to a local users home directory, and ran "product install dfu" getting the following. Is this due to the missing manifest file, or some other issue?

Best Regards

$ product install dfu

Performing product kit validation of signed kits ...
%PCSI-I-CANNOTVAL, cannot validate DKB1:[000000.USERS.CONCERO]hp-vms-dfu-v0302--
1.pcsi;1
-PCSI-I-NOTSIGNED, product kit is not signed and therefore has no manifest file

The following product has been selected:
HP VMS DFU V3.2 Layered Product

Do you want to continue? [YES]

Configuration phase starting ...

You will be asked to choose options, if any, for each selected product and for
any products that may be installed to satisfy software dependency requirements.

Configuring HP VMS DFU V3.2: Disk and File Utilities for OpenVMS Alpha

This product is unsupported on Alpha VMS versions

before V7.3-1, on IA64 before V8.2 and on Vax.

%PCSIUI-E-ABORT, operation terminated due to an unrecoverable error condition

6 REPLIES 6
Steven Schweda
Honored Contributor

Re: Trying to install DFU on OpenVMS V8.4-2L1

> I'm trying to install DFU on OpenVMS V8.4-2L1 from
> https://www.digiater.nl/dfu.html

   That's a VMS release from VSI.  As a mere hobbyist/peon, I have no
experience with it, so I know nothing, but...

> [...] Is this due to the missing manifest file, [...]

   The "%PCSI-I-" stuff is informational, not fatal.

> %PCSIUI-E-ABORT, operation terminated due to an unrecoverable error
> condition

   That's a real error.  I'd guess that the "HP VMS DFU" kit installer
was expecting to see "HP" somewhere, and couldn't cope when it saw
"VSI" there.  (It's been a while since "October 2006".)

   You might try to get some "info@digiater.nl".  There might be a
VSI-compatible kit available, or there may be some well-known
work-around (about which I know nothing).

   Or, you could try to disassemble the PCSI kit, and fix it yourself.

Jur van der Burg
Respected Contributor
Solution

Re: Trying to install DFU on OpenVMS V8.4-2L1

Get this:

https://www.digiater.nl/download/dfu032_vsi.zip

Jur (owner of digiater.nl).

 

JeradMason
Occasional Advisor

Re: Trying to install DFU on OpenVMS V8.4-2L1

Apologies, I tagged this as the solution a bit prematurely, as I did not have time to test it but wanted to acknowledge your response promptly. I really appreciate the reply, but I am unfortunately running into the same error as above. Any help would be greatly appreciated, though I understand if nothing can be done. 

Volker Halle
Honored Contributor

Re: Trying to install DFU on OpenVMS V8.4-2L1

The HP-VMS-DFU-V0302--1.PCSI$DESCRIPTION file from the hp-vms-dfu-v0302--1.pcsi kit in dfu032_vsi.zip has been modified to allow linking DFU on <software VSI I64VMS VMS>, but the initial check for the installed version of OpenVMS does not seem to have been corrected:

product HP VMS DFU V3.2 full ;
    if (<software DEC VAXVMS VMS installed before> or ((not <software DEC AXPVMS VMS installed before version minimum V7.3-1>) and (not <software HP I64VMS VMS installed before version minimum V8.2>))) ;
        error UNSUPP_VMS_VER abort ;

The above check seems to fail as shown by the text in module UNSUPP_VMS_VER in the library HP-VMS-DFU-V0302--1.PCSI$TLB: before V7.3-1, on IA64 before V8.2 and on Vax.

You can try to fix this yourself or wait for Jur to fix it and provide a new kit.

Volker.

Volker Halle
Honored Contributor

Re: Trying to install DFU on OpenVMS V8.4-2L1

Please also specify, on which architecture you want to install DFU: VSI OpenVMS on Integrity V8.4-2L1 or VSI OpenVMS on Alpha V8.4-2L1 - both variants need to be considered in the PCSI description file of the kit.

Consider to extract the files from the PCSI kit and link DFU yourself: $ PRODUCT EXTRACT FILE DFU/SELECT=*

You'll find the necessary commands in the *.PCSI$DESCRIPTION file.

Volker.

Jur van der Burg
Respected Contributor

Re: Trying to install DFU on OpenVMS V8.4-2L1

Apologies,

I replaced the file on my server with a newer version that should work. Let me know if that helps.

Jur.