cancel
Showing results for 
Search instead for 
Did you mean: 

UCX Commands

 
SOLVED
Go to solution
Mike D'Amico
Occasional Advisor

UCX Commands

Hello, I am using OpenVMS v7.2-1 on an Alpha 8200. I need to increase the number of TELNET sessions allowed from 400 to 514. I have used the command UCX> SET SERVICE TELENT/LIMIT=514. However, when I do a UCX> SHOW SERVICE TELENT/FULL the limit has not increased. Do I have to stop/restart TELENET services or reboot the server now? Also, will this change also affect the permanent DB?
7 REPLIES 7
Hoff
Honored Contributor
Solution

Re: UCX Commands

Yes, restart telnet. Or restart TCP/IP services. Or reboot.

Yes, it's permanent. (But it's not dynamic. See above.)

One of the existing discussions found via Google:

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=960393

The limits dictated by the system parameters CHANNELCNT and IJOBLIM and a few other tweaks can also come into play here.
Andy Bustamante
Honored Contributor

Re: UCX Commands


You need to:

UCX DISABLE SERVICE TELNET
UCX ENABLE SERVICE TELNET

I recomend not doing this from a telnet session of course. The change is to the permanent configuration. Are you limiting logins? You can also use SET LOGIN /INTERACTIVE=514 as long as your telnet limit also allows these connections.

With 7.2-1 you can also move to TCPIP 5.1, which corrects some telnet connection issues with appropriate ECOs. Do doubt you're aware that 7.2-1 is years out of support.

Andy Bustamante
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
John Gillings
Honored Contributor

Re: UCX Commands

Mike,
Just in case it's not obvious...

$ TCPIP DISABLE SERVICE TELNET
$ TCPIP ENABLE SERVICE TELNET

will kill all existing TELNET sessions.

So, you've got 400 users connected using telnet, and you need some more. The only way to do it is to ask all 400 users to logout first? What is wrong with this picture?

The OpenVMS Ambassadors have been lobbying TCPIP Engineering for years to find a way to be able to increase telnet limits without requiring a DISABLE/ENABLE :-(

Maybe one day...
A crucible of informative mistakes
Hoff
Honored Contributor

Re: UCX Commands

IIRC, the TCP/IP engineering folks were quite fond of recommending use the shutdown and startup procedures - and not the DISABLE / ENABLE sequence - for some years. There were (at least in years past) cases where DISABLE / ENABLE would leave the system state in the weeds for certain of the server applications.
Wim Van den Wyngaert
Honored Contributor

Re: UCX Commands

May be there are a lot of dangling sessions from e.g. people that power off their pc when going home. Decreasing the keepalive time could decrease the number of such sessions and thus may be avoid the need to increase the parameter.

There are also scripts around that kill long-time idlle sessions (e.g. 24h without touching a key).

fwiw

Wim
Wim
Mike D'Amico
Occasional Advisor

Re: UCX Commands

Rebooted server this AM. The change took. Thanks for your help. I will implement the keepalive timer as well. Great suggestion!!!
Mike D'Amico
Occasional Advisor

Re: UCX Commands

Problem solved. Rebooted server and changes were applied. Also implemented the Keepalive timmer as suggested.