Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

URGENT Problem Installing Images

SOLVED
Go to solution
Phillip Thayer
Esteemed Contributor

URGENT Problem Installing Images

We had some system sharable images removed as installed images. One of the shareables that was removed was SMGSHR.EXE. So when I went in to install the executables back into the system I get the following error:

%DCL-W-ACTIMAGE, error activating image SMGSHR
-CLI-E-IMGNAME, image file $1$DIA0:[SYS0.SYSCOMMON.][SYSLIB]SMGSHR.EXE;1
-SYSTEM-F-PRIVINSTALL, shareable images must be installed to run privileged image

This error is returned if I simply try to run install from the DCL prompt.

My problem is how do I install SMGSHR.EXE when the Install utility will not run without SMGSHR being installed.

This is a production system and I cannot simply reeboot at this time. I need a way to do this without rebooting. THIS IS URGENT.
Once it's in production it's all bugs after that.
12 REPLIES
Karl Rohwedder
Honored Contributor

Re: URGENT Problem Installing Images

Phillip,

I have no VMS at my hands at the moment, but
how did you try to install SMGSHR?

Check SYS$MANAGER:VMSIMAGES.DAT, e.g.
SEARCH VMSIMAGES.DAT SMGSHR on how VMS would install it during boot.

regards Kalle
Phillip Thayer
Esteemed Contributor

Re: URGENT Problem Installing Images

I did that and then tried to use the INSTALL utility to re-install SMGSHR.EXE as a sharable privileged image and that is when I got the error.

What I need to know is how to install the image without requiring the SMGSHR.EXE sharable image.

Phil
Once it's in production it's all bugs after that.
Daniel Fernandez Illan
Trusted Contributor

Re: URGENT Problem Installing Images

Hi.
You execute INSTALL command?
Are you check to execute $MC INSTALL and after install SMGSHR image as Kalle say? (using options in VMSIMAGES.DAT
Goog luck.
Saludos.
Daniel.

Phillip Thayer
Esteemed Contributor

Re: URGENT Problem Installing Images

The install utility will not run unless it has the SMGSHR.EXE installed. To install the SMGSHR.EXE I need to run the install utility but to run the install utility I need to have SMGSHR.exe ....You get the idea. How do I run INSTALL without the SMGSHR.EXE requirement?

Phil
Once it's in production it's all bugs after that.
Uwe Zessin
Honored Contributor
Solution

Re: URGENT Problem Installing Images

I wonder if INSTALL.EXE is installed (with privileges), too. In that case you can't run INSTALL, because it requires SMGSHR to be installed, no?

I'd try two things:
- run INSTALL.EXE;? (specify the version number)

- make a COPY of INSTALL.EXE and try to run this image
.
Arch_Muthiah
Honored Contributor

Re: URGENT Problem Installing Images

Phillip,

So my suggestion would be start with give REMOVE/delete command again. So the imageâ  s entry on the KNOWN FILE LIST and any GBL sections created for the image are freed.

The try this...
INSTAL> delete smgshr.exe
INSTAL> add smgshr.exe/authpriv=(priv-name,,)

or try this

INSTAL> add smgshr.exe / shared=address_data

Note the image should be in sys$system.

see this link...
http://h71000.www7.hp.com/doc/82FINAL/aa-pv5nj-tk/00/00/49-con.html#instal-priv-shar


Thanks
Archunan
Regards
Archie
Karl Rohwedder
Honored Contributor

Re: URGENT Problem Installing Images

Phillip,

you must run the INSTALL manually without invoking the installed one.

Try

$ run sys$sysdevice:[vms$common.sysexe]install
install> sys$share:smgshr/open/heade/share=addree/resi
install> ctrl/Z

regards Kalle
Phillip Thayer
Esteemed Contributor

Re: URGENT Problem Installing Images

O.K. So there is a reason why Uwe has that neat little symbol next to his posts. He understood exactly what the problem was and gave me the answer. When I run the INSTALL.EXE with the version number it worked and I was able to install the SMGSHR.EXE as well as all the other installed images. Once I was able to get INSTALL to run I defined sys$input to SYS$MANAGER:VMSIMAGES.DAT and ran install and it quickly installed all the images in VMSIMAGES.DAT. Now I am only left with installing all of our application files.

Great work Uwe. Thanks a million for this one.
Once it's in production it's all bugs after that.
Phillip Thayer
Esteemed Contributor

Re: URGENT Problem Installing Images

I assigned points to the responses from everyone. Once again, thanks Uwe.
Once it's in production it's all bugs after that.
Uwe Zessin
Honored Contributor

Re: URGENT Problem Installing Images

Glad it worked for you !! I've stumbled across this 'feature' (";") in my VAX/VMS V4 days by accident ;-)

It is just a variation of Karl's trick: fool the image activator.
.
Wim Van den Wyngaert
Honored Contributor

Re: URGENT Problem Installing Images

Nice job master Uwe.

Wim
Wim
Uwe Zessin
Honored Contributor

Re: URGENT Problem Installing Images

Excuse me, but what is that supposed to mean?
.