HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

VMS Installation on rx2660

 
Martin Vorlaender
Honored Contributor

VMS Installation on rx2660

Hi!

There's this shiny brand-new rx2660 waiting for VMS to be installed. Thing is: it came with Windows (eeek!) so there's no FIS kit on the built-in SAS disk.

But when I boot the VMS 8.3 OE DVD from the (USB!) DVD drive, this results in:

fs0:\EFI\BOOT> bootia64 -flags 0,30001
VMS_LOADER, Jul 10 2006 15:28:42
Boot Variables: System Root 0, Boot Flags 30001
Boot Device: Acpi(HWP0002,0,PNP0A03)/Pci(2|1)/Usb(0, 0)/CDROM(Entry0)
IPB allocated at: 0x0000000004000000
SYSBOOT allocated at: 0x0000000008000000
Memorydisk allocated at:0x0000000010000000
Initializing memory disk. Allocation size: 0x4000000
Mounting system disk
Loading boot file list from: [VMS$COMMON.SYS$LDR]SYS$MEMORYDISK.DAT;1
...
%SYSINIT-I-STACONFIG, STACONFIG finished
%SYSINIT-I-INIT, initializing the XQP
%SYSINIT-I-MOUNT, mounting the system disk
%SYSTEM-I-MOUNTVER, DNA0: is offline. Mount verification in progress.

%SYSTEM-I-MOUNTVER, DNA0: has completed mount verification.

with the mount verification messages repeated over and over until everything grinds to a halt.

I have it now installed (by transfering a PC-created DVD image file via a Tru64 box to an EVA disk and booting from there - still amazed that it worked!), but out of curiosity: has anyone seen this? Any ideas how to boot the USB DVD drive?

cu,
Martin
6 REPLIES
Hoff
Honored Contributor

Re: VMS Installation on rx2660

There were some oddities around booting off of USB from time to time; it was very dependent on the low-level disk structures, and I recall chasing these around for various cases. (When last I knew, the issues had not been isolated nor resolved, and the USB DVD I/O boot path was not considered supported. This may well have changed.)

There is not the level of consistency across DVD drives you might expect or might desire -- some of the drives I've worked with had, well, rather massive problems. The volume of required USB bus traffic for certain USB-connected DVD drives around application-level recovery traffic was, well, staggering. I've personally seen some USB DVD drives that I would consider utter junk.

I'd be tempted to connect into an external SCSI array and transfer the distro over that way. This assumes your rx2660 has an external SCSI adapter. Or use one of the new disk bricks, if you have a shelf of these on another system.

As for recording CD or DVD media for use with (or for recording on) OpenVMS, here are some details: http://64.223.189.234/node/28

Stephen Hoffman
HoffmanLabs LLC


jrd
Advisor

Re: VMS Installation on rx2660

VMS V8.3 doesn't fully support the rx2660 out of the box. Since you didn't obtain VMS Factory-Installed Software (FIS), you'll need to install some VMS patches.

Please refer to this rx2660 errata document:
http://www.docs.hp.com/en/5991-8664/5991-8664.pdf

Even without patches, the V8.3 DVD is supported for booting this system. We tested this very extensively in VMS engineering before we released rx2660. It should just work, with no special actions required.

There may be a problem with your DVD drive, with your VMS DVD, or some odd configuration problem that's not apparent from your description.
Martin Vorlaender
Honored Contributor

Re: VMS Installation on rx2660

A new data point:

On an OpenVMS Alpha V7.3-2, the 8.3 documentation CD is shown as

Disk xxx$DQA1:, device type Compaq CRD-8402B
...
Total blocks 812312

whereas the rx2660 under OpenVMS I64 V8.3 Update2, it's reported as

Disk xxx$DNA0:, device type TEAC DV-28E-N
...
Total blocks 3249232

I guess there's a problem with the DN driver in conjunction with this drive which also could affect mounting the DVD during installation.

If I can get my hands on some external USB DVD drive, I'll do further tests.

cu,
Martin
Heuser-Hofmann
Frequent Advisor

Re: VMS Installation on rx2660

Martin,

did you read the errata notes:

http://www.docs.hp.com/en/5991-8664/5991-8664.pdf

I just tested the boot via USB on my zx2000.
This boot went OK.

Eberhard
Martin Vorlaender
Honored Contributor

Re: VMS Installation on rx2660

Eberhard,

I did of course read the errata. All the ECOs mentioned are contained in UPDATE V2.0.

That does not have any impact on the statement that an rx2660 should be able to successfully boot from the VMS I64 OE DVD.

I suppose the problem has to do with the TEAC DVD drive used. It could also be the case that the machine has some other hardware problem, tough I haven't seen any indication of such while running VMS for some time.

cu,
Martin
Martin Vorlaender
Honored Contributor

Re: VMS Installation on rx2660

Unfortunately, the rx2660 has been rented out, so I don't have any chance to follow the issue for now.