Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

VMS RCP service

 
SOLVED
Go to solution
hf.yao
Occasional Advisor

VMS RCP service

hi, i am configuring R service on one VMS server and try to access it from another vms machine.
I enabled RSH and REXEC of TCP/IP on the server.
And when i access from another machine, RSH works fine but RCP always gets errors.

>rsh 10.40.247.63 /user=abc/pass=support dir
this command gets dir result successfully.

>rcp /user=abc/pass=support x.dat "10.40.247.63":"x.dat"
%RCP-E-REMERR, Remote error received

>rcp /user=abc/pass=support "10.40.247.63":"x.dat" x.dat
%DCL-W-IVKEYW, unrecognized keyword - check validity and spelling

Is there anything special for RCP configuration?
here i list the RSH service detail
TCPIP> show serv rsh/full

Service: RSH
State: Enabled
Port: 514 Protocol: TCP Address: 0.0.0.0
Inactivity: 5 User_name: not defined Process: TCPIP$RSH
Limit: 300 Active: 0 Peak: 8

File: TCPIP$SYSTEM:TCPIP$RSH_RUN.COM
Flags: Aprox Case Listen Proxy Rexe IPv6

Socket Opts: Rcheck Scheck
Receive: 0 Send: 0

Log Opts: Acpt Actv Dactv Conn Error Exit Logi Logo Mdfy Rjct TimO Addr
File: not defined

Separators:
Port: 0 User_name: 0 Password: 0 Command: 0

Security
Reject msg: not defined
Accept host: 0.0.0.0
Accept netw: 0.0.0.0

TCPIP> sh serv rexec /full

Service: REXEC
State: Enabled
Port: 512 Protocol: TCP Address: 0.0.0.0
Inactivity: 5 User_name: not defined Process: TCPIP$REXEC
Limit: 300 Active: 0 Peak: 3

File: TCPIP$SYSTEM:TCPIP$REXEC_RUN.COM
Flags: Aprox Listen Rexe IPv6

Socket Opts: Rcheck Scheck
Receive: 0 Send: 0

Log Opts: Acpt Actv Dactv Error Exit Mdfy Rjct TimO Addr
File: not defined

Separators:
Port: 0 User_name: 0 Password: 0 Command: 0

Security
Reject msg: not defined
Accept host: 0.0.0.0
Accept netw: 0.0.0.0

And another question is how configure on the client machine the remoter server ip as a host name? then i can use server name instead of ip addr in the commands.
3 REPLIES
Steven Schweda
Honored Contributor
Solution

Re: VMS RCP service

> [...] one VMS server [...]

> [...] another vms machine. [...]

Not very detailed descriptions of anything.

tcpip show version

Commands like your work for me. Are you
getting any OPCOM messages on the console of
the server system? (Or recorded in
"SYS$MANAGER:OPERATOR.LOG"?)

> [...] how configure on the client machine
> the remoter server ip as a host name?

Using DNS or the local HOSTS data base? For
the local HOSTS data base:

tcpip help set host
hf.yao
Occasional Advisor

Re: VMS RCP service

Thanks steven.
I got the answer. Because the VMS client machine used TCPWARE instead of TCPIP. Need add one qualifier /NOVMS in the RCP command.
hf.yao
Occasional Advisor

Re: VMS RCP service

thanks