Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Will the new version of SSL on VMS run in FIPS 140-2 mode?

Paul Gessling_2
Occasional Visitor

Will the new version of SSL on VMS run in FIPS 140-2 mode?

In a recent thread, Srividhya Subramanian, stated that the next version of OpenVMS SSL will be based on OpenSSL V0.9.8h.

Will this version run in a FIPS mode, and if so will I be able to claim that this version provides a FIPS 140-2 validated encryption module under certificate #1111 or #1051?

I currently have an application that uses the CDSA encryption library, but I need to be able to claim FIPS 140-2 validation.

Thanks in advance,
Paul
4 REPLIES
Hoff
Honored Contributor

Re: Will the new version of SSL on VMS run in FIPS 140-2 mode?

Until it's released and its standards-compliance is formally documented, you're probably going to end up starting a discussion directly with Srividhya Subramanian and (then) with the HP business manager that can provide a formal commitment for network security products.
Ian Miller.
Honored Contributor

Re: Will the new version of SSL on VMS run in FIPS 140-2 mode?

This question has been passed to people in HP who said they are working on an answer and will respond in a couple of days.
____________________
Purely Personal Opinion
Ian Miller.
Honored Contributor

Re: Will the new version of SSL on VMS run in FIPS 140-2 mode?

The response from the hp Product Manager is that this product is not currently certified but there are plans to look into this after V8.4 is released. If you have an urgent requirement then contact your HP support team.
____________________
Purely Personal Opinion
Paul Gessling_2
Occasional Visitor

Re: Will the new version of SSL on VMS run in FIPS 140-2 mode?

Thank you